Last Comment Bug 684716 - Consistent crash inside NVIDIA driver when zooming on Galaxy Tab 10.1 with GLES layers enabled
: Consistent crash inside NVIDIA driver when zooming on Galaxy Tab 10.1 with GL...
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks: opengl-mobile 683514
  Show dependency treegraph
 
Reported: 2011-09-05 08:07 PDT by Joe Drew (not getting mail)
Modified: 2011-09-09 11:43 PDT (History)
3 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Joe Drew (not getting mail) 2011-09-05 08:07:16 PDT
When I zoom in a lot on my Galaxy Tab, on basically any page, Fennec crashes inside the GL driver. Basically any zoom way in seems to do it for me.

bp-6aadb043-6a1e-41d5-bbd7-a6e772110903

(All the crashes at this location are probably me.)
Comment 1 Ali Juma [:ajuma] 2011-09-06 13:11:58 PDT
I can reproduce this on my Galaxy Tab in landscape orientation quite easily, but so far I've been unable to do so in portrait orientation.
Comment 2 Ali Juma [:ajuma] 2011-09-07 08:50:18 PDT
I cannot reproduce this using the September 1 nightly (rev. d772dfb96ba1) but I can in the September 2 nightly (rev. 0664108eb19d).

I can also reproduce this on the Xoom (with a more informative stack than what we're getting on the Galaxy Tab): bp-39e67446-7962-4fa4-bac4-917872110907
Comment 3 Ali Juma [:ajuma] 2011-09-07 11:15:04 PDT
This is a regression from Bug 683514 (which enabled the GL_EXT_unpack_subimage extension on Tegra 2 devices like the Galaxy Tab and Xoom).
Comment 4 Benoit Girard (:BenWa) 2011-09-07 14:43:04 PDT
Backout on inbound:
http://hg.mozilla.org/integration/mozilla-inbound/rev/4f3856dd4dd0
Comment 5 Ali Juma [:ajuma] 2011-09-09 11:43:01 PDT
This was resolved by backing out the patch causing the regression.

Note You need to log in before you can comment on or make changes to this bug.