Crash [@ js_ValueToBoolean(js::Value const&) ]

RESOLVED FIXED

Status

()

Core
JavaScript Engine
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: TinyButStrong, Assigned: jandem)

Tracking

({crash, regression})

Trunk
x86_64
Windows 7
crash, regression
Points:
---

Firefox Tracking Flags

(firefox9+)

Details

(Whiteboard: [qa-], crash signature)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0a1) Gecko/20110905 Firefox/9.0a1
Build ID: 20110905030839

Steps to reproduce:

Trying to login to localhost web admin interface of Software Kiwi Syslog Server, that is available only for licensed users.

For info http://www.kiwisyslog.com/kiwi-syslog-server-overview/


Actual results:

Crash Firefox.

Crash report: https://crash-stats.mozilla.com/report/index/bp-a0cb2631-75b5-4408-a2de-0e0d32110905


Expected results:

Not crash?!
(Reporter)

Comment 1

6 years ago
Software version used to report the problem was the latest to current date: 9.2.1

Updated

6 years ago
Assignee: nobody → general
Status: UNCONFIRMED → NEW
Crash Signature: [@ js_ValueToBoolean(js::Value const&) ]
Component: General → JavaScript Engine
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → general
Summary: js_ValueToBoolean(js::Value const&) → Crash [@ js_ValueToBoolean(js::Value const&) ]
(Reporter)

Comment 2

6 years ago
Ooops, the right crash report url is that one: https://crash-stats.mozilla.com/report/index/bp-e14e300f-4008-46a0-94d6-4256f2110905

Oh better, both are correct, but first one if from my current profile and second one is a new clean profile.
(Reporter)

Comment 3

6 years ago
The crash occur exactly after submit the login form.

Comment 4

6 years ago
TinyButStrong, since the login screen sounds like it's not easily accessible to others, could you use http://harthur.github.com/mozregression/ in order to determine when this bug was introduced?
(Reporter)

Comment 5

6 years ago
Already found:

Good build: http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2011-09-04-03-08-22-mozilla-central/

Bad build: http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2011-09-05-03-08-39-mozilla-central/

Comment 6

6 years ago
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a351ae35f2c4&tochange=2bb8c0b664cf
(Assignee)

Comment 7

6 years ago
Looks like a regression from bug 670493.

TinyButStrong, do you mind testing this build: ftp://ftp.mozilla.org/pub/firefox/tinderbox-builds/jaegermonkey-win32/1315303914/ ? Just to make sure the problem has not been fixed already on the JM branch. Thanks in advance.
Assignee: general → jandemooij
Status: NEW → ASSIGNED
(Assignee)

Updated

6 years ago
Keywords: crash, regression
(Assignee)

Updated

6 years ago
Blocks: 670493
(Reporter)

Comment 8

6 years ago
Yeah, today build fixed it. Lets mark as resolved.

Thanks Mooij!
(Assignee)

Comment 9

6 years ago
(In reply to TinyButStrong from comment #8)
> Yeah, today build fixed it. Lets mark as resolved.

Thanks! Just so I understand correctly, the build I linked to in comment 7 works OK and the latest mozilla-central nightly still crashes, right?

I will close this bug when crash-stats.mozilla.com confirms that all js_ValueToBoolean crashes are gone. Just in case there's another bug here :)
tracking-firefox9: --- → +
(Reporter)

Comment 10

6 years ago
My bad, you are right, mozilla-central still crashes.

I will use an alternative syslog server meanwhile.

Thanks to assist me.

Updated

6 years ago
Duplicate of this bug: 685081
(Assignee)

Comment 12

6 years ago
Crash-stats confirms that this has been fixed (and I can no longer reproduce bug 685081):

2011/09/05: 220
2011/09/06: 333
2011/09/07: 3
2011/09/08: 0
2011/09/09: 0
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Due to dependencies, qa-. Can someone who is already set up to reproduce this bug please verify the fix? Thanks
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.