Last Comment Bug 684818 - shift+tab fails on editable document after context menu is closed: enable mochitest
: shift+tab fails on editable document after context menu is closed: enable moc...
Status: RESOLVED FIXED
: access
Product: Core
Classification: Components
Component: Keyboard: Navigation (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: mozilla10
Assigned To: alexander :surkov
:
Mentors:
Depends on: 718235 673958
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-06 04:04 PDT by alexander :surkov
Modified: 2012-02-24 21:12 PST (History)
4 users (show)
surkov.alexander: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
testcase (377 bytes, text/html)
2011-09-06 04:04 PDT, alexander :surkov
no flags Details
patch (1.16 KB, patch)
2011-09-28 19:27 PDT, alexander :surkov
mzehe: review+
Details | Diff | Splinter Review

Description alexander :surkov 2011-09-06 04:04:37 PDT
Created attachment 558440 [details]
testcase

spun off bug 550338:

1. Focus the editable document.
2. Open context menu (press the applications key, shift+F10 or right click)
3. Dismiss context menu (press escape or alt key)
4. Press shift+tab
  Actual: Nothing happens.
Comment 1 alexander :surkov 2011-09-06 04:08:46 PDT
Neil's bug 550338 comment #8:
The second set of steps (5-9) look like an unrelated bug, which has to do with confusion over what should be focused in editable documents. Bug 544277 is an example of a bug related to this.
Comment 2 James Teh [:Jamie] 2011-09-26 19:02:32 PDT
Seems to be fixed in the last try build for bug 673958.
Comment 3 alexander :surkov 2011-09-28 02:29:17 PDT
fixed by bug 673958
Comment 4 alexander :surkov 2011-09-28 19:27:04 PDT
(In reply to alexander surkov from comment #3)
> fixed by bug 673958

It's really fixed but I bet that wasn't bug 673958.
Comment 5 alexander :surkov 2011-09-28 19:27:38 PDT
Created attachment 563274 [details] [diff] [review]
patch
Comment 6 Marco Zehe (:MarcoZ) on PTO until August 15 2011-09-28 23:12:10 PDT
Comment on attachment 563274 [details] [diff] [review]
patch

r=me. So which bug fixed this one?
Comment 7 Marco Zehe (:MarcoZ) on PTO until August 15 2011-09-29 08:19:37 PDT
This sounds awfully similar to bug 550338, which *was* fixed by bug 673958, so I think this is actually a dupe of bug 550338. The later steps of bug 550338 provide this exact testcase.
Comment 8 alexander :surkov 2011-09-29 08:27:22 PDT
(In reply to Marco Zehe (:MarcoZ) from comment #7)
> This sounds awfully similar to bug 550338

Marco, this bug is spun off the bug 550338 :), in other words, I filed it to keep  keyboard navigation issue separately from disability access problems. Eventually the problem was fixed (and our focus rework is not guilty of that). 

I'll enable mochitest to make sure it won't regress.
Comment 9 alexander :surkov 2011-10-03 08:22:49 PDT
landed on inbound https://hg.mozilla.org/integration/mozilla-inbound/rev/be9874f75bae

I disabled the test on linux since due to some reason shift + tab doesn't work on linux in this case.

Trevor, when you get some time then could you please check it and file new bug?
Comment 10 Matt Brubeck (:mbrubeck) 2011-10-03 16:56:26 PDT
https://hg.mozilla.org/mozilla-central/rev/be9874f75bae

Note You need to log in before you can comment on or make changes to this bug.