Empty groups with same name created over top of real groups

RESOLVED WONTFIX

Status

--
minor
RESOLVED WONTFIX
7 years ago
3 years ago

People

(Reporter: maytoss, Unassigned)

Tracking

7 Branch
x86
Windows Vista

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 558469 [details]
Panorama view with empty groups

See screenshot.

Originally, I thought the non-active groups weren't displaying their tabs at all (see bug 684763). After playing with it a bit more, however, I discovered what was actually going on: my actual tab groups were hidden underneath.

Somehow, Firefox (7.0b2) has created 3 new tab groups with the same name as 3 of the ones I created, and has placed them so that they overlap perfectly with my real groups. This is odd behaviour on numerous levels, not the least of which is the fact that usually groups resize themselves instead of overlapping!

I realise this bug report is more or less useless since I have no idea how to reproduce it, but I figure it's better to file *something* than nothing.
Thanks for reporting, Caitlin.

Can you reproduce the issue on your side while in Safe mode?
http://support.mozilla.com/en-US/kb/Safe+Mode
(Reporter)

Comment 2

7 years ago
Again, I don't know how to actually "replicate" it. But if I am in the screwy session and launch in safe mode from the Help menu, yes, it's still there.
From looking at the screenshot I guess that your session contains sensitive data. Is it somehow possible to create a reduced session (with maybe replaced tabs) that triggers this error? Some information about the structure of your failing session would be very helpful to tackle this.
Panorama has been removed from Firefox 45, currently in Beta and scheduled for release on March 7th. As such, I'm closing all existing Panorama bugs.

If you are still using Panorama, you will see a deprecation message in Firefox 44, and when 45 is released your tab group data will be migrated to bookmarks, with a folder for each group. There are also a few addons offering similar functionality.

See https://support.mozilla.org/en-US/kb/tab-groups-removal for more info.

We're removing Panorama because it has extremely low usage (about 0.01% of users), and has a large number of bugs and usability issues. The cost of fixing all those issues is far too high to justify, and so we'll instead be focusing our time and energy on improving other parts of Firefox.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

3 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.