Need To find default helper apps for *Protocols* from InternetConfig

VERIFIED DUPLICATE of bug 49758

Status

SeaMonkey
Preferences
VERIFIED DUPLICATE of bug 49758
17 years ago
14 years ago

People

(Reporter: Andrew Thompson, Assigned: Paul Chen)

Tracking

(Blocks: 1 bug)

Trunk
PowerPC
Mac System 9.x
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
See Control Panels->Internet->Advanced->Helper Apps.

Dialog maps system wide support for protocols (mailto:, telnet:) etc to helper 
applications used to process that protocol.

Need to be picking up these settings and using them as the default helper apps 
for those protocols (or at least any that Mozilla doesn't handle internally).
(Reporter)

Updated

17 years ago
Blocks: 5721
Summary: Need To find default helper apps *for* Protocols from InternetConfig → Need To find default helper apps for *Protocols* from InternetConfig
(Reporter)

Updated

17 years ago
Blocks: 68515
<*sigh*>. Please read the description of components before picking one. 
Preferences Backend is the raw mechanism of reading and setting prefs, nothing 
to do with specific prefs from any particular subsystems.

pchen seems to have others of this kind of bug, assigning to him. (how is this 
not a duplicate of 68515? You've listed it as blocking that one)
Assignee: dveditz → pchen
Component: Preferences: Backend → Preferences
(Reporter)

Comment 2

17 years ago
Um, I think maybe you missed the point of this bug, which is actually my fault
as the description is quite terse.

This says: preferences for protocols should be read from (and I guess written
to) the operating system provided Internet Config database on Mac OS, instead of
Mozilla maintaining its own list. This is preference backend to my mind, and I
believe it also fits your description, but I'll leave the component as it is for
now. Also the bug I'm breaking this out of  (5721, which is the overall "Support
Internet Config" bug) is "Preferences : Back End" and has been for years,
actually, I just copied that...

The reason this isn't a dupe of 68515 is that that bug says "once we have a
working backend implementation (this bug), we need some UI to let the user
actually change the prefs". This is not a facile comment - IE5 (and IIRC Nav4)
on Mac OS actually query the operating system to find the right icons and
descriptions to display for some of these sorts of settings - but that's why I
made a seperate bug.

I'm aware I spammed a few people over the weekend with these new bugs, and for
that I apologise, but 5721 covering *14* different preferences which need to be
fetched from Internet Config seemed to break the golden "1 problem to 1 bug
number" rule quite badly.
(Reporter)

Comment 3

17 years ago
Apologies: this one is indeed a dupe - I don't believe the other 2 are though.

I did spend some time looking first as it seemed unlikely that 5721 was all
there was, but I wasn't searching using "pchen@netscape.com"




*** This bug has been marked as a duplicate of 49758 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
zap
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.