Closed Bug 68525 Opened 24 years ago Closed 21 years ago

javascript strict warnings in mailWindowOverlay.js

Categories

(SeaMonkey :: MailNews: Message Display, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bugzilla, Assigned: ssu0262)

References

Details

Attachments

(3 obsolete files)

JavaScript strict warning:
chrome://messenger/content/mailWindowOverlay.js line 381: assignment to undeclar
ed variable destUri

JavaScript strict warning:
chrome://messenger/content/mailWindowOverlay.js line 382: assignment to undeclar
ed variable destResource

JavaScript strict warning:
chrome://messenger/content/mailWindowOverlay.js line 383: assignment to undeclar
ed variable destMsgFolder
Taking from sspitzer, I've got a patch coming up...
Assignee: sspitzer → hwaara
Whiteboard: fix in hand
r=timeless
Keywords: approval, patch
Seth, please sr= these small changes. Thanks!
sr=alecf
sorry for the delay.  

thanks for helping me out, alecf.

these changes look good.  I'll land them today.
fixed
Status: NEW → RESOLVED
Closed: 24 years ago
Resolution: --- → FIXED
Why are these suddenly seen again in build 2001032508 ?

JavaScript strict warning:
chrome://messenger/content/mailWindowOverlay.js line 447: assignment to undeclar
ed variable destUri

JavaScript strict warning:
chrome://messenger/content/mailWindowOverlay.js line 448: assignment to undeclar
ed variable destResource

JavaScript strict warning:
chrome://messenger/content/mailWindowOverlay.js line 449: assignment to undeclar
ed variable destMsgFolder
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
sr=sspitzer

the original fix must have changes must have gotten stomped by the mailnews perf 
branch landing.
need r= to checkin...
r=timeless
Status: REOPENED → RESOLVED
Closed: 24 years ago23 years ago
Resolution: --- → FIXED
Whiteboard: fix in hand
Fix checked in.
QA Contact: esther → stephend
Where am I supposed to see these errors?  I looked at hwaara's first patch,
looks like if I copy message and move messages, correct?
I copied and moved 5 messages to both local folders and IMAP folders, didn't see
any warnings.  If that's the case, then I can mark this verified, just let me
know, thanks.
verified.
Status: RESOLVED → VERIFIED
Whenever there is new functionality there's new js warnings!
Please add the following line to your prefs.js file, so we could avoid all the 
strict warning fixup...:
user_pref("javascript.options.strict", true);

Build 20010708:

Warning: redeclaration of var folder
Source File: chrome://messenger/content/mailWindowOverlay.js
Line: 467, Column: 10

Warning: function PromptGetMessagesOffline does not always return a value
Source File: chrome://messenger/content/mailWindowOverlay.js
Line: 1199

Warning: function PromptSendMessagesOffline does not always return a value
Source File: chrome://messenger/content/mailWindowOverlay.js
Line: 1219
Status: VERIFIED → REOPENED
Keywords: approval, patch
Resolution: FIXED → ---
It's a simple fix, but I'm tired of cleaning after others.

Mohan's big patch caused this. Reassign.
Assignee: hwaara → mohanb
Status: REOPENED → NEW
reassigning to ssu.
Assignee: mohanb → ssu
Comment on attachment 46660 [details] [diff] [review]
(Bv1)

r=ssu for stephend's patch
Attachment #46660 - Flags: review+
Comment on attachment 46660 [details] [diff] [review]
(Bv1)

>Index: mailWindowOverlay.js
>===================================================================
>RCS file: /cvsroot/mozilla/mailnews/base/resources/content/mailWindowOverlay.js,v
>retrieving revision 1.81
>diff -u -r1.81 mailWindowOverlay.js
>--- mailWindowOverlay.js	2001/08/15 05:07:10	1.81
>+++ mailWindowOverlay.js	2001/08/21 21:59:24
>@@ -432,6 +432,7 @@
>       GetMessagesForAllAuthenticatedAccounts();
>     }
>   }
>+  return true;

I don't trust my returns on this.  

> }
> 
> /**
>@@ -463,7 +464,7 @@
> function MsgGetNextNMessages()
> {
>   if(CheckOnline()) {
>-    var folder = GetFirstSelectedMsgFolder();
>+    folder = GetFirstSelectedMsgFolder();

This is already fixed in the trunk.

>     if(folder) 
>       GetNextNMessages(folder);
>   }
>@@ -1250,6 +1251,7 @@
>       return buttonPressed.value;
>     }
>   }
>+  return true;

I don't trust my return on this, either.

> }
> 
> function GetFolderMessages()
Attachment #46660 - Attachment is obsolete: true
Attachment #46660 - Flags: review+
Here's some more:

Warning: reference to undefined property
Components.classes['@mozilla.org;timeline-service;1']
Source File: chrome://messenger/content/mailWindowOverlay.js
Line: 34

Error: Components.classes['@mozilla.org;timeline-service;1'] has no properties
Source File: chrome://messenger/content/mailWindowOverlay.js
Line: 34

*** Bug 119250 has been marked as a duplicate of this bug. ***
in 20020326 we have:
Warning: function PromptGetMessagesOffline does not always return a value
Source File: chrome://messenger/content/mailWindowOverlay.js
Line: 1448
Source Code:
}

Warning: function PromptSendMessagesOffline does not always return a value
Source File: chrome://messenger/content/mailWindowOverlay.js
Line: 1468
Source Code:
}
Attachment #28791 - Attachment is obsolete: true
Attachment #25027 - Attachment is obsolete: true
Attachment #25027 - Attachment description: [Patch] Fixing the errors this bug's about, but also some other errors I spotted and some general code cleanup. → [Patch] Fixing the errors this bug's about, but also some other errors I spotted and some general code cleanup. [Checked in: Comment 7]
Attachment #28791 - Attachment description: fix for the new errors. please r=, sr= → fix for the new errors. please r=, sr= [Checked in: Comment 13]
Attachment #25027 - Attachment description: [Patch] Fixing the errors this bug's about, but also some other errors I spotted and some general code cleanup. [Checked in: Comment 7] → (Av1) Fixing the errors this bug's about, but also some other errors I spotted and some general code cleanup. [Checked in: Comment 7]
Attachment #28791 - Attachment description: fix for the new errors. please r=, sr= [Checked in: Comment 13] → (Av2) fix for the new errors. please r=, sr= [Checked in: Comment 13]
Comment on attachment 46660 [details] [diff] [review]
(Bv1)


The |folder| warning was bug 100906...

The "return a value" warnings were fixed by bug 128905.
Attachment #46660 - Attachment description: Patch → (Bv1)
Status: NEW → RESOLVED
Closed: 23 years ago21 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: