Closed Bug 685279 Opened 10 years ago Closed 7 months ago

New message notifications show top-most unread messages w/o regard to sort order

Categories

(Thunderbird :: General, defect)

6 Branch
x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 375717

People

(Reporter: todd_lewis, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (X11; Linux i686; rv:6.0) Gecko/20100101 Firefox/6.0
Build ID: 20110816220020

Steps to reproduce:

Sort Inbox by Date with newest messages at the bottom, then wait for a new message to arrive.


Actual results:

New mail arrives, and a message notification pops up, and shows the top-most unread messages -- i.e. the oldest unread messages in the inbox (those toward the top), not the newly arrived ones (the ones on the bottom of the list).


Expected results:

The new message notification should have been built using the most recent unread/unseen messages. To do that, it would need to pay attention to whether messages are sorted by ascending or descending data. Evidently it always takes the one(s) on top.
Yes, I have also noticed this. Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Blocks: biff

Should be fixed by bug 375717 after that will have reached release.

Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 375717
You need to log in before you can comment on or make changes to this bug.