Last Comment Bug 685302 - Use "website" instead of "web site" consistently across all strings in the UI
: Use "website" instead of "web site" consistently across all strings in the UI
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 9
Assigned To: :Margaret Leibovic
:
Mentors:
: 315987 385452 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-07 14:04 PDT by Matej Novak [:matej]
Modified: 2011-09-15 08:16 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch for dnt pref (1.85 KB, patch)
2011-09-08 12:14 PDT, :Margaret Leibovic
dao+bmo: review-
Details | Diff | Review
just change string for dnt pref (1.07 KB, patch)
2011-09-08 12:41 PDT, :Margaret Leibovic
dao+bmo: review+
Details | Diff | Review
change "web site" to "website" in all strings (44.18 KB, patch)
2011-09-13 13:50 PDT, :Margaret Leibovic
dao+bmo: review+
Details | Diff | Review

Description Matej Novak [:matej] 2011-09-07 14:04:28 PDT
In Preferences->Privacy->Tracking, "websites" should be one word next to the DNT check box: "Tell websites I do not want to be tracked"
Comment 1 :Margaret Leibovic 2011-09-07 14:17:51 PDT
It would be an easy fix to change this one string, but we seem to use both "website" and "web site" all over the product, and it looks like there more instances of "web site":

http://mxr.mozilla.org/mozilla-central/search?string=website&find=locale&findi=&filter=%5E%5B%5E%5C0%5D*%24&hitlimit=&tree=mozilla-central
http://mxr.mozilla.org/mozilla-central/search?string=web+site&find=locale&findi=&filter=%5E%5B%5E%5C0%5D*%24&hitlimit=&tree=mozilla-central

What's the right thing to do? Is this a problem we want to solve more generally?
Comment 2 Matej Novak [:matej] 2011-09-07 14:25:30 PDT
Would be great to be consistent throughout. "Website" is our style for Mozilla communications, so that would be my strong preference. Is it realistic to change it everywhere?
Comment 3 :Margaret Leibovic 2011-09-08 11:55:50 PDT
I'd be in favor of a cleanup, at least starting with the more common strings. I'm cc'ing Limi to see what he thinks.
Comment 4 :Margaret Leibovic 2011-09-08 12:00:43 PDT
Also cc'ing l10n because I'm curious how localizers treat "website" vs. "web site". If they're treated differently, perhaps this would also be a good time to clean up those translations.
Comment 5 Guillermo López :willyaranda (probably SLOW response) 2011-09-08 12:02:36 PDT
For es-ES both have the same translation, is there any difference in English?
Comment 6 Matej Novak [:matej] 2011-09-08 12:06:04 PDT
(In reply to Guillermo López (:willyaranda) from comment #5)
> For es-ES both have the same translation, is there any difference in English?

No difference in English. It's just a matter of style.
Comment 7 Francesco Lodolo [:flod] 2011-09-08 12:08:48 PDT
(In reply to Guillermo López (:willyaranda) from comment #5)
> For es-ES both have the same translation, is there any difference in English?

Same thing in Italian, and honestly it seems quite strange having two different translations for "web sites" and "websites".
Comment 8 Matej Novak [:matej] 2011-09-08 12:12:05 PDT
(In reply to flod (Francesco Lodolo) from comment #7)
> (In reply to Guillermo López (:willyaranda) from comment #5)
> > For es-ES both have the same translation, is there any difference in English?
> 
> Same thing in Italian, and honestly it seems quite strange having two
> different translations for "web sites" and "websites".

I'm pretty curious. My guess is that it's the same, given the ubiquity of the Web, but I can also imagine a language where there might be subtle differences in how the two words would be translated vs. just one.
Comment 9 :Margaret Leibovic 2011-09-08 12:14:47 PDT
Created attachment 559238 [details] [diff] [review]
patch for dnt pref

Here's a patch for the DNT pref. Matej, if we take this patch, will you be communicating this change to people who include screenshots of this pref pane in their communications materials, like the new DNT Field Guide?
Comment 10 Dão Gottwald [:dao] 2011-09-08 12:17:43 PDT
Comment on attachment 559238 [details] [diff] [review]
patch for dnt pref

You don't need a new entity name for this.
Comment 11 Axel Hecht [:Pike] 2011-09-08 12:24:31 PDT
Yeah, what dao says. We can do a a post in .l10n in addition to the communication in this bug to ask people to be consistent.

Also, looking at http://www.frenchmozilla.fr/transvision/index.php?recherche=web+sites&locale=fr&repo=aurora&regular=regular, we're having a bigger problem with web sites ;-)
Comment 12 Matej Novak [:matej] 2011-09-08 12:35:37 PDT
(In reply to Margaret Leibovic [:margaret] from comment #9)
> Created attachment 559238 [details] [diff] [review]
> patch for dnt pref
> 
> Here's a patch for the DNT pref. Matej, if we take this patch, will you be
> communicating this change to people who include screenshots of this pref
> pane in their communications materials, like the new DNT Field Guide?

I'll have to figure out the best way to do that, but yes, I'll make sure we're using the correct screenshot from here on out. When would that make its way into the browser?
Comment 13 :Margaret Leibovic 2011-09-08 12:41:47 PDT
Created attachment 559251 [details] [diff] [review]
just change string for dnt pref
Comment 14 :Margaret Leibovic 2011-09-08 12:42:53 PDT
(In reply to Matej Novak [:matej] from comment #12)
> (In reply to Margaret Leibovic [:margaret] from comment #9)
> > Created attachment 559238 [details] [diff] [review]
> > patch for dnt pref
> > 
> > Here's a patch for the DNT pref. Matej, if we take this patch, will you be
> > communicating this change to people who include screenshots of this pref
> > pane in their communications materials, like the new DNT Field Guide?
> 
> I'll have to figure out the best way to do that, but yes, I'll make sure
> we're using the correct screenshot from here on out. When would that make
> its way into the browser?

If this gets reviewed it would be in Nightly very soon, on the Firefox 9 train.
Comment 15 Dão Gottwald [:dao] 2011-09-08 12:45:14 PDT
Comment on attachment 559251 [details] [diff] [review]
just change string for dnt pref

Not much to review here anymore. Maybe this should get a ui-review.

What's this about?
> exporting patch:
> <fdopen>
Comment 16 Robert Kaiser (not working on stability any more) 2011-09-08 13:46:10 PDT
FYI, we have an open bug for switching everything consistently to "website" in the browser, but so far I think we don't have anyone who did a patch for that.
I did this for SeaMonkey some time ago, but I think int Firefox we still have inconsistent mentions of "site", "web site" and "website" even though the latter should be used ideally.
Comment 17 Matej Novak [:matej] 2011-09-08 15:02:25 PDT
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #16)
> FYI, we have an open bug for switching everything consistently to "website"
> in the browser, but so far I think we don't have anyone who did a patch for
> that.
> I did this for SeaMonkey some time ago, but I think int Firefox we still
> have inconsistent mentions of "site", "web site" and "website" even though
> the latter should be used ideally.

Good to hear. Definitely should be "website" where possible, but "site" can also be used if space is an issue (as I imagine it might be for mobile).
Comment 18 Tim Maks van den Broek [:mad_maks] 2011-09-09 00:00:43 PDT
in dutch everything is translated as website
Comment 19 :Margaret Leibovic 2011-09-13 13:17:13 PDT
(In reply to Dão Gottwald [:dao] from comment #15)
> Comment on attachment 559251 [details] [diff] [review]
> just change string for dnt pref
> 
> Not much to review here anymore. Maybe this should get a ui-review.

Limi told me that he was in favor of making this change everywhere.

> What's this about?
> > exporting patch:
> > <fdopen>

I'm not sure what's up with that. It looks like my system adds that when I pipe the output of hg export to a file.
Comment 20 :Margaret Leibovic 2011-09-13 13:50:25 PDT
Created attachment 560029 [details] [diff] [review]
change "web site" to "website" in all strings

I just did a string replace on all .dtd and .properties files. I looked through the patch to make sure there weren't any unwanted changes, and it looks good to me, but I think this is big enough that another set of eyes wouldn't hurt :)
Comment 21 Dão Gottwald [:dao] 2011-09-13 13:58:34 PDT
Comment on attachment 560029 [details] [diff] [review]
change "web site" to "website" in all strings

>--- a/browser/locales/en-US/chrome/browser/preferences/privacy.dtd
>+++ b/browser/locales/en-US/chrome/browser/preferences/privacy.dtd

>-<!ENTITY  rememberDescription.label      "&brandShortName; will remember your browsing, download, form and search history, and keep cookies from Web sites you visit.">
>+<!ENTITY  rememberDescription.label      "&brandShortName; will remember your browsing, download, form and search history, and keep cookies from Websites you visit.">

This should be "websites" (lowercase). r=me with that
Comment 23 Robert Kaiser (not working on stability any more) 2011-09-14 09:46:05 PDT
So this is basically either a dependency or even a dupe of bug 385452 now? We should mark those bugs in bugzilla somehow to belong together in some way...
Comment 24 :Margaret Leibovic 2011-09-14 11:36:20 PDT
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #23)
> So this is basically either a dependency or even a dupe of bug 385452 now?
> We should mark those bugs in bugzilla somehow to belong together in some
> way...

Oops, I didn't know that bug existed. I'm going to dupe it to this one, since this is where we made the patch.
Comment 25 :Margaret Leibovic 2011-09-14 11:36:38 PDT
*** Bug 385452 has been marked as a duplicate of this bug. ***
Comment 26 :Margaret Leibovic 2011-09-14 11:40:02 PDT
*** Bug 315987 has been marked as a duplicate of this bug. ***
Comment 27 :Margaret Leibovic 2011-09-14 12:18:28 PDT
https://hg.mozilla.org/mozilla-central/rev/846f2fbc4110
Comment 28 Daniel Cater 2011-09-15 08:16:08 PDT
See bug 249231 and various others for some background on this. http://en.wikipedia.org/wiki/Website#Spelling and the sources listed there seem to suggest that "website" is the way forward.

Note You need to log in before you can comment on or make changes to this bug.