Last Comment Bug 685347 - Context menu selections in URL bar removes focus on the URL bar
: Context menu selections in URL bar removes focus on the URL bar
Status: VERIFIED FIXED
: regression
Product: Fennec Graveyard
Classification: Graveyard
Component: General (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: Firefox 9
Assigned To: Wesley Johnston (:wesj)
:
Mentors:
: 685504 687004 687374 (view as bug list)
Depends on:
Blocks: 684710
  Show dependency treegraph
 
Reported: 2011-09-07 15:58 PDT by Naoki Hirata :nhirata (please use needinfo instead of cc)
Modified: 2011-09-19 10:00 PDT (History)
11 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Patch (985 bytes, patch)
2011-09-08 13:52 PDT, Wesley Johnston (:wesj)
mbrubeck: review+
Details | Diff | Splinter Review

Description Naoki Hirata :nhirata (please use needinfo instead of cc) 2011-09-07 15:58:52 PDT
1. tap in the URL bar
2. tap again to remove the highlight and place the cursor in the URL bar
3. long tap on the URL bar to bring out the context menu
4. select Select All

Expected: everything in the URL bar is highlighted, VKB is still out, and the focus is still on the URL bar

Actual: VKB dismisses, focus is no longer on the URL bar.

Note:
Mozilla/5.0 (Android; Linux armv7I; rv9.0a1) Gecko/20110907 Firefox/9.0a1 Fennec/9.0a1
Comment 1 Naoki Hirata :nhirata (please use needinfo instead of cc) 2011-09-07 15:59:49 PDT
Toshiba Thrive 3.1, HTC Flyer 2.3
With TabletUI turned on
Comment 2 Aaron Train [:aaronmt] 2011-09-08 06:33:07 PDT
*** Bug 685504 has been marked as a duplicate of this bug. ***
Comment 3 Cristian Nicolae (:xti) 2011-09-08 06:41:03 PDT
Practically there is the same result for all Awesomescreen/Context Menu options. If I tap on "Paste" option, for example, and I do not release the finger on the screen, I've noticed that in background the Awesomescreen is dismissed and the app goes to the mainview. 

--
Build ID: Mozilla/5.0 (Android;Linux armv7l;rv:9.0a1)Gecko/20110908
Firefox/9.0a1 Fennec/9.0a1
Device: Samsung Galaxy S
OS: Android 2.2
Comment 4 Cristian Nicolae (:xti) 2011-09-08 06:45:58 PDT
Is this issue related to Bug 684710?
Comment 5 Carla Nadastean 2011-09-08 06:52:07 PDT
Bug not reproducible with:
Mozilla/5.0 (Android;Linux armv7l;rv:9.0a1)Gecko/20110902
Firefox/9.0a1 Fennec/9.0a1
http://hg.mozilla.org/mozilla-central/rev/ce43a8644bc0

Bug reproducible with:
Mozilla/5.0 (Android;Linux armv7l;rv:9.0a1)Gecko/20110903
Firefox/9.0a1 Fennec/9.0a1
http://hg.mozilla.org/mozilla-central/rev/472716252ea3

Possible range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ce43a8644bc0&tochange=472716252ea3
Comment 6 Aaron Train [:aaronmt] 2011-09-08 06:53:56 PDT
(In reply to Cristian Nicolae (:xti) from comment #4)
> Is this issue related to Bug 684710?

Very well could be (same actual result)
Comment 7 Wesley Johnston (:wesj) 2011-09-08 13:52:58 PDT
Created attachment 559277 [details] [diff] [review]
Patch

This is because of the hacky way I implemented hiding the urlbar when the user taps outside of it. Sometimes, even though the user tapped outside, we should not hide the bar.

This is a quick fix, although I think maybe I should look into a cleaner one. Perhaps we can look for an element with a particular class (like modal-block)?
Comment 8 Martijn Wargers [:mwargers] (not working for Mozilla) 2011-09-15 16:40:21 PDT
I assume the patch can be checked in, right?
Comment 9 Aaron Train [:aaronmt] 2011-09-15 19:59:43 PDT
*** Bug 687004 has been marked as a duplicate of this bug. ***
Comment 10 Ed Morley [:emorley] 2011-09-16 02:02:45 PDT
Bug number added to commit message, pushed to inbound:
https://hg.mozilla.org/integration/mozilla-inbound/rev/17f7d5184d5a
Comment 12 Aaron Train [:aaronmt] 2011-09-18 21:47:43 PDT
*** Bug 687374 has been marked as a duplicate of this bug. ***
Comment 13 Cristian Nicolae (:xti) 2011-09-19 08:25:01 PDT
Verified fixed on:
Mozilla/5.0 (Android;Linux armv7l;rv:9.0a1)Gecko/20110919
Firefox/9.0a1 Fennec/9.0a1
Device: Samsung Galaxy S
OS: Android 2.2

Note You need to log in before you can comment on or make changes to this bug.