in a thread where mails have different subjects, show non-empty subject as thread subject

RESOLVED DUPLICATE of bug 91106

Status

--
enhancement
RESOLVED DUPLICATE of bug 91106
7 years ago
3 years ago

People

(Reporter: mozilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110622105737

Steps to reproduce:

Replied to a mail with an empty subject, but gave my reply a different (non-empty) subject, in order to make it easier to locate this thread later on.



Actual results:

The (collapsed) thread still kept the original empty (useless) subject


Expected results:

The collapsed thread should have shown the non-empty subject of the reply.

Comment 1

7 years ago
(In reply to Alain Knaff from comment #0)
> User Agent: Mozilla/5.0 (X11; Linux i686; rv:5.0) Gecko/20100101 Firefox/5.0
> Build ID: 20110622105737
> 
> Steps to reproduce:
> 
> Replied to a mail with an empty subject, but gave my reply a different
> (non-empty) subject, in order to make it easier to locate this thread later
> on.
This means that the e-mail now has a new subject and therefore a new thread was created for it. It'll not be listed with the empty-subject thread.
(Reporter)

Comment 2

7 years ago
> It'll not be listed with the empty-subject thread.

It is. At least in Thunderbird 5.0 . Please try it out!

Or what was your point?

Comment 3

7 years ago
(In reply to Alain Knaff from comment #2)
> > It'll not be listed with the empty-subject thread.
> 
> It is. At least in Thunderbird 5.0 . Please try it out!
> 
> Or what was your point?

I tried it and it is threaded in my TB; send an e-mail with empty subject, receive it with subject, it still appears within thread. This is applicable in the sent folder too.

I'm not a TB developer, but it looks like threading depends on the "In-Reply-To" in the e-mail header. This is how I understand it. Read more here: http://cr.yp.to/immhf/thread.html

My user agent: Mozilla/5.0 (X11; Linux i686; rv:7.0.1) Gecko/20110929 Thunderbird/7.0.1
Build ID: 20110929042316
(Reporter)

Comment 4

7 years ago
I'm not sure I understand what you are trying to get at. Do you mean that in your version of thunderbird, the non-empty subject is shown? If so, which version do you have?

I also checked on a different computer, with 3.1.15

Comment 5

7 years ago
(In reply to Alain Knaff from comment #4)
> I'm not sure I understand what you are trying to get at. Do you mean that in
> your version of thunderbird, the non-empty subject is shown? If so, which
> version do you have?
My Thunderbird version 7.0.1. Upgrade the one you have and try.
(Reporter)

Comment 6

7 years ago
I just upgraded to 7.0.1, and I'm sorry to say that this version continues to show the subject of the message which started a thread, even if that was empty, and a later reply with non-empty subject exists.

So, could we have this fixed, or is this a tunable setting somewhere.

Thanks

Comment 7

7 years ago
(In reply to Alain Knaff from comment #6)
> I just upgraded to 7.0.1, and I'm sorry to say that this version continues
> to show the subject of the message which started a thread, even if that was
> empty, and a later reply with non-empty subject exists.
Oh, now I get you! Yes, I do get the same treatment in Thunderbird, but that is not a problem.

A subsequent e-mail with a subject stays in a thread where the original mail has no subject. I don't think this is a bug.

Anyway, read about some work-arounds here: http://getsatisfaction.com/mozilla_messaging/topics/can_i_use_thunderbird_to_rename_a_subject_line_in_a_received_email

You can also participate in the discussion in that forum.
(Reporter)

Comment 8

7 years ago
(In reply to Hashem Masoud from comment #7)
>  Yes, I do get the same treatment in Thunderbird, but that is not a problem.

I understand that this is not bothering you, but it is bothering me. And probably others as well. That's why I brought it up.
 
> I don't think this is a bug.

Ok, so let's call it a wishlist item then. But please don't go around spamming enhancement requests with which you don't agree (or which you don't understand) with non-sequiturs and false claims that they've been fixed in later versions. You are doing nobody a favor with this behavior. If you do indeed manage to confuse matters enough to get the "offending" suggestions ignored by the developers, all you achieve is give Thunderbird a bad name, and drive people away to Chrome (... or back to Outlook).

> 
> Anyway, read about some work-arounds here:
> http://getsatisfaction.com/mozilla_messaging/topics/
> can_i_use_thunderbird_to_rename_a_subject_line_in_a_received_email
> 
> You can also participate in the discussion in that forum.

This is all fine and dandy, but why can't we just fix the underlying issue? Changing received mails could be dodgy in case you need to forward them on at a later day.

Comment 9

7 years ago
(In reply to Alain Knaff from comment #8)
> Ok, so let's call it a wishlist item then.
OK.
Severity: normal → enhancement

Updated

7 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 10

3 years ago
I don't believe we would ever do this. And bug 91106, ability to change subject, should be a sufficient alternative.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 91106
You need to log in before you can comment on or make changes to this bug.