Memory leaks. Sometimes mem usage gets to 1 GB+ with only one empty tab opened (after loading many images)

RESOLVED DUPLICATE of bug 683284

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 683284
7 years ago
6 years ago

People

(Reporter: clau.tm.ro, Unassigned)

Tracking

6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(6 attachments)

(Reporter)

Description

7 years ago
Created attachment 559417 [details]
ProcessExplorer_FFMemoryUsage.JPG

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:6.0.2) Gecko/20100101 Firefox/6.0.2
Build ID: 20110902133214

Steps to reproduce:

I opened Firefox 6.0.2 (default is one tab with https://encrypted.google.com). Memory usage was 109,560K (Private Bytes), 102,000K (Working Set) as reported by Process Explorer.

I opened a new tab and navigated to http://www.deviantart.com. The memory usage increased to 120,964K (Private Bytes), 139,972K (Working Set). I clicked on various pictures which were opened in the same tab. After I viewed a picture I clicked the back button. After viewing 20 pictures the memory usage increased to 145,472K (Private Bytes), 166,004K (Working Set). After I closed the tab the memory usage stayed the same.

I then opened a new tab and searched for "Firefox bug report" in Google. I had to make a new account so I opened http://gmail.com to activate my account. After that I had to leave the computer for 1 hour. At the moment I am writing this, the memory usage as reported by Process Explorer is 199,988K (Private Bytes), 220,884K (Working Set). See attached file ProcessExplorer_FFMemoryUsage.JPG. The Firefox cache size reported by about:cache is 11,614K. See attached file AboutCache.JPG.

In other instances of normal FF usage over 6+ hours, after browsing to different sites and viewing 100+ pictures (resolution 1000x1200 or more) and viewing several clips on youtube, the memory usage increased to 1,100,000+ KB (Private Bytes), 1,200,000+ KB (Working Set). At this point FF becomes laggy. I have multiple other applications opened and the machine has 2 GB of RAM. The problem is easily recreateable.


Actual results:

Memory usage increases a lot during use (especially when viewing pages that contain pictures - and especially when viewing large pictures).

Could memory fragmentation be an issue?



Expected results:

Memory usage should keep within reasonable limits.
(Reporter)

Comment 1

7 years ago
Created attachment 559418 [details]
The about:cache capture
(Reporter)

Updated

7 years ago
Attachment #559418 - Attachment description: The about → The about:cache capture
(Reporter)

Comment 2

7 years ago
I should mention that the 1.1+ GB memory usage that I mentioned above went down slightly after I closed all tabs to just under 1 GB, which is still a lot considering that there was only one empty tab opened.

Comment 3

7 years ago
Please capture the contents of about:memory when this occurs
(Reporter)

Comment 4

7 years ago
about:memory shows absolutely nothing. See screenshot (AboutMemory.JPG). Memory usage at this point is 222,356K (Private Bytes), 243,916K (Working Set). Only this bug page and about:memory page are opened in 2 tabs.
(Reporter)

Comment 5

7 years ago
Created attachment 559765 [details]
about:memory

Comment 6

7 years ago
Is about:memory empty if you start Firefox in Safe Mode? http://support.mozilla.com/en-US/kb/Safe+Mode
(Reporter)

Comment 7

7 years ago
I restarted FF in safe mode. My initial web page, as stated, above, is Google main page SSL. I entered "about:memory" in that initial tab. Attachement is AboutMemory_SafeMode_Initial.JPG. Memory usage was a lot lower than when all extensions were enabled (something around 50 MB). Then I opened www.deviantart.com again and opened some 20 tabs with images (middle click on each image). After all pages were loaded, memory usage went up to ~400 MB. I then tried to refresh the "about:memory" tab, but it showed nothing (see attachment AboutMemory.JPG). I closed all tabs and waited for about 1 minute. The memory usage stayed at around 250 MB. The only tab that is currently opened is this one that I am using for bug report. Before I opened the deviantart tabs, the memory usage was around 90-100 MB.
(Reporter)

Comment 8

7 years ago
Created attachment 559814 [details]
about:memory in Safe mode (initial state, one tab opened)

Comment 9

7 years ago
The about:memory from comment is empty. Have you been using private browsing mode at that moment? (That is a known problem in FF6). Comment 8 is better, but there is nothing wrong. Can you post an about:memory shot when there is explicit memory of 1GB+?
Still, reports from FF6 are not very helpful today, about:memory design from FF7/8/9 has radically changed and would provide better information if there really is a problem.
(Reporter)

Comment 10

7 years ago
I have FF 6.0.2 with Private Browsing, so maybe that's why about:memory only works when I open FF but not at any point afterwards.
(Reporter)

Comment 11

7 years ago
I disabled Private Browsing (Tools->Options->Privacy->Remember History), I restarted FF and I navigated again to deviantart.com. After opening about 300 pictures on deviantart.com and flickr.com in the same tab, the memory usage went up to 1.2 GB. I closed all tabs keeping only the about:memory tab opened. I waited for 2+ minutes but the memory usage stayed the same. I took a screen capture (see attached AboutMemory_NonPrivate.JPG). I then pressed the Minimize Memory Usage button and took another screenshot (see attached AboutMemory_NonPrivate_AfterMinimizeMemoryUsage.JPG).
(Reporter)

Comment 12

7 years ago
Created attachment 559921 [details]
about:memory in non Private Browsing mode after viewing 300+ pictures
(Reporter)

Comment 13

7 years ago
Created attachment 559922 [details]
about:memory in non Private Browsing mode after Minimize Memory Usage
(Reporter)

Comment 14

7 years ago
Any updates on this bug? Can anyone recreate it?
(Reporter)

Updated

7 years ago
Severity: normal → major
(Reporter)

Comment 15

7 years ago
I just bumped the severity of the bug. Is there any additional information that I need to provide? This bug is getting annoying. It's strange that noone else sees it.
Have you tried Firefox 7?  It fixes a number of issues with long-term memory usage.  It is releasing today.  See if that helps at all.  Other than that, it sounds like it could be related to image uses.  There's an existing bug around somewhere on problems we have with memory usage for images.
Whiteboard: [MemShrink]

Comment 17

7 years ago
In the screenshot there is the "negative amount" and "over 100% portion" problem (bug 664659), which is only fixed since Firefox 8. So you probably we probably still won't get better data until then. But I think this confirms the mem usage is due to images.

There are many bug reports about high memory usage with images, you can watch their progress, see the bugs dependent on bug 683284.
Depends on: 683284
Keywords: footprint
Summary: Memory leaks. Sometimes mem usage gets to 1 GB+ with only one empty tab opened → Memory leaks. Sometimes mem usage gets to 1 GB+ with only one empty tab opened (after loading many images)
No longer depends on: 683284
Comment on attachment 559922 [details]
about:memory in non Private Browsing mode after Minimize Memory Usage

This looks pretty normal to me.  Notice that javascript is using most of the memory here.  JS is known to use a lot of memory, particularly in older versions of FF.

(By the way, you can copy-paste the about:memory results.)
I'm removing the [MemShrink] tag because I don't think there's anything immediately actionable here.

We know that if you browse around and then close all tabs and click minimize memory usage, Firefox's memory usage doesn't go down to its initial state.  (This is bug 668809.)

clau.tm.ro, if you want a browser with improved memory usage, you might want to try the Aurora builds, which have many improvements.  See http://www.mozilla.com/firefox/channel/
Whiteboard: [MemShrink]

Comment 20

7 years ago
clau, which bug do you see this being a duplicate of?
bug 683284
bug 668809
Whiteboard: [closeme 2012-03-15]

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Keywords: footprint
Resolution: --- → DUPLICATE
Whiteboard: [closeme 2012-03-15]
Duplicate of bug: 683284
You need to log in before you can comment on or make changes to this bug.