Closed Bug 685958 Opened 11 years ago Closed 11 years ago

Firefox 3.6 users upgrading to Fx 7 Should see First Run page on Upgrade

Categories

(Firefox :: General, defect)

7 Branch
x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: lmesa, Unassigned)

References

Details

Firefox 3.6.x users upgrading to Fx 4+ should see First Run page after upgrade. 

This is important because the change between these versions is substantial and we need to make sure the change is not to jarring. The FR helps accomplish that.
We removed the in-product whatsnew logic in bug 685727 (for Firefox 7).

Can we use bug 459972 for this?
I don't think so, as support for the new attributes is not present in 3.6.
I thought the attributes were read on startup, by the new version?
Ah, but maybe they're not saved by 3.6? rstrong?
Depends on: 668108
No we can't. It was decided that we shouldn't backport the patches to 1.9.2 due to the code being different enough that it could cause regressions. Specifically, bug 549969 but there are additional bugs that would have needed to land as well.
Is there anything else we can do?
Duplicate of this bug: 685940
It looks like our only options here are to delay the major update offer until we can spin a new build to update *to* that includes some changes to support this (e.g. 7.0.2 or 8.0), which doesn't seem like something we'd do at this point.
No longer depends on: 685940
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WONTFIX
Summary: Firefox 3.6 users upgrading to Fx 4+ Should see First Run page on Upgrade → Firefox 3.6 users upgrading to Fx 7 Should see First Run page on Upgrade
You need to log in before you can comment on or make changes to this bug.