Last Comment Bug 686170 - Remove modules/zlib/standalone
: Remove modules/zlib/standalone
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: General (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla9
Assigned To: Ed Morley [:emorley]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-10 16:30 PDT by Matheus Kerschbaum
Modified: 2011-09-24 08:38 PDT (History)
7 users (show)
matjk7: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (2.76 KB, patch)
2011-09-13 13:26 PDT, Ed Morley [:emorley]
no flags Details | Diff | Splinter Review
Patch v2 (4.26 KB, patch)
2011-09-14 06:26 PDT, Ed Morley [:emorley]
ted: review+
Details | Diff | Splinter Review

Description User image Matheus Kerschbaum 2011-09-10 16:30:29 PDT

    
Comment 1 User image Ed Morley [:emorley] 2011-09-13 13:26:31 PDT
Created attachment 560024 [details] [diff] [review]
Patch v1
Comment 2 User image Ed Morley [:emorley] 2011-09-13 14:06:46 PDT
In fact, isn't this still needed for the installer? ie:
http://mxr.mozilla.org/mozilla-central/source/toolkit/toolkit-tiers.mk#80
Comment 3 User image Matheus Kerschbaum 2011-09-13 14:17:51 PDT
(In reply to Ed Morley [:edmorley] from comment #2)
> In fact, isn't this still needed for the installer? ie:
> http://mxr.mozilla.org/mozilla-central/source/toolkit/toolkit-tiers.mk#80

Well that sucks. Ted might know if it's really needed.
Comment 4 User image Ted Mielczarek [:ted.mielczarek] 2011-09-13 17:34:19 PDT
I bet that's a lie. Rob: we don't actually use libjar/zlib in the installer anymore, right?
Comment 5 User image Matheus Kerschbaum 2011-09-13 18:12:39 PDT
Considering that standalone libjar doesn't exist anymore (bug 505784), it's probably a lie.
Comment 6 User image Ed Morley [:emorley] 2011-09-14 06:26:40 PDT
Created attachment 560142 [details] [diff] [review]
Patch v2

Ah, in which case I presume this can come out after all then. 

Updated patch for toolkit-tiers.mk and toolkit-makefiles.sh changes. Builds fine locally, sent to try:
https://tbpl.mozilla.org/?tree=Try&usebuildbot=1&rev=f0f350512b05
Comment 7 User image Robert Strong [:rstrong] (use needinfo to contact me) 2011-09-19 15:02:47 PDT
(In reply to Ted Mielczarek [:ted, :luser] from comment #4)
> I bet that's a lie. Rob: we don't actually use libjar/zlib in the installer
> anymore, right?
Not for the desktop installer and that was probably for the win mobile installer... you should check with someone on the mobile team since they are more familiar with whether they plan on using it in the future.
Comment 8 User image Ed Morley [:emorley] 2011-09-20 03:32:12 PDT
CCing some mobile people for comment 7. Thanks :-)
Comment 9 User image Mark Finkle (:mfinkle) (use needinfo?) 2011-09-23 11:55:35 PDT
(In reply to Ed Morley [:edmorley] from comment #8)
> CCing some mobile people for comment 7. Thanks :-)

This was only used for the Windows Mobile installer. Removing won't affect mobile.
Comment 10 User image Ed Morley [:emorley] 2011-09-23 18:21:54 PDT
Thanks Mark :-)

https://hg.mozilla.org/integration/mozilla-inbound/rev/eafaff0efeef
Comment 11 User image Matt Brubeck (:mbrubeck) 2011-09-24 08:38:15 PDT
https://hg.mozilla.org/mozilla-central/rev/eafaff0efeef

Note You need to log in before you can comment on or make changes to this bug.