History Contains Duplicate Entries

RESOLVED INVALID

Status

()

Toolkit
Places
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: David E. Ross, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
In my History window, I have set [View > Group by > Day] and [View > Sort by > Last Visited].  When I open the window, I see the following collapsed folders: Today, Yesterday, Last 7 days, This month, and August (this now being September).  If I expand the August folder, I see entries for September and even for today.  These entries are duplicates of entries I can see in the other four folders.  

A history entry should appear only once, in the folder for its latest visit.
(Reporter)

Comment 1

6 years ago
The 10 MB size of places.sqlite could likely be reduced if this bug were fixed.
I think this is just an "optical effect" due to the fact Visit Date is not the latest visit in the timeframe, but it it the global latest visit, and the fact Group by is not really clear about what it does.
The date containers are supposed to show any page that was visited in that timeframe, but having the latest visit date value out of that range makes it confusing.
Actually you read the operation as "Sort by last visited and then group by date" while what happens is the opposite operation.
since there are bugs filed for the issues in comment 2, marking as invalid since it's working as intended (apart possible confusing ui)
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

6 years ago
What are the numbers for the bugs cited in comment #3, which refers to comment #2?  Any time a bug report is closed by citing other bugs, the numbers for those other bugs should be provided.
bug 497202
You need to log in before you can comment on or make changes to this bug.