Closed Bug 686391 Opened 10 years ago Closed 10 years ago

Update install buttons for Add-ons Marketplace

Categories

(addons.mozilla.org Graveyard :: Public Pages, defect, P3)

x86
macOS
defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: andy+bugzilla, Assigned: spasovski)

References

Details

(Whiteboard: [t:muffin])

To say "Free" or "Learn about Purchasing" and "Restartless". As per mock at:

https://people.mozilla.com/~fligtar/marketplace/Install%20Buttons.png

The "Learn about purchasing" link presumably points to a light box with more information.
Assignee: nobody → amckay
Target Milestone: --- → 6.2.8
Oy. can we stop adding UI complication to the buttons? I feel like there's an opportunity to use events or some sort of capability detection to make this not affect buttons.html. Adding more stuff just seems like we're going to have a (bigger) buggy mess on our hands.
Target Milestone: 6.2.8 → 6.2.9
Blocks: 690899
Priority: -- → P3
I'd be happy to do something magical with events, I have no idea.  Davor: do you have grand ideas?  I don't want to get stuck in a rabbit hole but button code is notoriously complex.
Assignee: amckay → dspasovski
Target Milestone: 6.2.9 → ---
Potch has ideas for this bubbling about and handled at the window.something level.  Let's all meet up before real work is done here. :)
Duplicate of this bug: 704875
Blocks: 710074
No longer blocks: 690899
Blocks: 718560
No longer blocks: 710074
I'm not sure what the status of this is.  Can someone summarize if it's still relevant and if so where we are at on it?
Blocks: 735054
No longer blocks: 718560
No longer blocks: 735054
Summary: Update install buttons → Update install buttons for Add-ons Marketplace
Blocks: 739471
Marketplace has made this irrelevant.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WONTFIX
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.