Closed Bug 6864 Opened 25 years ago Closed 25 years ago

[BETA][PP]Spell check menu item not functional on Mac or Linux.

Categories

(Core :: DOM: Editor, defect, P3)

PowerPC
Mac System 8.5
defect

Tracking

()

VERIFIED DUPLICATE of bug 25152

People

(Reporter: chrispetersen, Assigned: dougt)

References

Details

(Keywords: platform-parity, Whiteboard: [PRE-BETA])

Version:Apprunner
Build: 1999052008
Platform:Mac
Other Platforms: Linux (Works fine on Windows 98, NT)
Expected Results:
Selecting Spell check menu item should open the Spell check dialog.
What I got:
Selecting spell check menu item doesn't open spell check dialog.
Steps to Reproduce:
1) Launch Apprunner.
2) Select Editor from the Tasks menu.
3) From the Tools menu, select Spell Check.
4) The spell check dialog doesn't open.
Assignee: kostello → cmanske
Target Milestone: M7
Assigning to cmanske, setting milestone to M7
This is probably because you are not using the Netscape Commercial build.
Kin: Please describe how to do that for Mac and Linux -- is this information
posted anywhere?
*** Bug 6863 has been marked as a duplicate of this bug. ***
If you are using a commercial build, you should see a directory called
spellchecker:

    <executable dir>/components/spellchecker

If this directory is missing or there is no spellchecker library/dll in that
directory, then the spellchecker will not startup.
Can I get a full path Kin? thanks!
<executable dir> is the directory your apprunner executable is in.
okay I don't see a spellcheck directory in my executable directory So now what?
how do I get a commercial build? Kin, when you get a chance, pop on over and
check out my build to see whats wrong with the builds I'm grabbing and
installing.
I don't think there is a Commercial Linux build yet, So they might be placing
regular Mozilla builds in the dist directories for QA.
Target Milestone: M7 → M8
This isn't a real bug - just a reminder to make sure it can run
Chris: have you installed the needed DLLs to test this on Mac and Linux?
Status: NEW → ASSIGNED
Is this working yet? Please mark bug fixed if it is.
still not working. Here's what I get in console:

Check Spelling starting...
JavaScript error: uncaught exception: Component returned failure code:
0x80040154 [nsIEditorSpellCheck.StartSpellChecking, {file:
file:////u/sujay/LINUX/package/chrome/editor/composer/content/default/EditorAppShell.xul,
line: 393}]
Assignee: cmanske → kin
Status: ASSIGNED → NEW
Kin: Please help Sujay get this working.
Status: NEW → ASSIGNED
Accepting bug.
Target Milestone: M8 → M9
This is not an M8 blocker. Changing to M9.

Update: There is now a Linux Commercial build, but it looks like it only works
if you have a pre-installed nspr RPM or seperate NSPR build.
Moving all spellchecker/text services related bugs to M11 since I will still be
working on AutoComplete features through M10.
Target Milestone: M11 → M12
Moving to M12.
can we add the dependency for a Mac commercial build to the dependency list
above?
I checked in the makefiles so that we can build on Linux. I just need to add the
modules directory and modules/Makefile to Makefile.in and allmakefiles.sh.
Assignee: kin → sfraser
Status: ASSIGNED → NEW
I just enabled the spellchecker in the Linux Commercial build. Passing this bug
onto sfraser@netscape.com so he can help me turn on the building of the
modules/spellchk directory on the Mac.
Summary: [PP]Spell check menu item not functional on Mac or Linux. → [BETA][PP]Spell check menu item not functional on Mac or Linux.
Whiteboard: [BETA feature work]
Target Milestone: M12 → M14
setting to M14, this isn't dogfood, but it is beta
Whiteboard: [BETA feature work] → [PRE-BETA]
Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 25 years ago
Resolution: --- → FIXED
I fixed the location of the dictionary files (netscape.dic & pen4s324.dat) in
ns/build/mac/CommercialBuildList.pm

Marking fixed eventhough I'm not sure this is the only problem. Feel free to
reopen if Monday (11/29) build is still broken.
by the way, why is this bug in bugzilla instead of bugsplat (internal) ?
Status: RESOLVED → REOPENED
not working in 11/29 build...reopening..spellchecker doesn't come up...
Sujay: on Mac?
yes Mac...
Resolution: FIXED → ---
Clearing FIXED resolution due to reopen.
Simon, just to make sure this is not an install issue:

today's build has the 3 required files (SpellCheck.shlb, netscape.dic and
pen4s324.dat) installed under Components/SpellCheck/
If any other file is required for SpellChecker to work, it should be added to the
build script (ns/build/mac/CommercialBuildList.pm) AND the installer manifest
file (ns/xpinstall/packager/packages-mac)
Kin, let me know when you want me to check this out in new Mac/Linux builds..
still a problem on 1/20 build.


I can't believe this, I'm actually going to get to mark a bug WORKSFORME... ok,
not on mac, but Linux at least. I'm running the linux build off of sweetlou,
BuildID 2000012008, and i can run spellchecker successfully on a composer window.
sujay,
I also played with today's build on all platform, and here's a quick recap:

- both Windows and Linux manage to load the spellchecker ok from Components/
Spellchecker/ where the dll is
- Mac doesn't do anything with the analog configuration. However, if I move the 
dll and the dictionary one level up (inside 'Components' instead of 'Components/
SpellCheck', then it works fine.

This could be an XPCOM issue where components wouldn't get registered on Mac if 
they're nested inside sub directories under Components... cc'ing dp for his input 
on this.
I'll try it out on today's builds...I hope you're all right!
okay I see it working on Linux and Windows!! now lets work on Mac...

lets still keep this bug open unitl we fix Mac.
Nice observation jj.

We have never tested subdirs under component directory. This is probably the 
first one.

Simon, I can help you figure this out.
Keywords: pp
This turns out to be a simple problem with the naming of the spellchecker 
directory inside components.

I'm checking in build script and packaging file changes to rename this dir from 
"SpellCheck" to "SpellChecker". That fixes the problem on Mac.
Fix checked in
Status: REOPENED → RESOLVED
Closed: 25 years ago25 years ago
Resolution: --- → FIXED
Mac still not working using 1/26 builds...also Linux all of a sudden stopped
working also. Console message:

*** Exception error from Spell Checker
Check Spelling starting...
*** Exception error from Spell Checker

Windows works fine as usual...
Status: RESOLVED → REOPENED
dup of 24408 ?
Resolution: FIXED → ---
*** Bug 24408 has been marked as a duplicate of this bug. ***
adding leaf to Cc: list...

guys we need to make sure all the necessary files are packaged for not only
netscape-* builds but also mozilla -* builds..

QA doesn't always use the netscape-* builds...
okay will check using netscape-* builds on Linux and Mac....it should work...

will add comments...
I grabbed Mac M14 1/26 build and its still not working JJ....
ok, spellchecker is no longer working for me on linux; i get a console
javascript error:
``JavaScript Error: ReferenceError: Spelling is not defined''
This is new, as i was able to spellcheck when this bug was first filed.
After nsIFile landed, kin notices that directory enumeration didn't work in the
components directory. Spell checker get affected because it is installed in
components/spellchecker as opposed to components/

This is a regreassion that dougt knows about and is working feverishly to
fixing.
Assignee: sfraser → dougt
Status: REOPENED → NEW
this is a dup.

*** This bug has been marked as a duplicate of 25152 ***
Status: NEW → RESOLVED
Closed: 25 years ago25 years ago
Resolution: --- → DUPLICATE
verified in 1/26 build.
Status: RESOLVED → VERIFIED
dp: using yesterday's Mac build, I actually tried to move spellcheck.shlb + 
dictionaries one level up (under Components instead of Components/SpellChecker) 
and it still didn't work...
You need to log in before you can comment on or make changes to this bug.