Make ProcessingInstruction inherit from CharacterData

RESOLVED FIXED

Status

()

Core
DOM: Core & HTML
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: annevk, Assigned: smaug)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
We changed DOM4 so that ProcessingInstruction is much more like Text and Comment.
(Assignee)

Updated

6 years ago
Assignee: nobody → Olli.Pettay
(Assignee)

Comment 1

6 years ago
Created attachment 560267 [details] [diff] [review]
patch

uploaded to try
(Assignee)

Updated

6 years ago
Attachment #560267 - Flags: review?(jonas)
Attachment #560267 - Flags: review?(jonas) → review+
(Assignee)

Comment 2

6 years ago
https://hg.mozilla.org/mozilla-central/rev/f7cbb2d9c61d
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

4 years ago
Blocks: 888672

Comment 3

4 years ago
This seems to have regressed updating the contents of a PI and having that restyle the document - but re-inserting the PI after changing its contents offers a workaround. Is this expected behaviour (maybe the API we're supposed to use changed?), or should I file a bug to fix this in core? See bug 888672 for more details and easy STR.
Flags: needinfo?(bugs)
Please file a bug. It seems that it might be caused by pi->SetData now calling nsGenericDOMDataNode::SetData -> SetTextInternal directly rather than SetNodeValue -> SetNodeValueInternal which XMLStylesheetProcessingInstruction overrides.
Flags: needinfo?(bugs)
(Assignee)

Comment 5

4 years ago
Yes, new bug please.

Updated

4 years ago
Blocks: 888864
No longer blocks: 888864
Depends on: 888864
You need to log in before you can comment on or make changes to this bug.