Closed Bug 686457 Opened 10 years ago Closed 10 years ago

crash in mozilla::AndroidBridge::ValidateBitmap @ JNI_GetCreatedJavaVMs

Categories

(Core Graveyard :: Widget: Android, defect, P1)

ARM
Android
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 741166

People

(Reporter: jdm, Unassigned)

Details

(Keywords: crash, topcrash, Whiteboard: [mobile-crash])

Crash Data

This bug was filed from the Socorro interface and is 
report bp-7e132e6c-4129-45fe-ad47-5a7362110908 .
============================================================= 

Chris, looks like something is going wonky in the native bitmap code. This is one of the more popular crashes on 7.0, and I think I saw it in the reports for 8 as well.

0 	libdvm.so 	JNI_GetCreatedJavaVMs 	
1 	libandroid_runtime.so 	libandroid_runtime.so@0x37226 	
2 	libandroid_runtime.so 	libandroid_runtime.so@0x5aab8 	
3 	libjnigraphics.so 	AndroidBitmap_getInfo 	
4 	libxul.so 	mozilla::AndroidBridge::ValidateBitmap 	widget/src/android/AndroidBridge.cpp:915
5 	libxul.so 	nsWindow::OnDraw 	widget/src/android/nsWindow.cpp:997
6 	libxul.so 	nsWindow::OnGlobalAndroidEvent 	widget/src/android/nsWindow.cpp:830
7 	libxul.so 	nsAppShell::ProcessNextNativeEvent 	widget/src/android/nsAppShell.cpp:410
8 	libxul.so 	nsBaseAppShell::DoProcessNextNativeEvent 	widget/src/xpwidgets/nsBaseAppShell.cpp:172
9 	libxul.so 	nsBaseAppShell::OnProcessNextEvent 	widget/src/xpwidgets/nsBaseAppShell.cpp:312
10 	libxul.so 	mozilla::dom::ContentParent::OnProcessNextEvent 	dom/ipc/ContentParent.cpp:976
11 	libxul.so 	nsThread::ProcessNextEvent 	nsTArray.h:139
12 	libxul.so 	NS_ProcessNextEvent_P 	obj-firefox/xpcom/build/nsThreadUtils.cpp:245
13 	libxul.so 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:111
14 	libxul.so 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:219
15 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:511
16 	libxul.so 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:191
17 	libxul.so 	nsAppStartup::Run 	toolkit/components/startup/nsAppStartup.cpp:223
18 	libxul.so 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3688
19 	libxul.so 	Java_org_mozilla_gecko_GeckoAppShell_nativeRun 	toolkit/xre/nsAndroidStartup.cpp:132
20 	libmozutils.so 	Java_org_mozilla_gecko_GeckoAppShell_nativeRun 	other-licenses/android/APKOpen.cpp:234
21 	libdvm.so 	dvmPlatformInvoke 	
22 	libdvm.so 	dvmCallJNIMethod_general 	
23 	libdvm.so 	dvmResolveNativeMethod 	
24 	libdvm.so 	dvmAsmSisterStart 	
25 	libdvm.so 	dvmMterpStd 	
26 	libdvm.so 	dvmInterpret 	
27 	libdvm.so 	dvmCallMethodV 	
28 	libdvm.so 	dvmCallMethod 	
29 	libdvm.so 	dvmDetachCurrentThread 	
30 	libc.so 	__thread_entry 	
31 	libc.so 	pthread_create 	

https://crash-stats.mozilla.com/report/list?range_value=7&range_unit=days&date=2011-09-12&signature=JNI_GetCreatedJavaVMs&version=Fennec%3A6.0
OS: Mac OS X → Android
Hardware: x86 → ARM
Priority: -- → P1
Assignee: nobody → chrislord.net
It's #16 top crasher in Fennec 7.0.1.
It appeared across all versions (6.0, 6.0.2, 7.0, 8.0a2) from September 8.
It's #2 top crasher in Fennec 8.0.
Whiteboard: [mobile-crash]
Keywords: topcrash
It's now only #29 top crasher in 9.0.
Keywords: topcrash
I can't think of what would cause a crash in JNI_GetCreatedJavaVMs - Maybe the function isn't thread-safe?

I don't have the time to look at this at the moment, so unassigning.
Assignee: chrislord.net → nobody
Summary: crash in JNI_GetCreatedJavaVMs → crash in mozilla::AndroidBridge::ValidateBitmap @ JNI_GetCreatedJavaVMs
Component: General → Widget: Android
Product: Fennec → Core
QA Contact: general → android
Cwiiis, if you don't have time to investigate this ValidateBitmap/JNI_GetCreatedJavaVMs crash, can you recommend another developer?

This crash has jumped up to our #1 topcrash yesterday and #3 over the weekend.

https://crash-stats.mozilla.com/report/index/c8be5e30-e92c-4e8e-b632-fbdfb2120401
https://crash-stats.mozilla.com/report/index/ade75658-6b66-4aa0-b3d8-c02512120401
https://crash-stats.mozilla.com/report/index/6c589250-1095-4eb4-81de-4b0602120401
https://crash-stats.mozilla.com/report/index/d35caaab-dd1b-400f-bbb9-ec0272120401
...
blocking-fennec1.0: --- → ?
Keywords: topcrash
(In reply to Chris Peterson (:cpeterson) from comment #6)
> This crash has jumped up to our #1 topcrash yesterday and #3 over the
> weekend.
There are no crashes with this stack in Android Fennec. But bug 741166 which has the same signature (see bug 741315 to prevent this behavior) is #1 top crasher in the trunk.
oops.

Scoobidiver, you are correct. This bug is NOT the same as the new Android Fennec topcrash.
blocking-fennec1.0: ? → ---
(In reply to Chris Peterson (:cpeterson) from comment #6)
> Cwiiis, if you don't have time to investigate this
> ValidateBitmap/JNI_GetCreatedJavaVMs crash, can you recommend another
> developer?
> 
> This crash has jumped up to our #1 topcrash yesterday and #3 over the
> weekend.
> 
> https://crash-stats.mozilla.com/report/index/c8be5e30-e92c-4e8e-b632-
> fbdfb2120401
> https://crash-stats.mozilla.com/report/index/ade75658-6b66-4aa0-b3d8-
> c02512120401
> https://crash-stats.mozilla.com/report/index/6c589250-1095-4eb4-81de-
> 4b0602120401
> https://crash-stats.mozilla.com/report/index/d35caaab-dd1b-400f-bbb9-
> ec0272120401
> ...

These crashes are all bug 741166, as mentioned in comment 7 - I still don't have the time for this, and not sure who to recommend... Perhaps James Willcox?
Related bug fixed, no crashes since that fix checked in.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 741166
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.