If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash @ nsWindow::OnDraw

RESOLVED DUPLICATE of bug 717096

Status

()

Core
Widget: Android
--
critical
RESOLVED DUPLICATE of bug 717096
6 years ago
5 years ago

People

(Reporter: nhirata, Assigned: kats)

Tracking

({crash, reproducible, topcrash})

Trunk
ARM
Android
crash, reproducible, topcrash
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-fennec1.0 +)

Details

(Whiteboard: [mobile-crash][native-crash], crash signature)

From Socorro:
https://crash-stats.mozilla.com/report/index/9f7a3045-7b8b-4d39-b74b-9538a2111022

Frame 	Module 	Signature [Expand] 	Source
0 	libdvm.so 	dvmAbort 	
1 	libdvm.so 	JNI_CreateJavaVM 	
2 	libdvm.so 	JNI_CreateJavaVM 	
3 	libxul.so 	mozilla::AndroidBridge::AutoLocalJNIFrame::~AutoLocalJNIFrame 	widget/src/android/AndroidBridge.h:233
4 	libxul.so 	nsWindow::OnDraw 	widget/src/android/nsWindow.cpp:1129
5 	libxul.so 	nsWindow::OnGlobalAndroidEvent 	widget/src/android/nsWindow.cpp:836
6 	libxul.so 	nsAppShell::ProcessNextNativeEvent 	widget/src/android/nsAppShell.cpp:408
7 	libxul.so 	nsBaseAppShell::DoProcessNextNativeEvent 	widget/src/xpwidgets/nsBaseAppShell.cpp:172
8 	libxul.so 	nsBaseAppShell::OnProcessNextEvent 	widget/src/xpwidgets/nsBaseAppShell.cpp:312
9 	libxul.so 	mozilla::dom::ContentParent::OnProcessNextEvent 	dom/ipc/ContentParent.cpp:1144
10 	libxul.so 	nsThread::ProcessNextEvent 	nsTArray.h:170
11 	libxul.so 	NS_ProcessNextEvent_P 	obj-firefox/xpcom/build/nsThreadUtils.cpp:245
12 	libxul.so 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:111
13 	libxul.so 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:209
14 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:487
15 	libxul.so 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:191
16 	libxul.so 	nsAppStartup::Run 	toolkit/components/startup/nsAppStartup.cpp:229
17 	libxul.so 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3577
18 	libxul.so 	Java_org_mozilla_gecko_GeckoAppShell_nativeRun 	toolkit/xre/nsAndroidStartup.cpp:132
19 	libmozutils.so 	Java_org_mozilla_gecko_GeckoAppShell_nativeRun 	other-licenses/android/APKOpen.cpp:232
20 	libdvm.so 	dvmPlatformInvoke 	
21 	libdvm.so 	dvmCallJNIMethod_general 	
22 	libdvm.so 	dvmResolveNativeMethod 	
23 	libdvm.so 	dvmAsmSisterStart 	
24 	libdvm.so 	dvmMterpStd 	
25 	libdvm.so 	dvmInterpret 	
26 	libdvm.so 	dvmCallMethodV 	
27 	libdvm.so 	dvmCallMethod 	
28 	libdvm.so 	dvmDetachCurrentThread 	
29 	libc.so 	__thread_entry 	
30 	libc.so 	pthread_create



some of the same crashes are listed (some are mixed with other crashers) : https://crash-stats.mozilla.com/report/list?range_value=7&range_unit=days&date=2011-10-24%2008%3A00%3A00&signature=dvmAbort&version=Fennec%3A10.0a1
Crash Signature: [@ mozilla::AndroidBridge::AutoLocalJNIFrame::~AutoLocalJNIFrame] → [@ mozilla::AndroidBridge::AutoLocalJNIFrame::~AutoLocalJNIFrame] [@ nsWindow::OnDraw]
Summary: Crash [@ mozilla::AndroidBridge::AutoLocalJNIFrame::~AutoLocalJNIFrame] → Crash [@ nsWindow::OnDraw]
The earliest I see it on Socorro is : 20111014030948

Devices:
HTC Vision  ( htc_wwe/htc_vision/vision:2.3.3/GRI40/84109:user/release-keys )
HTC Desire HD ( htc_wwe/htc_ace/ace:2.3.3/GRI40/87995:user/release-keys )
bn NookColor ( google/passion/passion:2.3.6/GRK39F/189904:user/release-keys )
samsung SGH-I897 ( google/soju/crespo:2.3.4/GRJ22/121341:user/release-keys )
lge LG-P970 ( lge/lge_bprj/lgp970/lgp970:2.2.2/FRG83G/LG-P970-V10c.41E080EC:user/release-keys )
samsung GT-I9000 ( samsung/GT-I9000/GT-I9000:2.3.3/GINGERBREAD/DDJV6:user/release-keys )

Comment 2

6 years ago
(In reply to Naoki Hirata :nhirata from comment #1)
> The earliest I see it on Socorro is : 20111014030948
> 
> Devices:
> HTC Vision  ( htc_wwe/htc_vision/vision:2.3.3/GRI40/84109:user/release-keys )
> HTC Desire HD ( htc_wwe/htc_ace/ace:2.3.3/GRI40/87995:user/release-keys )
> bn NookColor ( google/passion/passion:2.3.6/GRK39F/189904:user/release-keys )
> samsung SGH-I897 ( google/soju/crespo:2.3.4/GRJ22/121341:user/release-keys )
> lge LG-P970 (
> lge/lge_bprj/lgp970/lgp970:2.2.2/FRG83G/LG-P970-V10c.41E080EC:user/release-
> keys )

Martijn, can you try and find a STR on your LG Optimus Black?  Sounds like a bug around onDraw.   Check with Chris Lord or MWU for more hints.  

Thanks


> samsung GT-I9000 (
> samsung/GT-I9000/GT-I9000:2.3.3/GINGERBREAD/DDJV6:user/release-keys )
So I should browse with the XUL Fennec build to reproduce this crash, right?
yes, that is correct.  It's a XUL based crash.
I do keep hitting the crash from bug 694992, but not this crash.
possible dup/related to bug 686457?
Crash Signature: [@ mozilla::AndroidBridge::AutoLocalJNIFrame::~AutoLocalJNIFrame] [@ nsWindow::OnDraw] → [@ mozilla::AndroidBridge::AutoLocalJNIFrame::~AutoLocalJNIFrame] [@ nsWindow::OnDraw] [@ dvmAbort ]
Whiteboard: [mobile-crash]

Comment 7

6 years ago
Now that dvmAbort and JNI_CreateJavaVM are in the Socorro skiplist, I change the crash signature.
Crash Signature: [@ mozilla::AndroidBridge::AutoLocalJNIFrame::~AutoLocalJNIFrame] [@ nsWindow::OnDraw] [@ dvmAbort ] → [@ dvmAbort | JNI_CreateJavaVM | JNI_CreateJavaVM | mozilla::AndroidBridge::AutoLocalJNIFrame::~AutoLocalJNIFrame] [@ nsWindow::OnDraw]

Updated

6 years ago
Depends on: 695096

Updated

6 years ago
Crash Signature: [@ dvmAbort | JNI_CreateJavaVM | JNI_CreateJavaVM | mozilla::AndroidBridge::AutoLocalJNIFrame::~AutoLocalJNIFrame] [@ nsWindow::OnDraw] → [@ dvmAbort | JNI_CreateJavaVM | JNI_CreateJavaVM | mozilla::AndroidBridge::AutoLocalJNIFrame::~AutoLocalJNIFrame] [@ dvmAbort | JNI_CreateJavaVM | JNI_CreateJavaVM | nsWindow::OnDraw] [@ nsWindow::OnDraw]
Component: General → Widget: Android
Product: Fennec → Core
QA Contact: general → android
Summary: Crash [@ nsWindow::OnDraw] → Crash @ nsWindow::OnDraw
Whiteboard: [mobile-crash] → [mobile-crash][native-crash]

Updated

6 years ago
Duplicate of this bug: 704785

Updated

6 years ago
Crash Signature: [@ dvmAbort | JNI_CreateJavaVM | JNI_CreateJavaVM | mozilla::AndroidBridge::AutoLocalJNIFrame::~AutoLocalJNIFrame] [@ dvmAbort | JNI_CreateJavaVM | JNI_CreateJavaVM | nsWindow::OnDraw] [@ nsWindow::OnDraw] → [@ dvmAbort | JNI_CreateJavaVM | JNI_CreateJavaVM | mozilla::AndroidBridge::AutoLocalJNIFrame::~AutoLocalJNIFrame] [@ dvmAbort | JNI_CreateJavaVM | JNI_CreateJavaVM | nsWindow::OnDraw] [@ mozilla::AndroidBridge::AutoLocalJNIFrame::~AutoLocalJNIFr…

Updated

6 years ago
Crash Signature: [@ dvmAbort | JNI_CreateJavaVM | JNI_CreateJavaVM | mozilla::AndroidBridge::AutoLocalJNIFrame::~AutoLocalJNIFrame] [@ dvmAbort | JNI_CreateJavaVM | JNI_CreateJavaVM | nsWindow::OnDraw] [@ mozilla::AndroidBridge::AutoLocalJNIFrame::~AutoLocalJNIFr… → [@ dvmAbort | JNI_CreateJavaVM | JNI_CreateJavaVM | mozilla::AndroidBridge::AutoLocalJNIFrame::~AutoLocalJNIFrame] [@ dvmAbort | JNI_CreateJavaVM | JNI_CreateJavaVM | mozilla::AndroidBridge::AutoLocalJNIFrame::~AutoLocalJNIFrame | nsWindow::OnDraw…
Depends on: 697145

Updated

6 years ago
Crash Signature: [@ dvmAbort | JNI_CreateJavaVM | JNI_CreateJavaVM | mozilla::AndroidBridge::AutoLocalJNIFrame::~AutoLocalJNIFrame] [@ dvmAbort | JNI_CreateJavaVM | JNI_CreateJavaVM | mozilla::AndroidBridge::AutoLocalJNIFrame::~AutoLocalJNIFrame | nsWindow::OnDraw… → [@ dvmAbort | JNI_CreateJavaVM | JNI_CreateJavaVM | mozilla::AndroidBridge::AutoLocalJNIFrame::~AutoLocalJNIFrame] [@ dvmAbort | JNI_CreateJavaVM | JNI_CreateJavaVM | mozilla::AndroidBridge::AutoLocalJNIFrame::~AutoLocalJNIFrame | nsWindow::OnDraw…
I was hitting this crash after a while on the HTC Desire HD (Android 2.) with this testcase:
http://people.mozilla.org/~mwargers/tests/videos/atomicplayboy_winopenclose.htm
- Tap on the 'win open then close after 10s' button
- When the popup block doorhanger windows appears after a short while, tap on the Alsways Show button, reload the page and tap on the 'win open then close after 10s' button again
- Wait for 5 minutes or so

Updated

6 years ago
Keywords: reproducible

Updated

6 years ago
Crash Signature: [@ dvmAbort | JNI_CreateJavaVM | JNI_CreateJavaVM | mozilla::AndroidBridge::AutoLocalJNIFrame::~AutoLocalJNIFrame] [@ dvmAbort | JNI_CreateJavaVM | JNI_CreateJavaVM | mozilla::AndroidBridge::AutoLocalJNIFrame::~AutoLocalJNIFrame | nsWindow::OnDraw… → [@ dvmAbort | JNI_CreateJavaVM | JNI_CreateJavaVM | mozilla::AndroidBridge::AutoLocalJNIFrame::~AutoLocalJNIFrame] [@ dvmAbort | JNI_CreateJavaVM | JNI_CreateJavaVM | mozilla::AndroidBridge::AutoLocalJNIFrame::~AutoLocalJNIFrame | nsWindow::OnDraw…

Updated

6 years ago
blocking-fennec1.0: --- → ?
Depends on: 748531

Comment 10

6 years ago
Kats, please try reproducing with test case when bug 748531 lands.
Assignee: nobody → bugmail.mozilla
blocking-fennec1.0: ? → +

Comment 11

6 years ago
It's #13 top crasher in 14.0a2.
Keywords: topcrash
Duplicate of this bug: 751588
qawanted since bug 748531; please try to reproduce this bug and report.
Keywords: qawanted
I can't reproduce this anymore with the str in comment 9. Tested on the HTC Desire HD and the Galaxy SII.
This is also working for me now. My best guess is this was fixed by bug 717096
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 717096

Updated

5 years ago
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.