Closed Bug 686468 Opened 9 years ago Closed 9 years ago

Sync: NS_ERROR_NOT_AVAILABLE in nsIHttpChannel.responseStatus

Categories

(Firefox :: Sync, defect)

x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 704539

People

(Reporter: kris.pryor, Unassigned)

References

Details

Attachments

(1 file)

Attached file synclog.txt
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0.2) Gecko/20100101 Firefox/6.0.2
Build ID: 20110902133214

Steps to reproduce:

I noticed that sync stopped working a while back, but did not pursue why until now.


Actual results:

I keep getting the above message at the bottom of the browser.  In the log(attached) among other things, I see: 
Net.Resource	WARN	Caught unexpected exception Component returned failure code: 0x80040111
Exception: Login failed: error.login.reason.server No traceback available
Autoconnect failed: error.login.reason.server; retry in 240 sec


Expected results:

Sync should have completed
atoll, petef: do you notice anything odd in the logs for 

  scl2-sync202 

for user 

  rh5co6emitomg7s5qvm4upaciveocbhh 

at

  Tue Sep 13 08:58:19 PDT 2011

? Perhaps a 0-length response?
Status: UNCONFIRMED → NEW
Component: Firefox Sync: UI → Firefox Sync: Backend
Ever confirmed: true
OS: All → Windows 7
QA Contact: sync-ui → sync-backend
Hardware: All → x86
Summary: Sync encountered an error while connecting: Server incorrectly configured → Sync: NS_ERROR_NOT_AVAILABLE in nsIHttpChannel.responseStatus
I have been away from my desk since I put the ticket in, but decided to refresh the log to see what had happened and I actually see two successes.  Here is one:

1315941555395	Engine.Tabs	INFO	1 outgoing items pre-reconciliation
1315941555559	Store.Tabs	DEBUG	Adding remote tabs from kpryor's Firefox on Windows NT 6.1; WOW64
1315941555561	Collection	DEBUG	mesg: GET success 200 https://scl2-sync202.services.mozilla.com/1.1/rh5co6emitomg7s5qvm4upaciveocbhh/storage/tabs?newer=1315930412.56&full=1
1315941555563	Collection	DEBUG	GET success 200 https://scl2-sync202.services.mozilla.com/1.1/rh5co6emitomg7s5qvm4upaciveocbhh/storage/tabs?newer=1315930412.56&full=1
1315941555565	Engine.Tabs	INFO	Records: 2 applied, 0 failed to apply, 0 reconciled.
1315941555598	Engine.Tabs	INFO	Uploading all of 1 records
1315941555600	Collection	DEBUG	POST Length: 2232
1315941555680	Collection	DEBUG	mesg: POST success 200 https://scl2-sync202.services.mozilla.com/1.1/rh5co6emitomg7s5qvm4upaciveocbhh/storage/tabs
1315941555681	Collection	DEBUG	POST success 200 https://scl2-sync202.services.mozilla.com/1.1/rh5co6emitomg7s5qvm4upaciveocbhh/storage/tabs
1315941555684	Service.Main	INFO	Sync completed successfully at 2011-09-13 14:19:15 after 4.09 secs.
Component: Firefox Sync: Backend → Firefox Sync: UI
OS: Windows 7 → All
Hardware: x86 → All
OK, so this is likely a transient problem. Kris, were you on an unreliable network connection around 9am this morning?
Component: Firefox Sync: UI → Firefox Sync: Backend
OS: All → Windows 7
Hardware: All → x86
This looks a lot like bug 672878.
Still have no good lead on the root cause, either.
I have looked again and I see that I have some more failures then another success.  It seems to keep doing this over and over.

As far as I know my connection is not intermittent.  My connection to Exchange and other services at my work network are not having similar problems.
This is possibly fixed in bug 690170 (Firefox 10). If not, it is almost certainly fixed in bug 704539 (Firefox 12).

If you still experience the issue after upgrading, please reopen this bug.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 704539
Duplicate of this bug: 708954
Duplicate of this bug: 700874
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.