Closed Bug 686574 Opened 10 years ago Closed 10 years ago

Inaccurate error message when webapp fails validation due to invalid widget height

Categories

(addons.mozilla.org Graveyard :: Developer Pages, defect, P4)

defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: krupa.mozbugs, Assigned: cvan)

References

Details

(Whiteboard: [webapps])

Attachments

(1 file)

Attached image screenshot
steps to reproduce:
1. Load https://addons-dev.allizom.org/z/en-US/developers/apps/submit/2
2. Enter the URL for a webapp with invalid widget height (set to 2000) or load https://people.mozilla.com/~kraj/test-files/webapps/webapp_with_invalid_widget_height.webapp
3. Notice the error message with which validation fails


expected behavior:
Error message is something like "Value of one of the properties in the webapp manifest exceeds the max allowed limit".

actual behavior:
Error message says "Your app failed validation with undefined error." See screenshot.
OS: Mac OS X → All
Hardware: x86 → All
This seems kumarish only because he has the most experience and I'm guessing it's something simple.  Hope so. :)
Assignee: nobody → kumar.mcmillan
Priority: -- → P4
Target Milestone: --- → 6.2.7
yep, I can take this
Target Milestone: 6.2.7 → 6.2.8
Blocks: 690899
Target Milestone: 6.2.8 → ---
Blocks: 710074
No longer blocks: 690899
Blocks: 718560
No longer blocks: 710074
Blocks: 735054
No longer blocks: 718560
    App: Widget size invalid.
    Apps: App must allow installs from Marketplace for inclusion.

We should not say "App" or "Apps"
https://github.com/mozilla/zamboni/commit/5902e78
Assignee: kumar.mcmillan → cvan
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → 6.5.2
Thanks for fixing this. Alas, widgets have been removed from the manifest.

I filed bug 748030
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.