Last Comment Bug 686694 - Don't extract libraries
: Don't extract libraries
Status: VERIFIED FIXED
[mobilestartupshrink]
:
Product: Core
Classification: Components
Component: Widget: Android (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: mozilla9
Assigned To: Mike Hommey [:glandium]
:
Mentors:
Depends on: 686728
Blocks: 692381
  Show dependency treegraph
 
Reported: 2011-09-14 09:48 PDT by Mike Hommey [:glandium]
Modified: 2011-10-05 23:46 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Don't extract libraries on Android unless we're starting with the DEBUG intent (1.88 KB, patch)
2011-09-15 11:19 PDT, Mike Hommey [:glandium]
dougt: review+
Details | Diff | Splinter Review
Don't extract libraries on Android unless we're starting with the DEBUG intent (2.74 KB, patch)
2011-09-15 14:37 PDT, Mike Hommey [:glandium]
mh+mozilla: review+
Details | Diff | Splinter Review
Remove library extraction splash screen (4.03 KB, patch)
2011-09-16 02:14 PDT, Mike Hommey [:glandium]
mark.finkle: review+
Details | Diff | Splinter Review

Description Mike Hommey [:glandium] 2011-09-14 09:48:16 PDT
On a lot of devices, extracted libraries are a perf hit because of filesystem and/or flash suckage. On the fastest devices, however, we don't get much benefit from extracted libraries. All in all, it would be better for everyone if we just skipped that.

There are however a few things to care about:
- extracted libs are necessary for gdb to work properly (at least currently)
- we need to clean-up the extracted libraries from previous versions

For the former, we could either enable library extraction on the debug intent, but that means we probably need to delay library loading until onResume to have the intent (wouldn't be an actual measurable delay, though, more of a code concern). Or, we could add a pref at the java app level.
Comment 1 Mike Hommey [:glandium] 2011-09-15 11:19:27 PDT
Created attachment 560415 [details] [diff] [review]
Don't extract libraries on Android unless we're starting with the DEBUG intent
Comment 2 Doug Turner (:dougt) 2011-09-15 14:30:53 PDT
Comment on attachment 560415 [details] [diff] [review]
Don't extract libraries on Android unless we're starting with the DEBUG intent

Review of attachment 560415 [details] [diff] [review]:
-----------------------------------------------------------------

can we remove kFreeSpaceThreshold?
Comment 3 Mike Hommey [:glandium] 2011-09-15 14:37:07 PDT
Created attachment 560461 [details] [diff] [review]
Don't extract libraries on Android unless we're starting with the DEBUG intent

sure, and kLibFreeSpaceBuffer as well.
Comment 4 Mike Hommey [:glandium] 2011-09-15 14:37:49 PDT
Comment on attachment 560461 [details] [diff] [review]
Don't extract libraries on Android unless we're starting with the DEBUG intent

carrying r+ over
Comment 5 Mike Hommey [:glandium] 2011-09-16 01:04:29 PDT
https://hg.mozilla.org/mozilla-central/rev/49c16f43ff26
Comment 6 Mike Hommey [:glandium] 2011-09-16 02:14:15 PDT
Created attachment 560530 [details] [diff] [review]
Remove library extraction splash screen
Comment 7 Mike Hommey [:glandium] 2011-09-16 02:23:01 PDT
https://hg.mozilla.org/mozilla-central/rev/f4d78560721a
Comment 8 Aaron Train [:aaronmt] 2011-09-17 17:47:54 PDT
Mozilla/5.0 (Android; Linux armv7l; rv:9.0a1) Gecko/20110917 Firefox/9.0a1 Fennec/9.0a1

Note You need to log in before you can comment on or make changes to this bug.