Closed Bug 687026 Opened 10 years ago Closed 5 years ago

[10.7] Add support look up gesture in Mac OS X 10.7 Lion

Categories

(Firefox :: General, defect)

6 Branch
x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 34

People

(Reporter: mozilla, Unassigned)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

User Story

For this being broken on OS X 10.11, see bug 1212527.

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:6.0.2) Gecko/20100101 Firefox/6.0.2
Build ID: 20110902133214

Steps to reproduce:

I double tapped with three fingers on a word in a website.


Actual results:

Nothing happend.


Expected results:

According to the "System Preferences" (under "Trackpad" -> "Point & Click" -> "Look up") a double tap should lookup the selected word using the Dictionary. Works, for example, in Safari (see screenshot).
Probably dependent on bug 301451
Summary: Add support look up gesture in Mac OS X 10.7 Lion → [10.7] Add support look up gesture in Mac OS X 10.7 Lion
Duplicate of this bug: 700223
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of this bug: 778544
Mountain Lion changed the gesture. You tap a word with three fingers now.
Depends on: 301451
Assignee: nobody → breaktech
Chandan, I suggest you start by trying out the patches from bug 308471 and bug 301451 and see if that's enough to support this. You'll also have to find a solution for bug 569331 so that this does not only work for focused elements.
You can ping me on IRC #macdev if you have questions.
Flags: needinfo?(breaktech)
It works in text boxes like the one I'm typing in, but it always looks up the definition for the very first word. So if I triple-finger-tap on the word "typing", it will look up "It" instead. So it semi-works but is very broken.
Assignee: breaktech → nobody
Flags: needinfo?(breaktech)
Duplicate of this bug: 1145224
Bug 1145224 is about the lookup gesture not working in the Preferences pane (or presumably anywhere you can't select text).
Wasn't this bug already fixed by bug 308471? It seems I can use the gesture in web page wherever text can be selected. I think making lookup gesture working on non-selectable text is a topic unrelated to this bug.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
Target Milestone: --- → Firefox 34
Why was this changed to WORKSFORME? I am running Firefox 37 on Yosemite. If I tap with 3 fingers on a word on a web page, nothing happens. But if I click somewhere on the page and then triple-tap, the lookup thing shows up. This is different from most other Mac apps (including Chrome and Safari) and something I think a lot of users will not discover and will instead think it is broken.
Flags: needinfo?(smichaud)
> Why was this changed to WORKSFORME?

It wasn't changed by me :-)
Flags: needinfo?(smichaud) → needinfo?(quanxunzhen)
Hmm, I think this bug should be marked as resolved, because it works since Firefox 34. But given it depends on the meta bug we track the implementation of dictionary lookup, which still has several depending bugs open, probably we could reopen it.
Status: RESOLVED → REOPENED
Flags: needinfo?(quanxunzhen)
Resolution: WORKSFORME → ---
I looked through some of the dictionary-related bugs. I don't know if the behavior I described in my above comment is covered by bug 569331 or if it is a separate issue.
I think that is an issue covered by bug 569331.
Bug 1212527 has been filed about El Capitan support.
Also title should be adjusted, since from what I understand OS X 10.7 - 10.11 is affected. At least in my tests w 10.11.3 this issue was reproducible. So all OS X versions from the last 5 years or more are affected.
(In reply to steve-_- from comment #37)
> Also title should be adjusted, since from what I understand OS X 10.7 -
> 10.11 is affected. At least in my tests w 10.11.3 this issue was
> reproducible. So all OS X versions from the last 5 years or more are
> affected.

It works from 10.7 to 10.10. Since 10.11, Apple removed the old API which the current implementation depends on, which is bug 1212527.
I'm going to close this bug, since this gesture actually works on 10.7 ~ 10.10. This being broken again since 10.11 is bug 1212527.
Status: REOPENED → RESOLVED
Closed: 6 years ago5 years ago
Resolution: --- → FIXED
User Story: (updated)
See Also: → 1212527
Good idea. This was rather confusing and obviously incorrect. Thanks for cleaning the bug tracker. Now let's hope Mozilla can address #1212527.
This bug fixed in macOS Sierra 10.12.1 Beta 5.

I just upgrade from Sierra beta 4 to beta 5 and the three look up gesture works again, after it stopped back in El Captain.
Flags: needinfo?(mozilla)
This bug is still open in macOS 10.13.6 with Firefox 63.0
(In reply to RB from comment #43)
> This bug is still open in macOS 10.13.6 with Firefox 63.0

Please file a new bug, we cannot track changes on a closed bug.
You need to log in before you can comment on or make changes to this bug.