[PP][Mac][BLOCKER]gfx rendered drop-down lists don't get placed 'on top'

VERIFIED FIXED in M10

Status

()

Core
XUL
P3
blocker
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: Alistair Vining, Assigned: dcone (gone))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+], URL)

(Reporter)

Description

19 years ago
See e.g. resource:/res/mailnews/messenger/am-server.xul

If the top frame isn't made tall enough, the drop-down list (<select>) goes
under the other frame, rather than on top.

Need to be above every (?) frameset etc.

Updated

19 years ago
Assignee: trudelle → evaughan

Comment 1

19 years ago
reassigning to evaughan for triage

Updated

19 years ago
Assignee: evaughan → kmcclusk

Comment 2

19 years ago
this is Kevin's widget.

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M8
Drop-down list now use popup child windows, so this should be fixed. Need to
confirm it is still a problem.
(Reporter)

Comment 4

19 years ago
Now resource:/chrome/messenger/content/default/am-server.xul

Sort of fixed, but try resizing the frame up/down.  Now, if the top frame is
*larger* than the list, the text fails to display, and the frame is drawn the
wrong size.

Plus, a) there seems to be a slight flickering,
b) losing the focus from the main window when selecting a drop-down list is
unusual behaviour, at least for Windows.  But perhaps unavoidable.

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
Fixed in June 21, 1999 4:13pm build.

Added nsListControlFrame::GetViewOffset to calculate the absolute position of a
view. This is used to calculate where the drop-down
list should be placed.

Added nsListControlFrame::SyncWithFrame to synchronize the view's position with
the nsListControlFrame's position.

Added nsListControlFrame::DidReflow to override nsScrollFrame::DidReflow to call
SyncWithFrame.

Added nsListControlFrame::GetScrollingParentView to override the
nsScrollFrame::GetScrollingParentView to return the root view.
Modified nsScrollFrame. Added a virtual method GetScrollingParentView which can
be overriden to control the parenting of the
ListControlFrame. (When the listcontrol frame is used as a drop-down it's parent
is the root view instead of it's normalposition in the
view hierarchy. (This is needed to prevent the view from being clipped when the
drop-down list extends outside of the parent window.

Updated

19 years ago
Whiteboard: [07.15.99]waiting for mac to stabilize (different gfx issue)

Comment 6

19 years ago
this is cross platform. it works on RedHat 5.2 and WinNT4sp4
(the M8 candidates), but not MacOS 8.51.

i will mark verified when mac gfx widgets start to behave better, or
will reopen if need be.

Updated

19 years ago
Status: RESOLVED → REOPENED
OS: Windows 95 → All
Hardware: PC → All
Whiteboard: [07.15.99]waiting for mac to stabilize (different gfx issue)

Updated

19 years ago
Resolution: FIXED → ---

Comment 7

19 years ago
i hate to do this, but even though this works on
     1999-07-16-08 RedHat Linux 5.2 (GNOME/enlightenment)
     1999-07-16-08 WinNT 4.0 sp4

it is still drawing beneath the lower frame on
     1999-07-16-08 MacOS 8.51

Comment 8

19 years ago
updating url

Updated

19 years ago
Assignee: kmcclusk → dcone
Severity: normal → blocker
Status: REOPENED → NEW
Summary: gfx rendered drop-down lists don't get placed 'on top' → [PP][Mac][BLOCKER]gfx rendered drop-down lists don't get placed 'on top'
Target Milestone: M8 → M9
This is a Mac specific problem with the implementation of borderless-top level
windows.

This is a blocker for frame-based comboboxes on the Mac.

Don, I'm reassigning to you to investigate why it doesn't work on the Mac.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 10

19 years ago
*** Bug 4780 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

19 years ago
Target Milestone: M9 → M10

Updated

19 years ago
Blocks: 11346
*** Bug 11973 has been marked as a duplicate of this bug. ***
adding myself to cc list.

just tried the url in the url field above and it crashes (8/16/99 build)

we also need to make sure that new top-level windows that are created don't cause
the front window to visibly lose focus. That would be bad if a combo-box popped
up and deactivated the main window.

Updated

19 years ago
Blocks: 12902
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 13

19 years ago
Using real Mac windows for popups, no longer clips.

Comment 14

19 years ago
Sorry for spam, re-assigning phillip's QA contact XPToolkit/XPWidget bugs to
claudius due to restructure

Updated

19 years ago
Whiteboard: [PDT+]

Comment 15

19 years ago
Putting on [PDT]+ radar.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 16

19 years ago
marking VERIFIED based on comments and I cannot reproduce the problem anymore
with any builds much less the 1999102909 builds

Updated

18 years ago
No longer blocks: 11346
You need to log in before you can comment on or make changes to this bug.