Last Comment Bug 687260 - crash js::mjit::EnterMethodJIT
: crash js::mjit::EnterMethodJIT
Status: RESOLVED FIXED
js-triage-needed
: crash
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: x86 Windows 7
: -- critical (vote)
: ---
Assigned To: general
:
: Jason Orendorff [:jorendorff]
Mentors:
http://maps.google.com/
Depends on: 687257
Blocks: infer-regress
  Show dependency treegraph
 
Reported: 2011-09-17 09:32 PDT by Alice0775 White
Modified: 2011-09-18 03:41 PDT (History)
4 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Alice0775 White 2011-09-17 09:32:56 PDT
This bug was filed from the Socorro interface and is 
report bp-fe38189c-244b-4e0a-94fa-1e5332110917 .
============================================================= 
Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/d14291158db7
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0a1) Gecko/20110917 Firefox/9.0a1 ID:20110917030857

Browser crashes when zoom-in Google Maps


Reproducible: Always

Steps to Reproduce:
1. Open Firefox with clean profile
2. Open http://maps.google.com/
3. Zoom in maps by mouse wheel or slider


Actual Results:
  Browser crashes
  
Expected Results:
  Browser should not crash
Comment 1 Alice0775 White 2011-09-17 09:46:03 PDT
Regression window(m-c hourly),
Works:
http://hg.mozilla.org/mozilla-central/rev/fb5d85637013
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0a1) Gecko/20110916 Firefox/9.0a1 ID:20110916154748
Crashes:
http://hg.mozilla.org/mozilla-central/rev/acc41ac331ce
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0a1) Gecko/20110916 Firefox/9.0a1 ID:20110916203248
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=fb5d85637013&tochange=acc41ac331ce


Regression Windows( jm hourly),
Works:
http://hg.mozilla.org/projects/jaegermonkey/rev/b31b25125429
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0a1) Gecko/20110909 Firefox/9.0a1 ID:20110909040314
Crashes:
http://hg.mozilla.org/projects/jaegermonkey/rev/323595f354b1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0a1) Gecko/20110910 Firefox/9.0a1 ID:20110910223634
Pushlog:
http://hg.mozilla.org/projects/jaegermonkey/pushloghtml?fromchange=b31b25125429&tochange=323595f354b1
Comment 2 Alice0775 White 2011-09-17 10:02:15 PDT
On linux build, I got different Crash Signature but same regression window:
bp-46c8ff6e-969a-4513-9ae0-7ef992110917

Regression Window(jm linux build),
Works
http://hg.mozilla.org/projects/jaegermonkey/rev/b31b25125429
Mozilla/5.0 (X11; Linux i686; rv:9.0a1) Gecko/20110909 Firefox/9.0a1 ID:20110909040314
Crashes:
http://hg.mozilla.org/projects/jaegermonkey/rev/323595f354b1
Mozilla/5.0 (X11; Linux i686; rv:9.0a1) Gecko/20110910 Firefox/9.0a1 ID:20110910223634
Pushlog:
http://hg.mozilla.org/projects/jaegermonkey/pushloghtml?fromchange=b31b25125429&tochange=323595f354b1
Comment 3 Ekanan Ketunuti 2011-09-17 10:16:02 PDT
I cannot reproduce this on Win32.
Nightly cset d14291158db7
Mozilla/5.0 (Windows NT 6.1; rv:9.0a1) Gecko/20110917 Firefox/9.0a1
Comment 4 Ekanan Ketunuti 2011-09-17 11:09:43 PDT
pls ignore comment 3. I get random crashes when zoom into map.  
I didn't get any crash when zoom into satellite. 

bp-a718a9f4-cdc0-4b14-a74d-474872110917 
bp-83f4994c-c9c8-4ae9-8120-a0fea2110917
Comment 5 Alice0775 White 2011-09-17 11:55:37 PDT
This might be fixed by
85fb038d1dd1	Ed Morley — Backout latest JM merge for OSX 10.5 M-oth permaorange (see bug 687257) on a CLOSED TREE
Comment 6 Ed Morley [:emorley] 2011-09-17 12:12:05 PDT
I've retriggered nightly builds on 85fb038d1dd1, which hopefully might solve the problem.
Comment 7 Alice0775 White 2011-09-17 17:34:51 PDT
Fixed by bug 687257
I cannot reproduced any more on the following Windows and Linux build.

http://hg.mozilla.org/mozilla-central/rev/85fb038d1dd1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0a1) Gecko/20110917 Firefox/9.0a1 ID:20110917121100

http://hg.mozilla.org/mozilla-central/rev/85fb038d1dd1
Mozilla/5.0 (X11; Linux i686; rv:9.0a1) Gecko/20110917 Firefox/9.0a1 ID:20110917121100
Comment 8 Ed Morley [:emorley] 2011-09-18 03:41:03 PDT
Thanks Alice :-)

Note You need to log in before you can comment on or make changes to this bug.