Last Comment Bug 687257 - OSX 10.5 M-oth permaorange brought across by latest JM merge
: OSX 10.5 M-oth permaorange brought across by latest JM merge
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Brian Hackett (:bhackett)
:
:
Mentors:
Depends on:
Blocks: 687260
  Show dependency treegraph
 
Reported: 2011-09-17 08:45 PDT by Ed Morley [:emorley]
Modified: 2011-10-06 19:15 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Ed Morley [:emorley] 2011-09-17 08:45:35 PDT
The latest JM merge brought with it an OSX 10.5 M-oth permaorange that had been present on Jaegermonkey for a week.

Inspecting tbpl gives a rough regression range of: (do double check, as I may have made a mistake)
https://hg.mozilla.org/projects/jaegermonkey/pushloghtml?fromchange=b31b25125429&tochange=ab2af24a1dfa

However, due to the numerous follow-up bit by bit fixing changesets with no detailed description or bug number, it was just easier to back out the whole JM merge, rather than try and untangle everything and backout just that regression range. 

I'm not going to attempt to reopen whatever was backed out - given that this presumably will be resolved on JM soon - and most of the changesets don't have a bug number. Once the orange is fixed, I presume the easiest thing will just be to backout the backout at the same time as the next JM merge.

{
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/browser_popupNotification.js | Test timed out
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/browser_popupNotification.js | Found a tab after previous test timed out: http://example.org/
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/browser_tabMatchesInAwesomebar.js | Test timed out
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/browser_tab_dragdrop.js | tab0 uri - Got about:privatebrowsing, expected about:blank
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/browser_visibleTabs_bookmarkAllTabs.js | Bookmark All Tabs should be disabled since there are two tabs with the same address - Got false, expected true
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_bug597248.js | Test timed out
}
...followed by numerous others.

Example log:
https://tbpl.mozilla.org/php/getParsedLog.php?id=6434465&tree=Firefox
Comment 1 Ed Morley [:emorley] 2011-09-17 08:52:38 PDT
The backout of the merge:
https://hg.mozilla.org/mozilla-central/rev/85fb038d1dd1
Comment 2 Brian Hackett (:bhackett) 2011-09-18 15:45:21 PDT
Geez, sorry about this.  I thought I'd looked at the orange on JM before pulling to m-c, but not closely enough it looks like.

This orange was caused by bug 685358.  That bug has been a never ending nightmare since it landed on JM and I tried to back it out, but there were still residual problems.

Will fix this by keeping the backout on JM and just relanding the other improvements and fixes that came in since the last JM -> m-c merge.  Pushed to Try (https://tbpl.mozilla.org/?tree=Try&usebuildbot=1&rev=77dd152fd50f) and it looks good but not yet to JM as I can't push anything to JM (bug 687208).
Comment 3 David Mandelin [:dmandelin] 2011-10-06 19:05:42 PDT
Did this get fixed by a backout?
Comment 4 Brian Hackett (:bhackett) 2011-10-06 19:08:22 PDT
Yes.
Comment 5 Ed Morley [:emorley] 2011-10-06 19:15:48 PDT
This was fixed by the backout in comment 1, but was left open for the investigation in comment 2, which I'm presuming is now complete.

Removing tracking firefox9 since the initial landing + backout both landed on 9, so no action needed for any other branches/channels.

Note You need to log in before you can comment on or make changes to this bug.