Rogers needs full username@rogers.com for authentication - autoconfig gets it wrong

RESOLVED DUPLICATE of bug 677048

Status

Webtools
ISPDB Server
RESOLVED DUPLICATE of bug 677048
6 years ago
5 years ago

People

(Reporter: Joe Drew (not getting mail), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
The Thunderbird account autoconfiguration gets the server name correct for Rogers, but doesn't know that it needs to use the full email address for authentication. Right now it just uses username instead of username@rogers.com, which leads to an inability to get mail!

Also, Rogers doesn't actually support IMAP except on their wireless connections, so it's probably best to drop that as an option.

Sorry if this isn't the right place to file the bug - nothing else looked correct. :)
Component: Account Manager → ispdb
Product: Thunderbird → Mozilla Messaging
QA Contact: account-manager → ispdb
Version: unspecified → other
Joe can you provide the proper xml file the documentation is at https://developer.mozilla.org/en/Thunderbird/Autoconfiguration
(Reporter)

Comment 2

6 years ago
I have discovered that rogers.com actually chains to yahoo.com (via mx lookup), which means that it's only using %EMAILLOCALPART%, cf <https://live.mozillamessaging.com/autoconfig/v1.1/yahoo.com>. I think it's safe for yahoo.com to use the full email address, isn't it?
Hey Ben,

you've been talking to Yahoo in bug 493064.  Could you ask if using %EMAILADDRESS% instead of %EMAILLOCALPART% would continue to work for them?

Thanks,
Blake.

Comment 4

6 years ago
I already did.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 677048
(Assignee)

Updated

5 years ago
Component: ispdb → ISPDB Server
Product: Mozilla Messaging → Webtools
You need to log in before you can comment on or make changes to this bug.