Last Comment Bug 493064 - [config] imap.mail.yahoo.com is now available
: [config] imap.mail.yahoo.com is now available
Status: RESOLVED FIXED
[config]
:
Product: Webtools
Classification: Server Software
Component: ISPDB Database Entries (show other bugs)
: other
: x86 All
: -- enhancement with 5 votes (vote)
: ---
Assigned To: Ben Bucksch (:BenB)
:
Mentors:
http://groups.google.com/group/thunde...
: 547639 (view as bug list)
Depends on: 610264
Blocks: 614826
  Show dependency treegraph
 
Reported: 2009-05-14 13:22 PDT by David Pflug
Modified: 2013-03-19 11:12 PDT (History)
13 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
thunderbird-yahoo-imap.patch (2.36 KB, patch)
2010-03-06 13:32 PST, Linas
no flags Details | Diff | Review
thunderbird-yahoo-imap-3.1.patch (2.22 KB, patch)
2010-07-17 13:56 PDT, Linas
no flags Details | Diff | Review
Add IMAP server to yahoo config file (667 bytes, patch)
2010-11-22 18:52 PST, Ben Bucksch (:BenB)
bwinton: review+
gozer: review+
Details | Diff | Review
Make IMAP the default (6.61 KB, patch)
2010-11-25 16:15 PST, Ben Bucksch (:BenB)
no flags Details | Diff | Review
Make IMAP the default (1019 bytes, patch)
2010-11-25 16:17 PST, Ben Bucksch (:BenB)
bwinton: review-
Details | Diff | Review

Description David Pflug 2009-05-14 13:22:57 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b4) Gecko/20090508 Firefox/3.5b4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b3pre) Gecko/20090223 Thunderbird/3.0b2

I've confirmed this with netcat. If you send LOGIN initially (or after CAPABILITIES), it returns an error, but if you send ID with "GUID" "1", then it will allow login.

Reproducible: Always

Steps to Reproduce:
1. [nc,telnet] imap.mail.yahoo.com 143
2. 0 LOGIN valid_yahoo_mail@yahoo.com password
3. There is no 3.

And/or try to login to imap.mail.yahoo.com with Thunderbird
Actual Results:  
No login

Expected Results:  
login
Comment 1 Ludovic Hirlimann [:Usul] 2009-05-14 13:26:32 PDT
This is the way to make imap.yahoo.com working with imap. Marking confidential as this is a work around's yahoo paid service. If you use this with a non + account you probably violate the Yahoo's TOS.
Comment 2 Ludovic Hirlimann [:Usul] 2009-05-18 05:26:24 PDT
Hidding to protect Yahoo's TOS.
Comment 3 Ludovic Hirlimann [:Usul] 2010-02-21 23:34:04 PST
*** Bug 547639 has been marked as a duplicate of this bug. ***
Comment 4 Josh D S Davis 2010-02-22 16:01:22 PST
Ludovic, 
There is no TOS limitation against IMAP.  See the Yahoo Mail TOS at:
http://info.yahoo.com/legal/us/yahoo/utos/utos-173.html

Also, it is POP access that is a benefit of a paid account, not IMAP. See this URL for plus vs free differences:
http://help.yahoo.com/l/us/yahoo/mail/yahoomail/mailplus/overview/overview-03.html

IMAP is available to any (free) user.  Supported clients are Zimbra (a Yahoo product) and mobile clients.

Other IMAP clients are not supported, because there is no support structure for them.  The support cost of IMAP would be higher than POP.  Since the ToS disclaims guarantee of functionality/features, supportability doesn't matter.

The natural assumption would be that this protocol quirk is for their benefit but is not a "security through obscurity" issue.

As such, there is no real reason to make this a hidden bug unless you have other, documented information from Yahoo counsel which claims otherwise.

Here's a URL for a technical conversation on this issue from 2009:
http://groups.google.com/group/mozilla.dev.apps.thunderbird/browse_thread/thread/546356554c73f8ca

Here's a URL with howto code:
http://www.crasseux.com/linux/
Comment 5 Josh D S Davis 2010-02-22 16:10:41 PST
Zimbra Desktop (free product) link left out:
http://www.zimbra.com/products/desktop.html
Comment 6 Linas 2010-03-06 13:32:03 PST
Created attachment 430873 [details] [diff] [review]
thunderbird-yahoo-imap.patch

I'm attaching the crasseux.com changes in patch form.
It applies cleanly to at least thunderbird 3.0.2, 3.0.3 and comm-central.

The patch sends the ID GUID to all imap connections, but it should probably add a property to the accounts which regulated if it should be sent or not.
Comment 7 st63z 2010-06-01 10:32:25 PDT
I also voted for this bug, and agree with Linas that the ID GUID command should only be sent for Yahoo IMAP accounts, or accounts explicitly flagged by the user.

Patching this in Thunderbird source would seem to be a better way than the current option of each user having to rely on a local or hosted IMAP proxy for Yahoo accounts.

In addition to the helpful info from Josh, the following post has a few other links:

http://www.emaildiscussions.com/showthread.php?t=59575
Comment 8 Linas 2010-07-17 13:56:40 PDT
Created attachment 458111 [details] [diff] [review]
thunderbird-yahoo-imap-3.1.patch

Updated the patch for thunderbird 3.1
Comment 9 Patrick Cloke [:clokep] 2010-11-17 08:05:31 PST
I've been able to log into Yahoo IMAP successfully via SSL without these patches using the configuration available at http://www.theanimail.com/imap_server_settings.html

Service name: Yahoo!Mail
User name: user@yahoo.com
IMAP server: imap-ssl.mail.yahoo.com
Port: 993
SSL: yes
SMTP server: smtp.mail.yahoo.com
Port: 465
SSL: yes

I did not try at imap.mail.yahoo.com (without ssl), however.
Comment 10 aditsu 2010-11-21 17:50:33 PST
Thanks Patrick, I confirm that it works in SeaMonkey mail.
I used imap.mail.yahoo.com instead (with SSL/TLS, port 993) because imap-ssl.mail.yahoo.com doesn't match its certificate.
Comment 11 Linas 2010-11-22 07:33:51 PST
It was required when I tested it a few months ago.

Fixed by Yahoo!
Comment 12 WADA 2010-11-22 08:00:26 PST
FYI.
I could access Yahoo! Mail(US) via IMAP with no problem, with next definition, using Tb 3.1.5 on Win-XP.
  IMAP server: imap.mail.yahoo.com
  User name: <user>@rocketmail.com
  Port: 993, with "SSL/TLS" of Tb's setting enabled.

Note:
When mail address of <user>@rocketmail.com, problem in autoconfig of Tb 3.1 happened, which I stated in bug 583602 comment #11. Same problem of autoconfig of Tb 3.1 may happen on mail address of <user>@ymail.com.
Comment 13 Ben Bucksch (:BenB) 2010-11-22 18:45:48 PST
Works for me too with a @yahoo.de account.
Comment 14 Ben Bucksch (:BenB) 2010-11-22 18:47:52 PST
Also works with my old @yahoo.com account (created from Germany, though.)

Can somebody physically in the US please create a @yahoo.com freemail account and check with that?
Comment 15 Patrick Cloke [:clokep] 2010-11-22 18:49:19 PST
(In reply to comment #14)
> Also works with my old @yahoo.com account (created from Germany, though.)
> 
> Can somebody physically in the US please create a @yahoo.com freemail account
> and check with that?

I am physically in the US with a @yahoo.com freemail account. I've had it for years though (I did not just create it if that matters).
Comment 16 Ben Bucksch (:BenB) 2010-11-22 18:50:22 PST
Patrick: Cool. Could you please also try with username = user without @yahoo.com ?
Comment 17 Ben Bucksch (:BenB) 2010-11-22 18:52:54 PST
Created attachment 492550 [details] [diff] [review]
Add IMAP server to yahoo config file
Comment 18 Patrick Cloke [:clokep] 2010-11-22 18:59:15 PST
(In reply to comment #16)
> Patrick: Cool. Could you please also try with username = user without
> @yahoo.com ?

Ben: I was actually using it without the @yahoo.com all along! I verified it works both ways, however, for both the SMTP and IMAP servers. Note that I'm suffering from bug 610264, however.
Comment 19 Ben Bucksch (:BenB) 2010-11-22 19:03:27 PST
> I was actually using it without the @yahoo.com all along!

Cool. Thanks, Patrick, for verifying, and the original tip in comment 9.
Very valuable!

Waiting for reviews, to enable this config for all new setups in Thunderbird.
Comment 20 Ben Bucksch (:BenB) 2010-11-22 19:08:12 PST
Comment on attachment 492550 [details] [diff] [review]
Add IMAP server to yahoo config file

I may make POP3 the default, given that IMAP seems to be experimental, depending on how well it works.
Comment 21 Blake Winton (:bwinton) (:☕️) 2010-11-23 12:17:26 PST
Comment on attachment 492550 [details] [diff] [review]
Add IMAP server to yahoo config file

I'll give it the r+, but I think we should make pop3 the default for the reasons you suggest.  (Also, IMAP will still be listed first in the UI, so some people might choose it.)

Thanks,
Blake.
Comment 22 WADA 2010-11-23 17:55:39 PST
IMAP of Yahoo! itself is never experimental. IMAP and imap.mail.yahoo.com is officially announced and supported and used by Yahoo! US, although it's official for mobile phone/device only.
> http://mobile.yahoo.com/mail
One of reasons why IMAP for PC is not announced or supported officially yet may be that MS's standard mailer of PC or Apple's standard mailer of PC doesn't support 'ID ("GUID" "1")' yet, unless 'ID ("GUID" "1")' is Yahoo!'s confidential.
Yahoo! doesn't seem to prohibit use of 'ID ("GUID" "1")' by free mailers.

If Yahoo! does not want access to his IMAP server using free mailers of PC, putting imap.mail.yahoo.com in server config is better avoided. Use of imap.mail.yahoo.com from PC should be done only with user's own risk.
In this case, autoconfig's next problem should be resolved first.
  Stop button doesn't permit field change for Manual Setup or Re-test,
  when server in MX record is never IMAP/POP3 server.
  ("Edit" is not shown. phenomenon observed with @rocketmail.com, Tb 3.1.5)

I believe my Note PC at home connected to Internet via Home LAN/VDSL modem/Phone cable is an "all other mobile devices" in http://mobile.yahoo.com/mail by Yahoo!.
> http://mobile.yahoo.com/mail
> IMAP tab
> For all other mobile devices, supply the following information, if prompted:
> 1. Incoming Server - imap.mail.yahoo.com
So, I think "putting imap.mail.yahoo.com in server config by Mozilla Foundation" can not be prohibited. 

For POP3 of Yahoo!.
POP3 access is available only for charged "Yahoo! Plus" user.
As POP3 server itself is officially opened and as login by non Yahoo! Plus user is merely rejected, I think "making POP3 the default" won't produce any problem on current autoconfig.
Comment 23 Ben Bucksch (:BenB) 2010-11-23 18:08:15 PST
> POP3 access is available only for charged "Yahoo! Plus" user.

Officially, yes. But it works for all users.
Comment 24 WADA 2010-11-23 18:30:20 PST
(In reply to comment #23)
> > POP3 access is available only for charged "Yahoo! Mail Plus" user.
> Officially, yes. But it works for all users.

If so(how?), POP3 shouldn't be deaulted, to avoid additoinal bugs for complaint around "Leave Messages on Server" of POP3. Our recomendation should be IMAP, although we will perhaps need Yahoo! IMAP version of bug 402793 for Gmail IMAP.
> Bug 402793 [Meta] Gmail IMAP is still under construction
Comment 25 Ben Bucksch (:BenB) 2010-11-24 13:37:37 PST
Thanks for the reviews.

Commited SVN Revision 78132.
add imap server for yahoo. still default to pop3 for now. Bug 493064, r=bwinton, r=gozer, p=me 

We'll monitor how IMAP works and can change to default to IMAP later.
Comment 26 WADA 2010-11-25 07:58:51 PST
FYI.
I've opened meta bug 614826 for Yahoo! IMAP related issues.
Comment 27 Ben Bucksch (:BenB) 2010-11-25 16:14:51 PST
<http://mobile.yahoo.com/mail> sounds very official and supported to me. I'd make IMAP the default, unless bug 610264 is a commonplace problem and not just with mailboxen of 1 GB or so.
Comment 28 Ben Bucksch (:BenB) 2010-11-25 16:15:55 PST
Created attachment 493306 [details] [diff] [review]
Make IMAP the default
Comment 29 Ben Bucksch (:BenB) 2010-11-25 16:17:03 PST
Created attachment 493307 [details] [diff] [review]
Make IMAP the default
Comment 30 WADA 2010-11-25 18:15:32 PST
(In reply to comment #27)
> unless bug 610264 is a commonplace problem and not just with mailboxen of 1 GB or so.

Unfortunately, that bug seems to occur always if more than 4999 mails exist in a folder and Tb's "uid fetch a:b,c:d,...y:z ..." falls in more than 4999 mails(e.g. first open of folder after account definition, Repair Folder. it seems no problem if "uid fetch 1:* flags").
However, it's similar to file size limitation of local mail folder(still problem), file size limitation of offline-store(already resolved).
So, we will probably be able to manage users by informing about workaround of "keep number of mails in a folder less than 5000", with description like next;
  - It's current restriction of Yahoo! IMAP.
  - Yahoo! IMAP is for mobile users like iPhone.
  - It's never Tb's RFC violation nor incomliance of Tb with RFC.
Comment 31 aditsu 2010-12-07 01:34:23 PST
I'm unable to connect to yahoo mail since today - "Login to server imap.mail.yahoo.com failed."
Does anybody else have this problem, or does it still work?
Comment 32 WADA 2010-12-07 01:56:11 PST
Curretly no problem in access to imap.mail.yahoo.com (from Japan, @rocketmail.com). Four @rocketmail.com accounts, minimum accessing; max cached connections=2, disable IDLE command use, disable automatic new mail checking, no offline-use=on folder, no concurrent Web mail access. No POP3 access(POP3 is not enabled for my accounts yet).
Comment 33 aditsu 2010-12-07 02:02:27 PST
I just noticed that pidgin also failed to log in to yahoo messenger, and it suggested re-logging in to the yahoo website.
After I did that, both pidgin and imap started working again.
Comment 34 WADA 2010-12-07 02:56:22 PST
(In reply to comment #33)
> and it suggested re-logging in to the yahoo website.
> After I did that, both pidgin and imap started working again.

If login to yahoo website was solution, it may be simillar issue to Google's one.
> http://getsatisfaction.com/mozilla_messaging/topics/thunderbird_suddenly_wont_work_with_gmail_login_to_server_failed

Repeated logout/login can happen especially when offline-use=off, if user quickly switches mails in an IMAP folder.
> https://bugzilla.mozilla.org/show_bug.cgi?id=565852#c25
In this case, Gmail seems to temporalily lock account, because such behaviour is similar to DoS attack.
In such situation, if user requests "forcing CAPTHA" option for his Gmail account, Gmail looks to request unlock operation by user at Web page like next, upon next access to IMAP folder by Tb, and connection request by Tb via IMAP fails.
> https://www.google.com/accounts/DisplayUnlockCaptcha
In this Gmail case, disabling of "forcing CAPTHA option by user" was a workaround.
Comment 35 hcwang 2010-12-10 11:23:50 PST
Hi all, 

I'm the PM for the Yahoo! Mail Platform and I wanted to drop a note on this thread (which David Ascher pointed me to).  Yahoo is working with Mozilla to bring IMAP access to Thunderbird but we are not prepared for this currently.  We will not support users that access IMAP from the desktop today.  This being said we are actively pursuing an open IMAP solution and have started by piloting for mobile.

Thanks much
Herbert
Comment 36 Blake Winton (:bwinton) (:☕️) 2010-12-10 11:35:21 PST
Comment on attachment 493307 [details] [diff] [review]
Make IMAP the default

Based on Herbert's comment, I think we should probably remove this from the Yahoo config until they support it, and certainly not make it the default until that time.

Thanks,
Blake.
Comment 37 Ben Bucksch (:BenB) 2011-06-02 15:56:48 PDT
We now have POP as default, with IMAP as option for those users who specifically want it. I think that takes care of comment 35.

FIXED
Comment 38 Ben Bucksch (:BenB) 2011-06-02 15:57:32 PDT
Compare bug 661510

Note You need to log in before you can comment on or make changes to this bug.