Last Comment Bug 68773 - flash intro hangs mozilla
: flash intro hangs mozilla
Status: VERIFIED DUPLICATE of bug 58339
: hang
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: x86 Linux
: -- critical (vote)
: mozilla0.9.1
Assigned To: av (gone)
: shrirang khanzode
:
Mentors:
http://www.didomusic.com
: 75383 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-13 22:43 PST by Boris Zbarsky [:bz] (still a bit busy)
Modified: 2001-05-31 15:07 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Boris Zbarsky [:bz] (still a bit busy) 2001-02-13 22:43:53 PST
BUILD: linux 2001-02-12-08

FLASH VERSION: version 4, from Macromedia.

REPRODUCIBLE: always

STEPS TO REPRODUCE: go to the url given

EXPECTED RESULTS:
1) pops up a flash window
2) plays intro
3) shows some content in same window

ACTUAL RESULTS
1) pops up flash window
2) starts playing intro
3) Shows some quotes from people/magazines and whatnot
4) Shows the text "Dido no Angel"
5) hangs instead of refreshing window to show the content.
Comment 1 Boris Zbarsky [:bz] (still a bit busy) 2001-02-13 22:46:37 PST
adding keywords
Comment 2 shrirang khanzode 2001-02-19 09:57:53 PST
hmm, works fine with flash player 5 and linux trunk build 0215. I see the popup 
and it's contents load fine and the browser does not hang. Boris , can you 
please retry this ? Is this happening for you 100% ? Thanks!
Comment 3 Boris Zbarsky [:bz] (still a bit busy) 2001-02-19 12:43:02 PST
This is happening to me 100% with flash player 4 and build 2001-02-16-08.

Where can I get flash player 5 for Linux to try with?
Comment 4 shrirang khanzode 2001-02-19 13:04:41 PST
macromedia's website have a flash player 5 for linux now (the default plugin 
pointed me to that link..)
Comment 5 Boris Zbarsky [:bz] (still a bit busy) 2001-02-19 14:11:25 PST
Still a problem with Flash player 5 and build 2001-02-19-08.

Anything I can provide that would help in diagnosing this?  Would knowing which
function that thread is in when it hangs help?
Comment 6 shrirang khanzode 2001-02-19 14:14:24 PST
yeah, pleas provide more info...thanks!
Comment 7 Boris Zbarsky [:bz] (still a bit busy) 2001-02-19 14:41:11 PST
OK.  It worked for me once, then hung again 3 times in a row...

Here is what I see on the console with a debug build.  When I start Mozilla, all
the plugins are registered (twice). Then when I go to the web page, all the
plugins are again registered twice.  Then the output says:

For application/x-shockwave-flash found plugin
/home/bzbarsky/mozilla/debug/mozilla/dist/bin/plugins/libflashplayer.so
Inside ns4xPluginInstance::Start(void)...
Inside ns4xPluginInstance::SetWindow(0x870ef94)...
About to create new ws_info...
About to create new xtbin of 620 X 380 from 0x8897c60...
About to show xtbin(0x88a98a8)...
completed gtk_widget_show(0x88a98a8)
About to call CallNPP_SetWindowProc()...
Falling out of ns4xPluginInstance::SetWindow()...
created stream for http://www.didomusic.com/intro.swf
InstantiateEmbededPlugin.. returning
killing stream for http://www.didomusic.com/intro.swf
Inside ns4xPluginInstance::SetWindow((nil))...
ns4xPluginInstance::Stop()
Enabling Quirk StyleSheet
********** Got plugins path:
/home/bzbarsky/mozilla/debug/mozilla/dist/bin/pluginsIsPluginFile(/home/bzbarsky/mozilla/debug/mozilla/modules/plugin/default/unix/libnullplugin.so)
LoadPlugin()
/home/bzbarsky/mozilla/debug/mozilla/modules/plugin/default/unix/libnullplugin.so
returned 81be5a8
GetMIMEDescription() returned "*:.*:All types"
Registering plugin 0 for: "*","All types",".*"
IsPluginFile(/home/bzbarsky/mozilla/debug/mozilla/dist/bin/plugins/libflashplayer.so)
LoadPlugin()
/home/bzbarsky/mozilla/debug/mozilla/dist/bin/plugins/libflashplayer.so returned
81beb48

At this point Mozilla hangs.

Stack trace to this point:

#0  0x40409a04 in __libc_open () from /lib/libc.so.6
#1  0x402fdd1c in __DTOR_END__ () from /lib/libpthread.so.0
#2  0x41c70ada in _IcePaAuthDataEntries ()
   from /home/bzbarsky/mozilla/debug/mozilla/dist/bin/plugins/libflashplayer.so
#3  0x41b6f1a1 in nsPluginFile::GetPluginInfo (this=0xbfffbd28, info=@0xbfffbd04)
    at nsPluginsDirUnix.cpp:245
#4  0x41b65e6b in nsPluginHostImpl::ScanPluginsDirectory (this=0x81b4d38, 
    pluginsDir=@0xbfffbda8, compManager=0x806b4b0, layoutPath=0x8838e88, 
    checkForUnwantedPlugins=0) at nsPluginHostImpl.cpp:3255
#5  0x41b661c2 in nsPluginHostImpl::LoadPlugins (this=0x81b4d38)
    at nsPluginHostImpl.cpp:3337
#6  0x41b6506d in nsPluginHostImpl::IsPluginEnabledForType (this=0x81b4d38, 
    aMimeType=0x4180ec03 "application/x-oleobject") at nsPluginHostImpl.cpp:2813
#7  0x4144ebd1 in nsObjectFrame::Reflow (this=0x891e120, aPresContext=0x8846c48, 
    aMetrics=@0xbfffc1bc, aReflowState=@0xbfffc1f8, aStatus=@0xbfffc324)
    at nsObjectFrame.cpp:745
 

Using RedHat 6.2, with glibc-2.1.3-21
Comment 8 Peter Lubczynski 2001-02-20 16:39:03 PST
Dup of bug 67933? Perhpas this is different but caused by the same problem, 
double registration?

I need to figure out how to debug on Linux. gdb keeps crashing.
Comment 9 Mark Schonbach 2001-02-24 10:52:37 PST
This bug still occurs with 0.8 and the latest nightly (2001-02-24-05).  I'm
using Flash plugin 5.0 r45.  Any workaround or fix in the works?  If anyone
needs any more info, or debugging, email me intrstructions on how to capture it,
and I'd be glad to provide it. 
Comment 10 Mark Schonbach 2001-03-01 09:34:11 PST
It seems to be fixed in 2001-02-28-08.  Someone else want to confirm this?
Comment 11 shrirang khanzode 2001-03-01 09:40:24 PST
this just works fine for me...(0226 trunk linux)
Comment 12 Boris Zbarsky [:bz] (still a bit busy) 2001-03-01 10:11:02 PST
Still seeing this in a CVS build from the evening of 2001-02-08, but it's harder
to trigger.  Steps to reproduce:

1)  Go to the page.  
2)  Watch through the intro
3)  wait for the flash navigation stuff to come up.  This _does_ work now.
4)  Close the flash window
5)  reload the original page (reload button or control-R)

This causes mozilla to hang reproducibly for me (10 times out of 10).
Comment 13 karnaze (gone) 2001-03-14 17:10:20 PST
Moving to m0.9.1
Comment 14 Brett Granger 2001-04-04 12:39:52 PDT
Don't know if people are interested in more test cases, but we are seeing that
this bug acts differently under certain scenarios.  Sometimes it hangs mozilla,
sometimes it just stops the Flash audio from working but the graphics still
display, and sometimes it works just fine.  The difference between hanging
mozilla and just losing audio appears to depend on which audio drivers are on
the system.  This is on Linux milestone 0.8.1 with Flash plugin 5.0r47.

The key factor seems to be whether or not the Flash movie has any audio in it. 
Flash movies that contain no audio seem to be able to reload reliably with no
problems.  Flash movies with audio sometimes cause problems and sometimes don't,
depending on the page that they are embedded in.  It appears that in some pages
in which the flash movie is embedded in one frame of a multi-frame page the bug
will also not happen.

Examples:
http://www.warnerbros.com/pages/link/external.jsp?url=http%3a%2f%2fharrypotter.warnerbros.com%2fweb%2fhome.jsp&fromtout=home_menu_movies_item6

This page contains a flash movie with audio.  However, the flash movie is only
in one frame of a frameset and so seems to reload reliably every time (the audio
chain is getting torn down before the next audio chain is instantiated?).

However, if you go directly to a page which contains the same Flash movie
without any of the frameset wrapping, it causes problems when the reload button
is clicked:
http://harrypotter.warnerbros.com/web/home.jsp

A similar (the same?) problem is encountered if you attempt to open two flash
movies with audio simultaneously.  Open two browser windows and then load the
harrypotter.warnerbros.com page into each one separately.  The movie will start
fine in the first window, but when the second window tries to load the movie
either audio will stop playing and won't come back until mozilla restarts or
mozilla will hang.

It appears that the Flash plugin is trying to access the audio device and chokes
if it is already in use, so the bug may be Macromedia's.  However, shouldn't
reloading a page tear down the previous plug-in instantiation which would free
up the audio device so that reloading a flash page won't cause problems?  In the
Harry Potter example with the frame set that seems to happen and it reloads
reliably.  In the case with no frame set, it appears that this doesn't happen.
Comment 15 Brett Granger 2001-04-04 13:11:10 PDT
BTW, this bug does not happen with Linux Netscape 4.x with the Flash 5.0r47
plugin -- reloading flash movies works just fine and loading flash movies with
audio in more than one window simultaneously does not cause a problem.  Maybe
it's not a Macromedia bug after all?  Maybe a bug in the Netscape 4.x plug-in
compatibility layer?

Comment 16 serge (gone) 2001-04-04 16:29:27 PDT
It sounds like a dup of 62460 [59653[36272]] 
I was unable to hang it myself, but it would be really interesting to get strace 
output in this case.
Comment 17 Brett Granger 2001-04-05 08:45:32 PDT
I'd be happy to strace it, but am unfamiliar with strace.  Any hints as to the
command line I should use and whether I should attach to the process in progress
(how do I figure out which of the many mozilla-bin pids) or just wrap strace
around the whole thing?
Comment 18 Peter Lubczynski 2001-04-10 21:42:38 PDT
*** Bug 75383 has been marked as a duplicate of this bug. ***
Comment 19 Peter Lubczynski 2001-05-02 12:26:26 PDT

*** This bug has been marked as a duplicate of 58339 ***
Comment 20 Chad Austin 2001-05-31 15:07:48 PDT
verified dups

Note You need to log in before you can comment on or make changes to this bug.