New Folder dialog is too small

VERIFIED FIXED

Status

SeaMonkey
MailNews: Message Display
--
minor
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: Mirek Hankus, Assigned: Navin Gupta)

Tracking

({polish})

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
1. RightClick on one of subscribed folders, select  New Subfolder. 
2. New dialog appears titled New Folder in which buttons OK and Cancel 
 are not visible.

I'll attach screenshot

Build id: 2001021320
I have fonts set to Large Fontst on my Windows (if it matters).
(Reporter)

Comment 1

18 years ago
Created attachment 25256 [details]
Screenshot of NewFolder dialog

Comment 2

18 years ago
Worksforme using a 02/12 build. This may be a theme problem, or something that
has to do with your big font.

Reporter, is this also happening in Classic for you?  Cc'ing hewitt.
new folder -> naving.
Assignee: sspitzer → naving

Comment 4

18 years ago
I think there is already a bug about this...
QA Contact: esther → sheelar
(Assignee)

Comment 5

18 years ago
To get rid of window.sizeToContent() , we had to use fixed sizes as 
shown in the patch submitted by disttsc@bart.nl. Here is what the problem will 
be with fixed size window, when font size changes.

From the last patch in bug #52564. This bug cannot be fixed until 
window.sizeToContent works on all platforms

RCS file: /cvsroot/mozilla/mailnews/base/resources/content/newFolderDialog.xul,v
retrieving revision 1.1
diff -u -r1.1 newFolderDialog.xul

We cannot do much until window.sizeToContent() is fixed for all platforms
--- newFolderDialog.xul 2000/12/16 00:42:38     1.1
+++ newFolderDialog.xul 2000/12/21 00:26:43
@@ -34,6 +34,7 @@
         title="&newFolderDialog.title;"
         align="vertical"
         class="dialog"
+        width="200" height="180"
         onload="onLoad();">
 
   <script type="text/javascript" src="chrome://global/content/strres.js"/>
@@ -54,7 +55,7 @@
     <text value="&description.label;" class="label" 
accesskey="&description.accesskey;" for="msgNewFolderPicker"/>
 
     <box align="horizontal">
-      <menu id="msgNewFolderPicker" oncommand="doEnabling(); 
window.sizeToContent();"/>
+      <menu id="msgNewFolderPicker" oncommand="doEnabling();" crop="right" 
flex="1"/>
       <spring flex="1"/>
     </box>
Status: UNCONFIRMED → NEW
Ever confirmed: true
*** Bug 72662 has been marked as a duplicate of this bug. ***
adding window.sizeToContent() bug as a blocker.

Can we do heights in units other than px? If we can size in em, that would be
very nice....

os->all -- happens to anyone with a high-res screen.
Depends on: 72152
Keywords: polish
OS: Windows ME → All
Hardware: PC → All

Comment 8

17 years ago
Navi, The dialog looks even worse with Classic theme (see screenshot in bug 72662 ).
Can't see what the buttons are, and wether they are buttons at all or something
else.

can you just make it a bit bigger in newFolderDialog.xul?

- width="200" height="180"
+ width="260" height="210"

those sizes should make buttons visible on high resolution screens.

Comment 9

17 years ago
Created attachment 30877 [details] [diff] [review]
proposed patch

Comment 10

17 years ago
the above fix does it for me
dialog appears just right on Win2K in high res

I'm not sure how it will affect IMAP stuff in bug 52564

Updated

17 years ago
Keywords: patch, review
(Assignee)

Comment 11

17 years ago
No, this is not the correct fix. I will investigate if sizeToContent() is working 
now ?

Comment 12

17 years ago
I understand you would like to use sizeToContent() for this dialog and probably
for many other dialogs as well.
I didn't find any reference to sizeToContent() in newFolderDialog.js, yet when
you don't explicitly specify window size in newFolderDialog.xul the window sizes
itself properly under Win2K.
If sizeToContent() is called for it frome some other place I can understand your
concern about it crashing Linux machines.
Or maybe other OSes don't handle this the same way Windows does and this fix
doesn't work for them.

In either way, the issue of sizing of this dialog has been addressed in bug
52564, and as I understand a temp fix has been placed by setting a fixed window
size. That size however is too small for high res screens, and buttons are not
visible, especially under Classic theme.

If the above fix doesn't work for anything else apart from Windows, it would be
good to adjust the fixed size to make everyone happy until sizeToContent() is fixed.

attaching new small fix.

Comment 14

17 years ago
related to bug 69702?

Comment 15

17 years ago
*** Bug 81644 has been marked as a duplicate of this bug. ***

Comment 16

17 years ago
Removing <width="200" height="180"> seems to fix this bug. Isn't this correct?

Summary: New Folder dialog is to small → New Folder dialog is too small
(Assignee)

Comment 17

17 years ago
I am working on UW:IMAP new folder dialog bug 52564, will fix this also. 

Comment 18

17 years ago
*** Bug 84987 has been marked as a duplicate of this bug. ***

Comment 19

17 years ago
*** Bug 87789 has been marked as a duplicate of this bug. ***

Comment 20

17 years ago
Navin, if that other bug will fix this - then please duplicate this and adjust
the summary on the new bug.
(Assignee)

Updated

17 years ago
Depends on: 52564
(Assignee)

Comment 21

17 years ago
this should be fixed because of the partial fix landed for #52564
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 22

17 years ago
*** Bug 84538 has been marked as a duplicate of this bug. ***

Comment 23

17 years ago
verified,
win98, mac, linux-trunk build 2001080208
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.