Open Bug 688166 Opened 11 years ago Updated 1 month ago

macOS Apple Mail Import broken - "No mailboxes were found to import"

Categories

(MailNews Core :: Import, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

People

(Reporter: bugzilla.mozilla.org, Unassigned)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [gs])

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_1) AppleWebKit/534.48.3 (KHTML, like Gecko) Version/5.1 Safari/534.48.3

Steps to reproduce:

OS X 10.7.1, Thunderbird 6.0.2, No mail accounts in thunderbird.  Several mail accounts and saved ("On My Mac") folders in Apple Mail

Tools, Import menu.  Select to import mail from dialog.  Select Apple Mail from list (shows options Apple mail and Eudora).  Press Next


Actual results:

Message displayed "No mailboxes were found to import"
New folder appears under "Local Folders" called Apple Mail Import" which is emplt and has no sub-folders


Expected results:

Mailboxes should have been imported (I would expect)
The closest is bug 621417 but in that case the top level folder(s) are being imported without sub-folders.  In my case nothing at all is being imported.

Tried it again with Error Console (cleared before starting) and nothing appears in the "All" section through doing the import (that does nothing).

In my case I have around 4 POP/SMTP mail accounts (that are not configured in Thunderbird) and a large number of folders/sub-folders/messages under "On My Mac".  I also have a large number of RSS feeds in Apple Mail.
Confirming the same problem here.

Running Intel Mac OSX Lion 10.7.1 and Thunderbird 6.0.2 or Thunderbird 3.1.14 and it reports:

No mailboxes were found to import

No account settings and no mail whatsoever is imported.

Also, when selecting the Import wizard the "Everything" option is greyed out.

Similar posting on the Apple discussions forums sees other users having the same problem.

Possibly Lion has broken a dependency for Thunderbird's Apple Mail Import features?
Wayne do we have a Lion tracker bug ?
Summary: OS X Apple Mail Import → [Lion] OS X Apple Mail Import
Status: UNCONFIRMED → NEW
Ever confirmed: true
If this is a confirmed bug, any idea of how long before a fix might make it into a release version or beta build?

I know you devs are busy (and awesome), just wondering if I should try waiting this out or try finding an older pre-lion computer and moving my mail there, then importing with TB, then transferring it all back to my Lion computer.
Confirming the issues is still present with v7.0.1 of Thunderbird.
(In reply to seanspratt from comment #7)
> Confirming the issues is still present with v7.0.1 of Thunderbird.

and will be until someone fixes it :)
you'll see activity in this bug when it happens.
sorry, no ETA
Any news on this?  A lot of us are so desperate ;)
A patch would be welcomed
The lot of us that are desperate should vote for this bug - I was suprised to see that it only has 2 votes.

Now that Thunderbird is nicely supporting Retina, has everyone else figured out some way to get their mail out of Mail?   Care to share?

Thanks!
It seems that the reason things are broken is because Apple Mail has inserted a new level of directory into its mbox.  The actual mbox for import is _inside_ the directory called folder.mbox (or so I am deducing).

There is a workaround for manual transfer.     It's laborious if you have a lot of folders:

• Download the ImportExportTools add-on and install it in TB using the Add-ons Manager.
• Download and install emlx to mbox Converter.app.
• In a finder window go to ~/Library/Mail/POPmyaccount name/Inbox/Messages/ and select ALL messages.
• Launch TB and the emlx to mbox Converter.
• Drag the selected messages and drop them in the Converter window and click Save mbox... 
A file "Messages.mbox" will be created on Desktop.
• In the TB Folder pane R-click on e.g. Inbox and in the context menu choose Import/Export -> Import mbox file -> OK
• in the Finder window select the "Messages.mbox" file, then "mbox" and click "Open".
• The imported message file will appear as a sub-folder (called "mbox") of the TB Inbox folder.
The next imported Messages.mbox file would appear as a sub-folder named somewhat like mbox790, 
but you may rename the imported folders to Inbox, Sent, Drafts, ... etc to distinguish the import folders and 
later copy the imported messages to the genuine TB folders or other sub-folders you will have created.
Anyone willing to write a patch for this, we would accept it and would help you get the pacth in
Duplicate of this bug: 801597
nightmare and silly. should allow manual selection of Mail folder.
I'm not sure if comment #12 is referring to the same format.  They had updated the format around Oct 2012 in Mountain Lion; the one that's included in Mavericks uses the same layout.

The top level directory is ~/Library/Mail/V2; beyond that it's tough to make heads or tails of what's going on.
(In reply to Frank Solensky from comment #16)
> updated the format around Oct 2012 in Mountain Lion;
Make that Oct 2013
I installed Thunderbird just a couple days ago. When I tried to import my mail from Apple's Mail app, Thunderbird just said, "nothing found."  
I beg to differ, of course, because there are many megs of mail in the (confusing) Apple Mail folders.
I'd love to use Thunderbird, guys, but I need my previous mail ... :-(
Removing myslef on all the bugs I'm cced on. Please NI me if you need something on MailNews Core bugs from me.
Duplicate of this bug: 1210324
Summary: [Lion] OS X Apple Mail Import → [Lion] OS X Apple Mail Import broken - "No mailboxes were found to import"
I find it quite unbelievable that this bug has not been fixed yet. 
I have some 20 Gb of local emails in Mail.app that I cannot easily import to Thunderbird. I am running OSX 10.9.5 on a 2011 PowerBook Pro.
It's open source, you can fix it yourself ;-) (or hire someone to do it).
Best work around I found is given here:

http://forums.mozillazine.org/viewtopic.php?p=14069759#p14069759

In short: Quit TB. In Mail.app select the folder to be transferred to TB, then Mailbox/Export Mailbox it. The exported .mbox folder contains a file called simply mbox that contains all messages. Rename this file to that of the original folder (or choose a new name), then copy it to the TB "Local Folders" folder at user/Library/Thunderbird/Profiles/xxxxxxxx.default/Mail/Local Folders. Repeat for all other folders to be transferred. Restart TB and the folders will appear as subfolders in the Local Folder.
Duplicate of this bug: 621417

Still broken as of Thunderbird 78 on macOS, 9+ years later.

Worse, Thunderbird 78's import function still lists Mail as an option. Then import fails. Then Thunderbird fails to throw a useful error message.

Since Mac Mail import no longer works, I recommend taking Mail off Thunderbird's import options list until the importer gets fixed.

@kerstel's Mac Mail manual import method from above worked for me... but was a hassle with >250 email boxes. If I wasn't already a power user, I might have given up.

In my experience, this is precisely the sort of hassle that convinces potential new users not to adopt.

** 11 YEARS LATER, Mac Mail import is STILL broken** in Thunderbird 91.7.0 (the current release version available when I tested today, 27 March 2022).

Yet Thunderbird 91 still lists Mac Mail import as an option. Then throws an error message that it found no mailboxes to import.

This is not exactly laying out the welcome mat for new users wanting to migrate from Mac Mail.

In fact, I am just today recommending to a tech-savvy Mac-using friend that she NOT adopt Thunderbird. And that makes me sad.

Thunderbird is a wonderful, amazing power tool and I had high hopes for it when I adopted it. Maybe I can still get it to work for me, a power user. But it's clearly NOT suitable for ordinary people, or busy execs, or busy tech entrepreneurs like my friend. These folks don't have the time, attention, or skills to deal with serious issues such as having to hand-import Mac Mail mailboxes one at a time. Or the four -- wait, make that five -- crash bugs I found today in Thunderbird 91, which involve critical functionality such as global Search. That one of those bugs dates back at least to Thunderbird 78 tells me that even serious workflow-affecting bugs aren't getting fixed, another point against.

The people I most want to recommend Thunderbird to need above all else reliable, it-just-works email that they don't have to fight with so they can get their work done... and currently, Thunderbird can't provide that.

I hope this situation can get turned around. Thunderbird is truly wonderful and I love it.

(In reply to account from comment #26)

Yet Thunderbird 91 still lists Mac Mail import as an option. Then throws an error message that it found no mailboxes to import.

I haven't yet used it, but you might test what recently shipped in beta 97 from Bug 1720042 - Order and logic of import dialogs should be changed to allow selecting the app to import before what to import. It specifically has a new importer for Mac. The current beta is available at https://www.thunderbird.net/en-US/#channel (installing and starting beta will cause the beta to use a new thunderbird profile, so be aware of https://support.mozilla.org/en-US/kb/using-multiple-profiles)

Thunderbird is a wonderful, amazing power tool and I had high hopes for it when I adopted it. Maybe I can still get it to work for me, a power user. But it's clearly NOT suitable for ordinary people, or busy execs, or busy tech entrepreneurs like my friend. These folks don't have the time, attention, or skills to deal with serious issues such as having to hand-import Mac Mail mailboxes one at a time. Or the four -- wait, make that five -- crash bugs I found today in Thunderbird 91, which involve critical functionality such as global Search.

I have 12 accounts on a Mac and a large message store, and not having such problems, so I'm not sure your bad experience extrapolates to the general public.

What are your crash IDs?

Flags: needinfo?(account)

Using 103 daily on Mac 12.5 the results in the UI suggest the import was successful, but

  • In error console I see
    12:02:17.220 debuggee 'resource://devtools/shared/loader/base-loader.js:291' would run builtin-modules.js:209:11
    12:02:17.391 NS_ERROR_UNEXPECTED: Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getBoolPref]
  • And "Apple Mail Import" folder in Thunderbird is empty.

No crash

Blocks: tb-mac
Flags: needinfo?(account)
Summary: [Lion] OS X Apple Mail Import broken - "No mailboxes were found to import" → macOS Apple Mail Import broken - "No mailboxes were found to import"

I've tried this repeatedly on Thunderbird 102.0b8 AND Thunderbird 103 Daily on macOS 12.4.
Attempting to import an active Apple Mail account -- using the detected ~/Users/jason/Library/Mail directory OR manually selecting all possible mail profile directories -- results in an empty import.

However, Thunderbird UI says that the import completes. The resulting mail folder is empty.

Using current release 102.2.0, trying to import from a "Mail" folder copied from a Time Machine backup. The import immediately says "complete", but the "Apple Mail Import" folder is empty. There are no error messages in the UI or Thunderbird's error console.

You need to log in before you can comment on or make changes to this bug.