Closed Bug 621417 Opened 14 years ago Closed 6 years ago

Tools>Import>Apple Mail does not import most nested Folders

Categories

(Thunderbird :: Migration, defect)

x86_64
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 688166

People

(Reporter: grischa, Unassigned)

Details

(Whiteboard: dupeme?)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_5; en-US) AppleWebKit/534.13 (KHTML, like Gecko) Chrome/9.0.597.19 Safari/534.13
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.13) Gecko/20101207 Thunderbird/3.1.7

I have a complex hierarchy of folders in Apple Mail in the "On my Mac" section.
The Tools -> Import -> Apple Mail feature only imports the top level.
Further, it imports some of the Subfolders from all accounts (even disabled ones) in the Mail.app directory, but not all of them. Specifically it does not import [Gmail] folders.


Reproducible: Always

Steps to Reproduce:
1. Have deep folder structure in Apple Mail "On My Mac"
2. Use Tools>Import>Mail>Apple Mail in Thunderbird
3. Examine results in Thunderbird
Actual Results:  
Folders deeper than 1 are missing.

Expected Results:  
Import the exact same folder structure that is found in Apple Mail

The applemailimportlog log showed no errors.
Of note: during import of accounts the depth was 2, and for the one nested folder that worked it said 3, together with "Found what looks like an .mbox container:"
During import of the "On My Mac" folders (folder Mailboxes) the depth was 1 always and no .mbox containers were found even though there are many in the directory.

Happy to help with testing or providing more logs.
Whiteboard: dumpe?
I am actually getting a message "No mail to import" from TB (17.0.3) using Mail.app 6.2 under OS X 10.8.2

Very frustrating and seems to have been around for a while.
Still not solved. Thunderbird won't import anything. Import-Export Tools won't import from separate mboxes either.
duplicate of bug 688166 ?
Flags: needinfo?(Nomis101)
(In reply to Wayne Mery (:wsmwk) from comment #4)
> duplicate of bug 688166 ?

I think so.
Flags: needinfo?(Nomis101)
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.