Closed Bug 688183 Opened 10 years ago Closed 10 years ago

Keyboard shortcut interferes with the new built-in inspector shortcut

Categories

(Other Applications :: DOM Inspector, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: ahal, Unassigned)

Details

In recent nightlies (fx 8.0a), the new built-in inspector was added. The built-in inspector and DOM Inspector both have the same keyboard shortcut <Ctrl><Shift>-I
Should add this is unverified in OSX
Press <Ctrl><Shift>-I

Expected results:
Firefox's built-in inspector pops up

Actual results:
DOM Inspector pops up

It would be nice to have two different shortcuts.
bug 569054
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WONTFIX
I resolved this WONTFIX due to the expected results; the same sentiment goes for any other suggestion where Ctrl/Cmd+Shift+I results in anything that involves, by default, DOM Inspector not opening (when it's installed).  This conversation has already passed.  Even with my own pre-emptive attempts to be cautious and play nice here, the suggestions still came to do what we did.  (In particular, see bug 569054, comment 5 and bug 569054, comment 8.)

However, feel free to repurpose this bug and re-open for a different set of expected results (e.g., conditionally remapping the devtools inspector key).

(For the sake of continuity, meandering Bugzilla reader, bug 747603 is related.)
Duplicate of this bug: 764110
devtools inspector has two set of keys: CTRL+SHIFT+I and F12

DOMi on other hands at this point has none, with a proposed resolution is WONTFIX.

Great.
Reread my message.

The bug as written was that pressing Ctrl+Shift+I opened DOM Inspector (when installed) instead of the devtools inspector.  I marked the bug WONTFIX in response to the request that Ctrl+Shift+I *not* open DOM Inspector.

If you're using that shortcut expecting it to open DOM Inspector, and it's not happening, then that's the complete opposite of Andrew Halberstadt's request, and it's an entirely different bug.

In any case, I stepped down from maintaining DOM Inspector over two years ago, and I don't think anybody else is working on it.  So DOMi is effectively dead or close to it.

I started a project to create a replacement meant to be very close in spirit to DOM Inspector (in contrast to Firebug or the devtools stuff).  <https://addons.mozilla.org/en-US/firefox/addon/sepsis-inspector/>  The Ctrl+Shift+I shortcut does work there (controlled by the sepsis.inspector.integration.overrideKeys pref in about:config).  Downside: It's pre-1.0, never reached the point where it could match DOMi feature-for-feature, and the Firefox/Add-ons teams are killing extension development.  So I stopped actively working on sepsis a couple months ago, and it's effectively dead for now, too.  :/
You need to log in before you can comment on or make changes to this bug.