Closed Bug 688423 Opened 9 years ago Closed 8 years ago

Virtual Keyboard is automatically dismissed from awesomescreen when opening a new tab

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED WORKSFORME
Tracking Status
firefox9 --- unaffected
firefox10 --- affected

People

(Reporter: csuciu, Assigned: ehsan)

References

Details

(Keywords: inputmethod, regression, Whiteboard: [vkb])

Mozilla/5.0 (Android;Linux armv7l;rv:9.0a1)Gecko/20110922
Firefox/9.0a1 Fennec/9.0a1
Device: HTC Desire
OS: Android 2.2

Steps:
1. Start nightly
2. Open left panel and tap on "new tab"

Expected: Awesomescreen opens and VKB is displayed

Actual: VKB is displayed for 1 sec in awesomescreen, then disappears. 

Note: Tapping on the URL bar in awesomescreen does not bring up the VKB.
Also occurs with the TabletUI.
1. click in the URL bar
2. click on the new tab

Actual : VKB dismisses
Expected: VKB does not dismiss

Mozilla/5.0 (Android; Linux armv7I; rv9.0a1) Gecko/20110922 Firefox/9.0a1 Fennec/9.0a1
Device: Toshiba Thrive
OS Android 3.1
I can't reproduce this on Nightly on an SII and Tab 10.1. Was this a regression from a few days ago now fixed? Does it still happen?
This could have been a regression from bug 612128, which landed on 9/21 and was backed out on 9/23.   See bug 688438 for another Android VKB regression caused by 612128.
Blocks: 612128
Duplicate of this bug: 688935
It's quite likely that this is also fixed by my patch in bug 688438.  We should see if it happens again after we reland bug 612128.
Assignee: nobody → ehsan
Summary: VKB is automatically dismissed from awesomescreen when opening a new tab → Virtual Keyboard is automatically dismissed from awesomescreen when opening a new tab
Duplicate of this bug: 696798
This bug reappeared after bug 612128 was re-landed on 10-22.
tracking-fennec: --- → ?
Whiteboard: [vkb]
Version: Trunk → Firefox 10
Matt, can you please point me to the place in the mobile code where the VKB for the awesomebar is triggered after opening a new tab?
Also, is this reproducible on desktop Fennec builds too?  That would help me a lot in debugging this.
(In reply to Ehsan Akhgari [:ehsan] from comment #8)
> Matt, can you please point me to the place in the mobile code where the VKB
> for the awesomebar is triggered after opening a new tab?

The focus() call here triggers the keyboard ("this._edit" is the textbox#urlbar-edit element from browser.xul):
http://hg.mozilla.org/mozilla-central/file/767693e248aa/mobile/chrome/content/browser-ui.js#l991

The NavigationPanelShown event is dispatched from the AwesomeScreen.activePanel setter here:
http://hg.mozilla.org/mozilla-central/file/767693e248aa/mobile/chrome/content/AwesomePanel.js#l97

(In reply to Ehsan Akhgari [:ehsan] from comment #9)
> Also, is this reproducible on desktop Fennec builds too?

I don't know how to test this in desktop Fennec.
I backed out my patches for now as I don't have enough time to investigate this now.  :(
Is this still reproducible?
Product: Fennec → Firefox for Android
Version: Firefox 10 → Trunk
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → VERIFIED
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.