Copy & paste from textarea strips out newlines and 'markup'

VERIFIED DUPLICATE of bug 68166

Status

()

VERIFIED DUPLICATE of bug 68166
18 years ago
18 years ago

People

(Reporter: jlpoutre, Assigned: rods)

Tracking

Trunk
PowerPC
Mac System 8.6
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; N; PPC; en-US; 0.8) Gecko/20010214
BuildID:    2001021408

Copied text from a textarea in Mozilla has all "Markup" removed. More specific:

    * newlines are removed
    * witespace is normalized
    * HTML elements (entered as markup tags) are removed
    * Additionally, Drag & Drop is broken (doesn't work, for Mac at least)



Reproducible: Always
Steps to Reproduce:
1.Copy text from textarea in Mozilla (pre-entered or typed)
2.Paste in different text area OR text editor
3.Verify that newlines, multiple spaces and <elements> are gone.

Actual Results:  Newlines, multiple spaces and <elements> are gone.

Expected Results:  Pasted text "as is"

Some observations:

    * The "normalization" is done after copying (checked by pasting into a plain
text editor)
    * Drag & Drop from the top area to the lower one doesn't work on MacOS 8.6.
    * Dragging to input fields in XUL elements does still work (tested with the
location field on top of the browser window and the search input field in the
left search pane).

Likely the observed behaviour has been introduced on purpose to clean up text
for the most generic copy and paste tasks. Most likely that is not what we want
for text areas.

    * Mozilla Build 2001012204 Apple (MacOS 8.6) was still OK.

Comment 1

18 years ago
See bug 68166 and bug 68795
(Reporter)

Comment 2

18 years ago
One more observation:
* On Linux, the x-server copy and paste routines work as normal (selecting text
and then pressing the middle mouse button over the input field). All lay-out
information, spaces and < > characters are preserved in that case.

* The missing drag & drop behaviour is somewhat complicated - opened bug 68896
to describe this one. More info also on the demonstration URL for this bug.
http://bugzilla.mozilla.org/show_bug.cgi?id=68896
This is a duplicate of bug 68166 ("Copy text from a form textarea to notepad
drops CRLF").  The issues described in this were seen on all platforms, and are
mostly fixed as of the morning of 2001-02-15.  Newlines and HTML tags are no
longer removed, but whitespace is still normalized.

This bug is a consequence of the fixing of bug 56135

*** This bug has been marked as a duplicate of 68166 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

18 years ago
vrfy dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.