Bulk compatibility tool ignored binary XPCOM components in 6.* -> 7.* bump

VERIFIED FIXED in 6.2.5

Status

P1
critical
VERIFIED FIXED
7 years ago
3 years ago

People

(Reporter: jorgev, Assigned: sancus)

Tracking

unspecified
6.2.5

Details

(Whiteboard: [needs review][patch])

(Reporter)

Description

7 years ago
We have received notifications from 2 add-on developers (WebRunner and Input Language Assistant) that say that their add-ons were incorrectly upgraded in the latest compatibility bump.

They both have binary XPCOM components in them, which is something the compatibility tool should be checking for, and I thought worked correctly in previous compatibility bumps.

We need this fixed ASAP. We are planning a 7 -> 8 bump for next week and a 8 -> 9 bump for the following week.
From a quick look at the thunderbird log [https://addons.mozilla.org/z/en-US/admin/email_preview/validation_job-39-success.csv] and seeing an addon on it (FireTray - which I recognised as containing a XPCOM binary) I'd guess the Thunderbird run was incorrect also.
That's a surprise, because I believe that Lightning was detected as not compatible - unless there was something else that it had been incompatible for. Unfortunately the logs don't tell you the results for the addons, and unless you're the add-on author you can't access the specific results.
(Reporter)

Comment 3

7 years ago
(In reply to Mark Banner (:standard8) from comment #2)
> That's a surprise, because I believe that Lightning was detected as not
> compatible - unless there was something else that it had been incompatible
> for. Unfortunately the logs don't tell you the results for the addons, and
> unless you're the add-on author you can't access the specific results.

I can see Lightning in the failure log, which means it was validated even though it has binary components. You can see the validation link in the log. Here it is: https://addons.mozilla.org/en-US/developers/addon/lightning/validation-result/68848
(In reply to Jorge Villalobos [:jorgev] from comment #3)
> I can see Lightning in the failure log, which means it was validated even
> though it has binary components.

Ah right.

> You can see the validation link in the log.
> Here it is:
> https://addons.mozilla.org/en-US/developers/addon/lightning/validation-result/68848

I get nothing when I try to load that link, even though I'm logged in.
(Assignee)

Comment 5

7 years ago
I can fix this for you guys, I know what the problem is. One sec.
(Assignee)

Updated

7 years ago
Assignee: nobody → sancus
(Assignee)

Comment 6

7 years ago
I have patch for this https://github.com/Sancus/amo-validator/commit/69046421bccd1f0b894296b2335dace7e7eeaa88 that should fix it forever, but I'm not too sure how to write a test for it, or alter the existing test so that it accounts for version strings. I emailed Matt Basta and hopefully he'll respond with some insight over the weekend.
(Reporter)

Updated

7 years ago
Whiteboard: [needs review][patch]

Comment 8

7 years ago
In job #38, add-ons with binary components fail validation as expected. See

https://addons-dev.allizom.org/en-US/developers/addon/dock-progress/validation-result/67969
https://addons-dev.allizom.org/en-US/developers/addon/snagit-autoscroll-helper/validation-result/68658

We filed bug 690435

NOTE: I haven't verified all the failures. I just picked a few samples.
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.