Closed Bug 689049 Opened 9 years ago Closed 9 years ago

[build failed] win64-jemalloc build failed after Bug 677501

Categories

(Firefox Build System :: General, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 722933

People

(Reporter: hATrayflood, Unassigned)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:6.0.2) Gecko/20100101 Firefox/6.0.2
Build ID: 20110902133214

Steps to reproduce:

I tried to win64-jemalloc build from rev 77515:c722928d8b69, but I failed to build.
following is build log.

make -C mozutils libs
make[6]: Entering directory `/f/mozilla/nightly/comm-central/mozilla/obj-i686-pc-mingw32/memory/mozutils'
/bin/sh /f/mozilla/nightly/comm-central/mozilla/build/msys-perl-wrapper /f/mozilla/nightly/comm-central/mozilla/config/version_win.pl -QUIET 1 -DEPTH ../.. -TOPSRCDIR /f/mozilla/nightly/comm-central/mozilla -OBJDIR . -SRCDIR /f/mozilla/nightly/comm-central/mozilla/memory/mozutils -DISPNAME Nightly -APPVERSION 9.0a1 -MODNAME mozutils
Creating Resource file: module.res
rc.exe  -r -DOSTYPE=\"WINNT6.1\" -DOSARCH=WINNT  -I/f/mozilla/nightly/comm-central/mozilla/memory/mozutils -I. -I../../dist/include -I../../dist/include/nsprpub  -If:/mozilla/nightly/comm-central/mozilla/obj-i686-pc-mingw32/dist/include/nspr -If:/mozilla/nightly/comm-central/mozilla/obj-i686-pc-mingw32/dist/include/nss     -Fomodule.res /f/mozilla/nightly/comm-central/mozilla/obj-i686-pc-mingw32/memory/mozutils/module.rc
Microsoft (R) Windows (R) Resource Compiler Version 6.1.7600.16385

Copyright (C) Microsoft Corporation.  All rights reserved.


f:/mozilla-build/python/python2.6.exe /f/mozilla/nightly/comm-central/mozilla/config/Preprocessor.py -D_CRT_SECURE_NO_WARNINGS=1 -D_CRT_NONSTDC_NO_WARNINGS=1 -DHAVE_SEH_EXCEPTIONS=1 -DHAVE_WINSDKVER_H=1 -DMOZ_MSVC_STL_WRAP__Throw=1 -DWINVER=0x502 -D_WIN32_WINNT=0x502 -D_WIN32_IE=0x0500 -DMOZ_WINSDK_TARGETVER=0x06010000 -DMOZ_NTDDI_WS03=0x05020000 -DMOZ_NTDDI_LONGHORN=0x06000000 -DMOZ_NTDDI_WIN7=0x06010000 -DHAVE_IO_H=1 -DHAVE_SETBUF=1 -DHAVE_ISATTY=1 -DX_DISPLAY_MISSING=1 -DHAVE_64BIT_OS=1 -DMOZILLA_VERSION=\"9.0a1\" -DMOZILLA_VERSION_U=9.0a1 -DHAVE_SNPRINTF=1 -D_WINDOWS=1 -DWIN32=1 -DXP_WIN=1 -DXP_WIN32=1 -DHW_THREADS=1 -DSTDC_HEADERS=1 -DWIN32_LEAN_AND_MEAN=1 -DNO_X11=1 -D_AMD64_=1 -D_WIN64=1 -DD_INO=d_ino -DNS_ALWAYS_INLINE= -DNS_ATTR_MALLOC= -DNS_WARN_UNUSED_RESULT= -DNS_NORETURN= -DMALLOC_H=\<malloc.h\> -DHAVE_FORCEINLINE=1 -DHAVE_LOCALECONV=1 -DNS_ENABLE_TSF=1 -DMOZ_PHOENIX=1 -DMOZ_BUILD_APP=browser -DMOZ_PDF_PRINTING=1 -DMOZ_INSTRUMENT_EVENT_LOOP=1 -DMOZ_DISTRIBUTION_ID=\"org.mozilla\" -DIBMBIDI=1 -DACCESSIBILITY=1 -DNS_PRINTING=1 -DNS_PRINT_PREVIEW=1 -DMOZ_OGG=1 -DMOZ_WEBM=1 -DVPX_X86_ASM=1 -DMOZ_WAVE=1 -DMOZ_SYDNEYAUDIO=1 -DMOZ_MEDIA=1 -DMOZ_VORBIS=1 -DMOZ_XTF=1 -DMOZ_CRASHREPORTER=1 -DMOZ_CRASHREPORTER_ENABLE_PERCENT=100 -DLIBJPEG_TURBO_X64_ASM=1 -DMOZ_SMIL=1 -DMOZ_UPDATER=1 -DMOZ_UPDATE_CHANNEL=default -DMOZ_FEEDS=1 -DMOZ_SAFE_BROWSING=1 -DMOZ_URL_CLASSIFIER=1 -DMOZ_LOGGING=1 -DMOZ_MEMORY_SIZEOF_PTR_2POW=3 -DMOZ_MEMORY=1 -DMOZ_MEMORY_WINDOWS=1 -DHAVE_JEMALLOC_POSIX_MEMALIGN=1 -DHAVE_JEMALLOC_MEMALIGN=1 -DMOZ_OMNIJAR=1 -DMOZ_USER_DIR=\"Mozilla\" -DMOZ_STATIC_JS=1 -DMOZ_TREE_CAIRO=1 -DHAVE_UINT64_T=1 -DMOZ_TREE_PIXMAN=1 -DMOZ_XUL=1 -DMOZ_PROFILELOCKING=1 -DMOZ_RDF=1 -DBUILD_CTYPES=1 -DMOZ_PLACES=1 -DMOZ_SERVICES_SYNC=1 -DMOZ_APP_UA_NAME=\"\" -DMOZ_APP_UA_VERSION=\"9.0a1\" -DMOZ_UA_FIREFOX_VERSION=\"9.0a1\" -DFIREFOX_VERSION=9.0a1 -DMOZ_UA_BUILDID=\"\" -DMOZ_DLL_SUFFIX=\".dll\"  /f/mozilla/nightly/comm-central/mozilla/memory/mozutils/mozutils.def.in > mozutils.def
f:/mozilla-build/python/python2.6.exe /f/mozilla/nightly/comm-central/mozilla/config/pythonpath.py -I../../config /f/mozilla/nightly/comm-central/mozilla/config/expandlibs_exec.py --uselist -- link -NOLOGO -DLL -OUT:mozutils.dll -PDB:mozutils.pdb -SUBSYSTEM:WINDOWS     ./module.res -LARGEADDRESSAWARE -NXCOMPAT -DYNAMICBASE  -DEF:mozutils.def     ../jemalloc/jemalloc.lib  kernel32.lib user32.lib gdi32.lib winmm.lib wsock32.lib advapi32.lib   
LINK : warning LNK4068: /MACHINE の指定がありません。X86 を既定とします。
..\jemalloc\jemalloc.obj : fatal error LNK1112: モジュールのコンピュータの種類 'x64' は対象コンピュータの種類 'X86' と競合しています。
make[6]: *** [mozutils.dll] Error 88
make[6]: Leaving directory `/f/mozilla/nightly/comm-central/mozilla/obj-i686-pc-mingw32/memory/mozutils'
make[5]: *** [libs] Error 2
Blocks: 677501
OS: Windows XP → Windows 7
Product: Firefox → Core
Hardware: x86 → x86_64
this linker error caused by both Bug 677501 and Bug 682788.
but, win64-vc10 pgo build crashes without Bug 682788 now.
Attached patch patch v1Splinter Review
Attachment #562324 - Flags: review?(mh+mozilla)
Depends on: 682788
Comment on attachment 562324 [details] [diff] [review]
patch v1

Review of attachment 562324 [details] [diff] [review]:
-----------------------------------------------------------------

::: memory/mozutils/Makefile.in
@@ +97,5 @@
>  
> +LDFLAGS += -ENTRY:DllMain
> +
> +ifeq (x86_64, $(TARGET_CPU))
> +LDFLAGS += -MACHINE:X64

IIUC, this is required because your patch from bug 682788 makes us use the x86 compiler and cross build. Why would that only be necessary on mozutils and not on any other library? Corollary, why isn't this part of bug 682788?
Comment on attachment 562324 [details] [diff] [review]
patch v1

(resetting r? until there are answers to my questions)
Attachment #562324 - Flags: review?(mh+mozilla)
this was fixed by bug 722933.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 722933
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.