Last Comment Bug 722933 - add -MACHINE option for link.exe
: add -MACHINE option for link.exe
Status: RESOLVED FIXED
[inbound]
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: x86 Windows Vista
: -- normal (vote)
: mozilla13
Assigned To: Makoto Kato [:m_kato]
:
:
Mentors:
: 689049 (view as bug list)
Depends on:
Blocks: 672799 803862
  Show dependency treegraph
 
Reported: 2012-01-31 16:59 PST by Makoto Kato [:m_kato]
Modified: 2012-10-20 10:32 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (4.94 KB, patch)
2012-02-07 00:08 PST, Makoto Kato [:m_kato]
no flags Details | Diff | Splinter Review
fix v2 (6.00 KB, patch)
2012-02-17 00:24 PST, Makoto Kato [:m_kato]
khuey: review+
Details | Diff | Splinter Review

Description Makoto Kato [:m_kato] 2012-01-31 16:59:27 PST
when building dll, link.exe outputs the following warning.

LINK : warning LNK4068: /MACHINE not specified; defaulting to X86


Also...
- 64-bit link.exe bug, we cannot switch to VS2010 for Win64 build, To use 32-bit link.exe for 64-bit build, we require -MACHINE options.
- When we supports Win32/arm build, since arm target is cross compiler only, we must add this options...
Comment 1 Makoto Kato [:m_kato] 2012-02-07 00:08:14 PST
Created attachment 594932 [details] [diff] [review]
fix
Comment 2 Makoto Kato [:m_kato] 2012-02-17 00:24:46 PST
Created attachment 598165 [details] [diff] [review]
fix v2
Comment 4 Makoto Kato [:m_kato] 2012-02-21 23:47:53 PST
*** Bug 689049 has been marked as a duplicate of this bug. ***
Comment 5 Ed Morley [:emorley] 2012-02-22 04:43:13 PST
https://hg.mozilla.org/mozilla-central/rev/6d0f16d85f27

Note You need to log in before you can comment on or make changes to this bug.