Last Comment Bug 689051 - drop the drop shadow on the back button for Windows 7
: drop the drop shadow on the back button for Windows 7
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Theme (show other bugs)
: Trunk
: x86 Windows 7
: -- enhancement (vote)
: Firefox 9
Assigned To: Dão Gottwald [:dao]
:
Mentors:
Depends on: 603790
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-25 13:03 PDT by Asa Dotzler [:asa]
Modified: 2013-11-12 00:57 PST (History)
22 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
side by side view of back button with and without drop shadow (52.93 KB, image/png)
2011-09-25 13:03 PDT, Asa Dotzler [:asa]
no flags Details
patch (1.45 KB, patch)
2011-09-25 23:27 PDT, Dão Gottwald [:dao]
shorlander: review+
Details | Diff | Splinter Review

Description Asa Dotzler [:asa] 2011-09-25 13:03:16 PDT
Created attachment 562321 [details]
side by side view of back button with and without drop shadow

+++ This bug was initially created as a clone of Bug #603790 +++

We removed the drop shadows from most toolbar buttons in bug 603790. There's still a slight shadow effect created by having the bottom borders of the buttons be darker than the top borders. This is nice and looks great.

The one button that didn't get this same treatment is the large circular back button. That button still has a slight drop shadow.

That button is unique in our toolbar in that it's large and round and sort of sits "on top" of the forward button. It might make some "physical" sense for the back button to feel raised up off of the toolbar but I don't think it makes for an ideal visual sense. 

I propose that we fully drop the drop shadow on the back button and rely on the top and bottom border color differences to give it all the raised quality it needs. 

I've attached a screenshot of the current button and the minor modification to it I've made of removing the drop shadow. You can see the two side-by-side at regular size and magnified to see the differences. It's subtle, but I think it's a win.
Comment 1 Peter Henkel [:Terepin] 2011-09-25 13:05:46 PDT
If you ask me, they should be completely flat. But aside that, go for it!
Comment 2 Dão Gottwald [:dao] 2011-09-25 23:27:35 PDT
Created attachment 562364 [details] [diff] [review]
patch
Comment 3 Dão Gottwald [:dao] 2011-09-27 08:17:01 PDT
http://hg.mozilla.org/mozilla-central/rev/dca24d75d9cc
Comment 4 Joe Drew (not getting mail) 2011-09-27 19:58:41 PDT
Dão backed this out because it had a typo that broke the world.
Comment 5 Stephen Horlander [:shorlander] 2011-09-27 20:08:25 PDT
(In reply to Joe Drew (:JOEDREW!) from comment #4)
> Dão backed this out because it had a typo that broke the world.

That was bug 687754 wasn't it?
Comment 6 Frank Yan (:fryn) 2011-09-27 20:09:58 PDT
Yes it was.
Comment 7 Joe Drew (not getting mail) 2011-09-27 20:14:03 PDT
Whoops! Sorry.

Note You need to log in before you can comment on or make changes to this bug.