Closed Bug 638526 Opened 10 years ago Closed 9 years ago

[meta] De-curve GUI to match new tabs curve style

Categories

(Firefox :: Theme, defect)

All
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: Terepin, Unassigned)

References

Details

(Keywords: meta)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b13pre) Gecko/20110303 Firefox/4.0b13pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b13pre) Gecko/20110303 Firefox/4.0b13pre

If UX team really want to keep current style of tabs, rest of GUI need to be adjusted accordingly, as tabs with their style don't fit anywhere in the UI and thus breaking the consistency. Furthermore, I believe this changes don't require beta coverage, so they should land in 4.x.

Bug tree is up to UX.

Reproducible: Always
Blocks: 544820
blocking2.0: --- → ?
Keywords: uiwanted
Version: unspecified → Trunk
Depends on: 603790
Upps, meta bug can't block.
blocking2.0: ? → ---
Keywords: polish
Keywords: polishmeta
This "as designed" and so Invalid.

Peter, your participation on these couple of bugs is not productive. You disagree with a design choice and you're free to disagree but you are abusing the bug system, filing bugs you really don't believe in, because of that disagreement and I won't tolerate that. 

If you'd like to chat about this in email, please write me, but don't make a mess of our bug system. Thanks. (asa@mozilla.org works)
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → INVALID
No longer blocks: 544820
No longer depends on: 603790
Keywords: uiwanted
This is a valid request. Asa, you filed bug 603790 yourself. I don't care if Peter Henkel actually believes in what he files.
Blocks: 544820
Status: RESOLVED → REOPENED
Depends on: 603790
Ever confirmed: true
Resolution: INVALID → ---
Status: REOPENED → NEW
(In reply to comment #3)
> This is a valid request. Asa, you filed bug 603790 yourself. I don't care if
> Peter Henkel actually believes in what he files.

It's not whether he believes what he filed; the logic is nonsensical.
Dao, this bug doesn't offer any value beyond what's already filed. The buttons are already scheduled for an overhaul elsewhere (see my bug and the mock-ups there) and the only other curves that matter, the corners on toolbars of restored windows, are actually better aligned with the new tab style. 

If this bug had come with real suggestions, mock-ups, or a design spec, maybe it'd have value (assuming it wasn't a duplicate) but short of those, it's just a second registration of dislike and that's not useful.

"Fix it" is not a bug report.
Status: NEW → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → INVALID
It's not nonsensical. We've matched border radii before so that they don't look completely random. It's no coincidence that Asa filed bug 603790 and bug 603798 together.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Status: REOPENED → NEW
Depends on: 570279
This bug doesn't offer any value beyond what's already being covered in other bugs. It doesn't contain any actionable suggestions, design specs, mock-ups, or even descriptions of what specifically needs to be changed except "everything else" which just isn't helpful.
Status: NEW → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → INVALID
(In reply to comment #7)
> This bug doesn't offer any value beyond what's already being covered in other
> bugs.

Yes, it's a meta bug. I'm removing you form the CC list, though, since you don't want to track it.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Status: REOPENED → NEW
It's a meta bug that serves no useful purpose. My bugs do not block this thing.
No longer depends on: 603790
Asa, could you please stop it? I consider this a valid tracking bug, this should be enough.
Depends on: 603790
You want this bug to track one other bug, my bug. Why not just cc yourself on my bug, Dao?
It's not clear how your bug will turn out, specifically, whether it will make all curves harmonic. Time will tell.
So maybe there need to be two bugs about adjusting radii in our GUI, but even two bugs don't require a tracking bug of a tracking bug, especially underneath a top level tracker that was version specific and is going to change for upcoming releases.
(In reply to comment #5)
> it's just a second registration of dislike and that's not useful.

How can be filling a bug, that aims to make exactly same change to the rest of UI, another registration of dislike?
Depends on: 638688
Is this bug intended for Firefox 5?
(In reply to comment #15)
> Is this bug intended for Firefox 5?

This isn't a bug. It's a tracking ticket for other bugs. There is already a planned set of improvements to the Windows theme for Firefox 5 being tracked in other bugs, and in design documents, and in other work that still resides with the design team. If you want to know what's being worked on for Firefox 5, you'll want to find and follow actual bugs.
I just want to know if these changes are intended for Firefox 5+ and not for Firefox 4+.
Depends on: 646419
No longer depends on: 646419
Depends on: 646424
Depends on: 649954
Depends on: 686671
Depends on: 689051
No longer depends on: 689051
Status: NEW → RESOLVED
Closed: 10 years ago9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.