Closed Bug 689152 Opened 10 years ago Closed 10 years ago

Broken feed preview prevents subscribing to any feed

Categories

(SeaMonkey :: Feed Discovery and Preview, defect)

defect
Not set
major

Tracking

(seamonkey2.5+ fixed, seamonkey2.6+ fixed)

RESOLVED FIXED
Tracking Status
seamonkey2.5 + fixed
seamonkey2.6 + fixed

People

(Reporter: wicked, Assigned: Callek)

References

Details

When viewing a RSS feed in the inline preview before subscribing results in a broken preview without any active control or feed contents. This was working in comm-beta build from last week but seems to be broken on comm-central at least since few days ago.

There are few errors in the Error Console but this one seems to be the root error (preventing a nsIFeedWriter object to be instantiated):
--!--
Error: missing } after property list
Source file: jar:file:///omni.jar!/components/FeedWriter.js
Line: 1377, Column: 2
Source code:
  QueryInterface: XPCOMUtils.generateQI([Components.interfaces.nsIFeedWriter, 
--!--

Just before the error line, there's some code related to nsIClassInfo:
--!--
  classID: FEEDWRITER_CID,
  classInfo: XPCOMUtils.generateCI({classID: FEEDWRITER_CID,
                                    contractID: FEEDWRITER_CONTRACTID,
                                    interfaces: [Components.interfaces.nsIFeedWriter],
                                    flags: Components.interfaces.nsIClassInfo.DOM_OBJECT})
--!--
broken patch landed on aurora for 2.5 and trunk, I know what my problem is, so will fix (with rs+=bustage) soon.
Assignee: nobody → bugspam.Callek
Blocks: 682808
http://hg.mozilla.org/comm-central/rev/03bb4b6e57ee
http://hg.mozilla.org/releases/comm-aurora/rev/82bbc61f708b
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.