Show all facets all the time

VERIFIED FIXED in 6.2.6

Status

addons.mozilla.org Graveyard
Search
VERIFIED FIXED
6 years ago
2 years ago

People

(Reporter: krupa, Assigned: jbalogh)

Tracking

unspecified
6.2.6

Details

(URL)

(Reporter)

Description

6 years ago
steps to reproduce:
1. Load https://addons-dev.allizom.org/z/en-us/firefox/search/es?q=firebug
2. Click on 'Works with' from the sidebar and choose 'Windows' or load https://addons-dev.allizom.org/z/en-us/firefox/search/es?q=firebug&platform=windows
3. Click on 'Works with..' option again 

expected behavior:
All the previously available options for Platforms are listed.

actual behavior:
Linux which was previously listed is missing.
(Reporter)

Comment 1

6 years ago
Search sidebar behaves weirdly. For example:
1. Load https://addons-dev.allizom.org/en-US/firefox/search/es?q=test&platform=all&appver=8.0&atype=1
2. Click on 'All platforms' under 'Works with' section

expected behavior: 
'All platforms' expands with a list of available options.

actual behavior:
User cannot choose any other platform option since the list of available options is not made available.
(Reporter)

Updated

6 years ago
Assignee: nobody → cwiemeersch
Jeff, do you have any ideas here? The code for the platform sidebar looks completely fine to me. I am suspicious of the facets. I don't have enough data locally to reproduce this.
(Reporter)

Updated

6 years ago
Duplicate of this bug: 689945
(Assignee)

Comment 4

6 years ago
The legacy behavior of the sidebar is to show only filters that can further affect the current results. So if I filter to Extensions we present all the Extension categories but not Persona categories because I cannot drill down into the current results using Persona categories.

The other way of doing faceting is to show all the applicable facets all the time, so I can switch from filtering by Windows add-ons to Mac add-ons. I'm fine doing it either way. The latter is the default behavior for ES, so it may perform better.
Assignee: cwiemeersch → fligtar
Whiteboard: [ddn]
It sounds like we currently allow multiple depths of refinement, but the interface is only designed to support one level. I don't think we need multiple levels.

In other words, we should fix this bug.
Assignee: fligtar → nobody
Whiteboard: [ddn]
(Assignee)

Updated

6 years ago
Assignee: nobody → jbalogh
Summary: Not all options are available when switching filter options for search results → Show all facets all the time
Target Milestone: 6.2.5 → 6.2.6
(Assignee)

Comment 6

6 years ago
https://github.com/jbalogh/zamboni/commit/e32331b 

(In reply to Justin Scott [:fligtar] from comment #5)
> It sounds like we currently allow multiple depths of refinement, but the
> interface is only designed to support one level. I don't think we need
> multiple levels.

Not quite. When you search for q=fire&tag=webdev we do a text-search for "fire" AND tag=webdev. We do the same thing for facets, so the other tags in the sidebar will be for add-ons matching "fire" with a webdev tag.

The new behavior is to show tags in the sidebar for add-ons matching "fire". The extra tag, platform, etc. filters won't affect the sidebar.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

6 years ago
This looks fixed to me at https://addons-dev.allizom.org/en-US/firefox/search/es?q=test&cat=all&appver=6.0&platform=mac
Status: RESOLVED → VERIFIED
The platforms do not show up here:

https://addons-dev.allizom.org/en-US/firefox/search/es?q=quake&cat=all&appver=6.0&platform=mac
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 9

6 years ago
(In reply to Chris Van Wiemeersch [:cvan] from comment #8)
> The platforms do not show up here:
> 
> https://addons-dev.allizom.org/en-US/firefox/search/
> es?q=quake&cat=all&appver=6.0&platform=mac

They don't show up here either: https://addons-dev.allizom.org/en-US/firefox/search/es?q=quake&cat=all&appver=6.0.

Of all the add-ons matching "quake", none of them have decided to be platform-specific. Therefore there's no platform information to facet, which is the proper and expected behavior.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
I'd like us to be consistent in showing all facets all the time, especially since doing additional searches from the SERP will carry over what the user has chosen for app/platform facets.

So, if Mac is cleared from platforms and I do another search, it may begin showing me incompatible results. But mainly I want us to be consistent, and also ensure that this search ( https://addons-dev.allizom.org/en-US/firefox/search/?q=quake&cat=all&appver=9.0a2&platform=mac ) does not have an empty Works with box when facets are actually being applied.
(Assignee)

Comment 11

6 years ago
(In reply to Justin Scott [:fligtar] from comment #10)
> I'd like us to be consistent in showing all facets all the time, especially
> since doing additional searches from the SERP will carry over what the user
> has chosen for app/platform facets.

Do you want this because there's a bug with carry-over or because it's a good thing? This will make facet filters available that won't affect the results.

Either way, please file new bugs; don't reopen verified bugs for new issues.
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.