Last Comment Bug 689626 - Brief flash of out-of-position content when keyboard opens with OGL layers on Galaxy Tab
: Brief flash of out-of-position content when keyboard opens with OGL layers on...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: mozilla10
Assigned To: Ali Juma [:ajuma]
:
: Milan Sreckovic [:milan]
Mentors:
Depends on:
Blocks: opengl-mobile
  Show dependency treegraph
 
Reported: 2011-09-27 09:45 PDT by Joe Drew (not getting mail)
Modified: 2011-10-14 03:56 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
surfaceChanged shouldn't cause a frame of the previous size to be rendered on Honeycomb (2.03 KB, patch)
2011-10-12 08:07 PDT, Ali Juma [:ajuma]
jmuizelaar: review+
Details | Diff | Splinter Review

Description Joe Drew (not getting mail) 2011-09-27 09:45:08 PDT
This seems the same as bug 621745, but it persists on my Galaxy Tab despite the recent fixes.

Opening and closing the awesomescreen causes a brief flash of out-of-position content; either the texture is drawn too high or too low, depending on whether you're opening or closing the keyboard.
Comment 1 Ali Juma [:ajuma] 2011-10-12 08:07:42 PDT
Created attachment 566532 [details] [diff] [review]
surfaceChanged shouldn't cause a frame of the previous size to be rendered on Honeycomb

In Bug 621745, it was discovered that when a surfaceChanged event occurs, we still need to draw one more frame at the old size since the buffer size only changes after the next eglSwapBuffer.

However, in Honeycomb, the buffer size is changing immediately. So when we draw a frame of the old size, we are either drawing a frame that is too large (e.g. when the keyboard appears) or too small (e.g. when the keyboard disappears).

This patch modifies the behaviour introduced in Bug 621745 so that we only draw a frame of the old size on pre-Honeycomb.
Comment 2 Jeff Muizelaar [:jrmuizel] 2011-10-12 11:35:14 PDT
Comment on attachment 566532 [details] [diff] [review]
surfaceChanged shouldn't cause a frame of the previous size to be rendered on Honeycomb

It would be nice to know what change caused this, but that will at least need to wait til Ice Cream Sandwich.
Comment 4 Ed Morley [:emorley] 2011-10-14 03:56:49 PDT
https://hg.mozilla.org/mozilla-central/rev/46ce491cec60

Note You need to log in before you can comment on or make changes to this bug.