flickr.com says Firefox 10 is an unsupported browser; tells to download e.g. Firefox

RESOLVED FIXED

Status

RESOLVED FIXED
7 years ago
3 years ago

People

(Reporter: hsivonen, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

7 years ago
Steps to reproduce:
 1) Make sure you don't have cookies from flickr.com
 2) In about:config, set general.useragent.override to Mozilla/5.0 (X11; Linux x86_64; rv:9.0) Gecko/20100101 Firefox/9.0
 3) Navigate to any Flickr photo page, e.g. http://www.flickr.com/photos/hsivonen/5887960514/in/photostream
 4) In about:config, set general.useragent.override to Mozilla/5.0 (X11; Linux x86_64; rv:10.0) Gecko/20100101 Firefox/10.0
 5) Reload the Flickr photo page.

Actual results:
When viewing Flickr with the Firefox 9 UA string, there's no notice about your browser being unsupported. When viewing Flickr (for the first time) with the Firefox 10 UA string, there is a notice saying that your browser in unsupported and you should upgrade to the latest version of Firefox (or Chrome, Safari or IE).

Expected results:
No unsupported browser notice with the Firefox 10 UA string.

Comment 1

7 years ago
I'm gonna take a wild guess that Flickr's sniffing script is only looking at the first character after the "Firefox/" part of the UA string. There were a lot of sites that broke for that reason when Flash went to version 10.

Do we have Flickr contacts we can CC here?
This didn't take long :-D
Kev can you help us out here?
Thanks to Chris Heilmann, I've found a contact. They're gonna try to fix it today or tomorrow.

See https://twitter.com/ysaw/status/119069882972250112

Comment 5

7 years ago
We pushed a fix for this today, let me know if this doesn't work. Oh and yes, we did the dumb thing and assumed that there would never be a two digit version number. Bad us.

Comment 6

7 years ago
(In reply to Stephen Woods from comment #5)
> We pushed a fix for this today, let me know if this doesn't work. Oh and
> yes, we did the dumb thing and assumed that there would never be a two digit
> version number. Bad us.

Hah. Are there any more obvious non-future-proof sniffers over there (see bug 410430 and bug 471816 for other examples of very non-future-proof code at Yahoo properties)? Might not be a bad idea to audit the codes :)
(Reporter)

Comment 7

7 years ago
(In reply to Stephen Woods from comment #5)
> We pushed a fix for this today, let me know if this doesn't work.

Thank you. It looks like the fix works.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Updated

7 years ago
Blocks: 691159
No longer blocks: 691159

Updated

6 years ago
Blocks: 813960
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.