searching for local hosts in address bar with hidden http:// prefix

RESOLVED WORKSFORME

Status

()

Firefox
Location Bar
RESOLVED WORKSFORME
6 years ago
3 years ago

People

(Reporter: Jeff, Unassigned)

Tracking

7 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [testday-20120713])

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:7.0) Gecko/20100101 Firefox/7.0
Build ID: 20110922153450

Steps to reproduce:

Visit a site on your local network, such as http://teamspace/xyz. Type www.google.com into the location bar and hit enter. Click on the location bar and start typing "teamspace". When the teamspace/xyz is found, click it or press the down arrow to select it and hit enter.


Actual results:

Took me to a google search for teamspace/xyz


Expected results:

Should have taken me to http://teamspace/xyz
(Reporter)

Comment 1

6 years ago
For anyone else experiencing this problem, you can disable hiding the http:// prefix by going to "about:config" and setting "browser.urlbar.trimURL" to false.

Updated

6 years ago
Blocks: 665580
Hm, when I put foo/bar in the location bar and hit enter, the status panel says "Looking up foo...". Only when that fails I get the google search.
Keywords: qawanted
Summary: searching for addresses in address bar with hidden http URL prefix → searching for local hosts in address bar with hidden http:// prefix
I just started up a local web server, entered localhost/test, correctly got a response from the local server, closed the tab, entered "loc" and selected localhost/test from the autocomplete popup and got the page from the server again, no google search.

Updated

6 years ago
Duplicate of this bug: 693977
I wonder if this may just be a local proxy issue, you may try setting up a PAC (proxy auto config) file to resolve that intranet address to the proper ip.

Updated

5 years ago
Duplicate of this bug: 736233

Comment 7

5 years ago
unable to reproduce this bug :

1) Opened local website on a website on a local server http://localhost/
2) Opened www.google.com in location bar 
3) After that type http://local selected the local website again and pressed enter 

Observed result:
1) It is not taking me to google search.

OS Version : Windows 7 32 bit
Browser version : Aurora 15.0a2 (2012-07-11)
Can't reproduce this report:

OS Version : Linux x86-64
Browser version : Aurora 15.0a2 and Firefox 14.0b12 build1

Any unexpected result.
Whiteboard: [testday-20120713]
wfm.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME

Comment 10

3 years ago
I was about to file a bug for this and can replicate reliably if the path contains spaces.

Paste the following URL into the address bar:
http://localhost/path%20containing%20spaces/to/some/file.html
Wait for it to time out or whatever.
Select the URL bar.
Press enter.


The pruning of http:// from the URL and the lack of a TLD is causing the URL bar to interpret the URL it just visited as a search! Interestingly, if I copy the URL to clipboard and paste into Notepad, it recovers the http:// and %20's all the spaces so there's clearly some logic in place already that can tell this is a URL, not a search.

I often select the URL bar and press enter instead of using the refresh button because it removes the POST, and I often develop on localhost and LAN URLs which are similarly affected if they lack a TLD.

The about:config is a good workaround since trimming the http:// is pointless anyway.
You need to log in before you can comment on or make changes to this bug.