Last Comment Bug 689948 - Fennec won't open again if minimized
: Fennec won't open again if minimized
Status: VERIFIED FIXED
: regression
Product: Fennec Graveyard
Classification: Graveyard
Component: General (show other bugs)
: Trunk
: ARM Android
: -- major (vote)
: Firefox 9
Assigned To: James Willcox (:snorp) (jwillcox@mozilla.com)
:
Mentors:
Depends on:
Blocks: 686992 690260
  Show dependency treegraph
 
Reported: 2011-09-28 07:51 PDT by Catalin Suciu [:csuciu]
Modified: 2013-12-10 10:00 PST (History)
10 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
aLog file (10.34 KB, text/plain)
2011-09-28 07:51 PDT, Catalin Suciu [:csuciu]
no flags Details
nightly crash (62.06 KB, text/plain)
2011-09-28 08:09 PDT, Catalin Suciu [:csuciu]
no flags Details
Bug 689948 - Fix regressions caused by bug 686992 (4.13 KB, patch)
2011-09-28 11:46 PDT, James Willcox (:snorp) (jwillcox@mozilla.com)
blassey.bugs: review+
christian: approval‑mozilla‑aurora+
Details | Diff | Review

Description Catalin Suciu [:csuciu] 2011-09-28 07:51:00 PDT
Created attachment 563069 [details]
aLog file

Mozilla/5.0 (Android;Linux armv7l;rv:10.0a1)Gecko/20110928 Firefox/10.0a1 Fennec/10.0a1
Device: HTC Desire
OS: Android 2.2.

Steps:
1. Install and start Fennec nightly
2. Press the Home key to bring up Android main screen.
4. Tap on Nightly icon to open it again

Expected:
Nightly will open.

Actual:
Nothing happens for aprox. 5 seconds, then the screen turns black. Only the  phone status strip is displayed. The black screen can be dismissed only by pressing the Home key. 
You'll have to kill Nightly and open it again in order to be able to use it.

Occurs: Every time.

Please see the attached log file.
Comment 1 Catalin Suciu [:csuciu] 2011-09-28 08:08:50 PDT
If the black screen is not dismissed for aprox 10 minutes, Nightly will crash.

Please see the "nightly crash" log file.
Comment 2 Catalin Suciu [:csuciu] 2011-09-28 08:09:57 PDT
Created attachment 563075 [details]
nightly crash
Comment 3 Mark Finkle (:mfinkle) (use needinfo?) 2011-09-28 08:15:31 PDT
I also see this on my Galaxy Tab, running Android 2.2 (froyo). I do not see it on my Nexus One, running Android 2.3.4 (gingerbread)
Comment 4 Mark Finkle (:mfinkle) (use needinfo?) 2011-09-28 08:24:40 PDT
More data: This only appears to happen if the current tab is a "local" page. Meaning an about: page or some page that is not running in the child process.
Comment 5 James Willcox (:snorp) (jwillcox@mozilla.com) 2011-09-28 08:26:12 PDT
I can reproduce this on a Droid Pro, running 2.2.  Worryingly, pressing the home screen does not get out of the black screen state and I had to reboot the phone.  Nothing interesting in logcat...
Comment 6 Matt Brubeck (:mbrubeck) 2011-09-28 09:53:13 PDT
This is similar to a previously-fixed bug 664996.
Comment 7 James Willcox (:snorp) (jwillcox@mozilla.com) 2011-09-28 10:28:26 PDT
My patch for bug 686992 seems to have caused this...taking
Comment 8 James Willcox (:snorp) (jwillcox@mozilla.com) 2011-09-28 11:46:32 PDT
Created attachment 563131 [details] [diff] [review]
Bug 689948 - Fix regressions caused by bug 686992

Accidentally removed a call to GeckoAppShell.scheduleRedraw() which
caused a deadlock.  Also, this fixes an issue with uninitialized
member variables in AndroidBridge.
Comment 9 Matt Brubeck (:mbrubeck) 2011-09-28 13:38:36 PDT
Comment on attachment 563131 [details] [diff] [review]
Bug 689948 - Fix regressions caused by bug 686992

Pushed to inbound:
https://hg.mozilla.org/integration/mozilla-inbound/rev/ece3ae642585

Requesting approval-mozilla-aurora for Firefox 9.  This fixes a very serious regression introduced in Firefox 9.  The regression causes Firefox to deadlock reproducibly in common conditions on Android 2.2 and earlier.  The patch is low-risk: It is Android-only, and it only re-orders some code to avoid using unitialized variables and restores a function call that was accidentally removed.
Comment 10 Michael Wu [:mwu] 2011-09-29 01:34:30 PDT
https://hg.mozilla.org/mozilla-central/rev/ece3ae642585
Comment 11 Matt Brubeck (:mbrubeck) 2011-09-29 16:01:07 PDT
Pushed to Aurora for Firefox 9:
https://hg.mozilla.org/releases/mozilla-aurora/rev/532a0a9ed1ee
Comment 12 Carla Nadastean 2011-09-30 06:30:25 PDT
Retested bug with:

Build ID: Mozilla/5.0 (Android;Linux armv7l;rv:10.0a1)Gecko/20110930
Firefox/10.0a1 Fennec/10.0a1
Device: Motorola DROID 2
OS: Android 2.3

and

BUILD ID: Mozilla/5.0 (Android;Linux armv7l;rv:9.0a2)Gecko/20110930
Firefox/9.0a2 Fennec/9.0a2

Bug no longer reproducible. Fennec is opened without any issues after is minimized. 
Verifying bug.

Note You need to log in before you can comment on or make changes to this bug.