Closed Bug 689974 Opened 9 years ago Closed 9 years ago

resizeTo and resizeBy do nothing

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: webmaster, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0) Gecko/20100101 Firefox/6.0
Build ID: 20110811165603

Steps to reproduce:

In version 7.0, click an <a> tag where either onclick or the href is set to resize the window.  For example:

    <a href="javascript:window.resizeTo(800,480);">Resize Window</a>

Other failing scenarios include: resizeTo and any function manipulating innerHeight or innerWidth.

The failure occurs despite ensuring the Allow JavaScript to Size Windows flags are enabled.


Actual results:

Nothing.

Any function calling resizeTo or resizeBy or manipulating innerHeight and innerWidth processes normally.  There simply is no change to the window size.


Expected results:

Behavior should be as it is in 6.0.2.  The window should resize per spec.
Confirmed on Windows XP, Firefox 7.0

Entering "javascript:window.resizeTo(800,400);" without quotes into the URL-Bar does also not work.
This is a deliberate change by bug 565541 so I suspect this one is wontfix.
Added info here:
https://developer.mozilla.org/en/Firefox_7_for_developers#DOM
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → INVALID
Component: General → DOM
OS: Windows 7 → All
Product: Firefox → Core
QA Contact: general → general
Hardware: x86_64 → All
Version: 7 Branch → Trunk
Blocks: 565541
Let me offer a little perspective:

<1> Websites that resize the main window are dubiously designed websites.  Protecting users from such websites -- because contributors here find them annoying -- is draconian.  There are legitimate reasons to resize main windows and apps doing so should not be penalized.

<2> The issue minimally requires correcting the label for the JavaScript options switch to something like "[Allow JavaScript to] Move or resize ***pop-up*** windows".  (I of course would recommend splitting the switch into two.)  At least then the (change in) behavior would be a little better documented.
It's pointless to discuss this here. This decision has been made (bug 565541, it's also pointless to discuss it there).

See https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

you can discuss here:
http://www.mozilla.org/about/forums/#general-development
but ideally *before* the decision is made
But the point <2> is valid. Filed bug 690648.
(In reply to Masatoshi Kimura [:emk] from comment #6)
> But the point <2> is valid. Filed bug 690648.

True, I overlooked it (actually, I didn't read it, sorry!)
Duplicate of this bug: 691726
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.