l10n HG commit access for Selim Şumlu [tr]

RESOLVED FIXED

Status

mozilla.org
Repository Account Requests
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Selim Şumlu, Assigned: ashish)

Tracking

Details

(Whiteboard: ssh-key,form,voucher)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

7 years ago
Created attachment 563341 [details]
Public SSH key for Selim Sumlu

I need HG commit access for Turkish in order to help Rail, who has been committing our translations for a long time but having a pressure of time lately.

Rail and Erkan will vouch for me, and you already have my Committer's Agreement (please see 600511).

Updated

7 years ago
Summary: l10n HG commit access for Selim Şumlu → l10n HG commit access for Selim Şumlu [tr]
Whiteboard: ssh-key,form
+1 for Selim!

Comment 2

7 years ago
+1 from me for Selim too.

Comment 3

7 years ago
Over to IT for hg account creation with scm_l10n bits set. That's a level-1a type-of account.

PS: I'd recommend to use a phrase that explicitly contains the words "I vouch for ...". Vouching is more than supporting a request, you're also taking responsibilities yourself as part of that action.
Assignee: mozillamarcia.knous → server-ops
Whiteboard: ssh-key,form → ssh-key,form,voucher

Comment 4

7 years ago
I (erkan kaplan) vouch for Selim Sumlu.
Please activate his HG commit access.
(Assignee)

Comment 5

7 years ago
Selim - you already have an LDAP account under selim@selimsumlu.com.tr . I will add your ssh keys and setup your access under the same account. Is that alright?
Assignee: server-ops → ashish
Ashish, this is correct, Selim is already our web localizer and has SVN commit rights with this account.
(Assignee)

Comment 7

7 years ago
Added key, enabled hg and scm_l10n.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

7 years ago
Sorry to disturb, but unfortunately I cannot commit via neither Narro nor TortoiseHg.

Note that I've never used Mercurial before and I might be doing something wrong, but I tried reading and trying everything I could find. Looks like by private key is not being accepted.

I've generated the pair using PuTTYgen on Windows, then converted my private key to the OpenSSH RSA2 format. However, it's still not working. What could be the cause of this?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 9

7 years ago
Error output from Narro:

remote: Could not create directory '/var/www/.ssh'.
remote: Failed to add the host to the list of known hosts (/var/www/.ssh/known_hosts).
remote: Permission denied (publickey,gssapi-with-mic).
adding narro/configuration/configuration.narro.local.inc.php
adding narro/includes/narro/plugins/NarroBinaryUnicode.class.php
adding narro/locale/he/narro.mo
adding narro/locale/he/narro.po
adding narro/locale/ht/narro.mo
adding narro/locale/ht/narro.po
adding narro/locale/tr/narro.mo
adding narro/locale/tr/narro.po
adding narro/narro_context_suggest.php
adding narro/narro_project_list.php
adding narro/offline.php
adding narro/run.php
remote: Could not create directory '/var/www/.ssh'.
remote: Failed to add the host to the list of known hosts (/var/www/.ssh/known_hosts).
remote: Permission denied (publickey,gssapi-with-mic).
(Assignee)

Comment 10

7 years ago
Please try again. There was an error with the stored ssh key. Thanks!
(Reporter)

Comment 11

7 years ago
Unfortunately, still not working, Ashish.

Would it help if I generate a completely new pair of keys under Linux?
(Assignee)

Comment 12

7 years ago
Sure, we could try that...
(Reporter)

Comment 13

7 years ago
Created attachment 572476 [details]
Public SSH key for Selim Sumlu

This one is generated in Ubuntu.
Attachment #563341 - Attachment is obsolete: true
(Assignee)

Comment 14

7 years ago
I've updated the key. Please give it a few mins and try again. Thanks!
(Reporter)

Comment 15

7 years ago
Seems to be working. Thanks!
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 16

7 years ago
HG access works perfectly, but it looks like I cannot sign off anything on https://l10n-stage-sj.mozilla.org/shipping/dashboard?locale=tr . "sign off" button is disabled.
Could this be a permission issue or something else?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 17

7 years ago
Probably got lost between the first account attempt and the latter, I added the permissions on the dashboard manually. That was different from the IT tasks here, fwiw.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.