The default bug view has changed. See this FAQ.

handling of boolean prefs in gfxPlatform broken by the PRBool->bool rewrite

RESOLVED FIXED in mozilla10

Status

()

Core
Graphics
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: jfkthame, Assigned: mwu)

Tracking

({regression})

Trunk
mozilla10
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

1.07 KB, patch
jfkthame
: review+
Details | Diff | Splinter Review
(Reporter)

Description

6 years ago
In gfxPlatform, we have code that relied on being able to initialize PRBool variables to a special UNINITIALIZED_VALUE (-1), which lets us defer reading the actual prefs until they're needed. It looks like the rewrite to use bool will break this and make the prefs appear to be true before we've actually read them at all.
(Assignee)

Comment 1

6 years ago
Created attachment 563359 [details] [diff] [review]
Fix

This was actually detected by static analysis but I dropped this fix while I was cleaning up and uploading patches. :(
Assignee: nobody → mwu
Attachment #563359 - Flags: review?(jfkthame)
(Assignee)

Comment 2

6 years ago
Created attachment 563363 [details] [diff] [review]
Fix v2

More cases fixed, switched to PRInt8.
Attachment #563359 - Attachment is obsolete: true
Attachment #563359 - Flags: review?(jfkthame)
Attachment #563363 - Flags: review?(jfkthame)
(Reporter)

Comment 3

6 years ago
Comment on attachment 563363 [details] [diff] [review]
Fix v2

LGTM. Let's hope that's all of them! :)
Attachment #563363 - Flags: review?(jfkthame) → review+
(Assignee)

Comment 4

6 years ago
https://hg.mozilla.org/mozilla-central/rev/a44d328b9f44
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla10

Updated

6 years ago
Depends on: 692450

Updated

6 years ago
No longer depends on: 692450

Updated

6 years ago
Depends on: 696599
(Assignee)

Updated

6 years ago
No longer depends on: 696599
You need to log in before you can comment on or make changes to this bug.