Status

Socorro
General
VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: jberkus, Assigned: lonnen)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Currently, Top Crashes By URL is not part of NewTCBS, and is not getting calculated for betas of the new products.  AFAIK, we have yet to have a complaint about this.  Further, several of the purposes for TCBU are expected to be served by Elastic Search.

Can we make a decision, at this point, on whether or not there will be a NewTCBU?

Comment 1

7 years ago
Not for me to decide - over to Kairo.
Assignee: laura → kairo

Comment 2

7 years ago
I don't have a problem if Top Crashes By URL/Domain/Topsite all go away.

Marcia, chofmann, smooney, juanb: Do you know if anyone on our side really need those?

If the Socorro team doesn't need to care about those, doing other reports might be easier.
Going through those views hasn't been a common scenario for me. If there's a way to search according to that criteria some other way, as suggested in comment #0 - through Elastic Search - then I see no problem in letting them go.

Comment 4

7 years ago
The goal of Top Crashes By URL/Domain/Topsite wasn't to serve "us" (us aas in firefox developers and testers).    

It was/is to inform topsite web developers and administrators about instability problems that they created with content changes that tickle crash bugs in the browser, and enable them to see user feedback on their sites.  The goal should be to get folks like that looking at these reports (including developers of mozilla.org sites), but that will probably require some outreach and education.  we used to have some people at yahoo trained to watch this kind of report many years ago.

figuring a plan to get this kind of report published daily would make sense, but only if combined with some web developer outreach.
(Reporter)

Updated

7 years ago
Blocks: 697197

Comment 5

7 years ago
It would probably be much more useful with a mobile focus now ...

Comment 6

7 years ago
(In reply to Stormy Peters from comment #5)
> It would probably be much more useful with a mobile focus now ...

And why is that?

Comment 7

7 years ago
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #6)
> (In reply to Stormy Peters from comment #5)
> > It would probably be much more useful with a mobile focus now ...
> 
> And why is that?

Because most all web pages seem to look good on the desktop but they are not all really good in the mobile version ... some take so long to load they might as well be crashes. 

That said, I'm not sure the Top Crashes list is the right place to get the data we'd need to reach out to them. And as chofman said, we'd need an outreach program for them ...

Comment 8

7 years ago
(In reply to Stormy Peters from comment #7)
> Because most all web pages seem to look good on the desktop but they are not
> all really good in the mobile version ... some take so long to load they
> might as well be crashes. 

TCBU won't help with that much. It has a list of top crash signatures per domain/site/URL, and you must have a high interest in one of those domains/sites to even look at those reports.

What helps more IMHO is to have URL reports for signatures that turn up in our reports, which we are working on in a different bug.
Component: Socorro → General
Product: Webtools → Socorro

Comment 9

7 years ago
Kairo: can we kill this then, in favor of bug 550538?

Updated

7 years ago
Target Milestone: 2.4 → 2.4.2

Comment 10

7 years ago
(In reply to Laura Thomson :laura from comment #9)
> Kairo: can we kill this then, in favor of bug 550538?

I'd think so. We already are removing links to TCBU in 2.4, AFAIK, if that doesn't cause complaints, I think we should remove it altogether - and bug 550538 should provide the URL analysis we actually need usually.
Looks like we will be able to get rid of this.  The links are gone.  We will wait another month and then get rid of the code.
Target Milestone: 2.4.2 → 2.4.4

Updated

7 years ago
Assignee: kairo → chris.lonnen
Target Milestone: 2.4.4 → 2.5.1
(Assignee)

Comment 12

7 years ago
https://github.com/mozilla/socorro/pull/384

To the reviewer:
I used a lot of grepping and I think I've got everything related to these two reports, and the orphaned files that result from it. I think I've got the bulk of the dead code and dead JS files.

There are also some white space / indentation / style guide fixes. You may need to read the diff to review those.

The biggest risk area for regression is top crash by os code, where I resolved merge conflicts for this pull. Please verify that filtering by OS still works on the topcrasher page.
Status: NEW → ASSIGNED
(Assignee)

Comment 13

7 years ago
r=adrian, merged.

https://github.com/mozilla/socorro/pull/384
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: 2.5.1 → 2.5

Comment 15

7 years ago
Commits pushed to jberkus-master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/ebc46d6b39d15bcb9be42f6bec9b0f21a12da5c1
bug 690462 - purge dead code, tidy up a bit

https://github.com/mozilla/socorro/commit/6d3030b03fd0dc6cc3c204c55c3d2b50fa1f09fa
Merge pull request #384 from Lonnen/690462-tcbu-removal

bug 690462 - purge dead code, tidy up a bit
QA verified on stage TCBU appears to be purged - QA will remove the Selenium tests that relate to TCBU testing.
Status: RESOLVED → VERIFIED
The related automated tests for TCBU and TCBD reports are being removed by this pull request:

https://github.com/mozilla/Socorro-Tests/pull/94
You need to log in before you can comment on or make changes to this bug.